summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2009-07-28 18:43:26 +0000
committerThomas Sachau <tommy@gentoo.org>2009-07-28 18:43:26 +0000
commitd03040c6fb5bb9e84908df5b8fcabb349dd60075 (patch)
treeaa5321d393689a92322aca38ea3a93a5a4d3966d /sys-fs/aufs2/files
parentStable for HPPA (bug #263579). (diff)
downloadhistorical-d03040c6fb5bb9e84908df5b8fcabb349dd60075.tar.gz
historical-d03040c6fb5bb9e84908df5b8fcabb349dd60075.tar.bz2
historical-d03040c6fb5bb9e84908df5b8fcabb349dd60075.zip
Version bump, add support for kernel version 2.6.30
Package-Manager: portage-2.2_rc33-r4/cvs/Linux x86_64
Diffstat (limited to 'sys-fs/aufs2/files')
-rw-r--r--sys-fs/aufs2/files/aufs2-standalone-27.patch241
-rw-r--r--sys-fs/aufs2/files/aufs2-standalone-28.patch (renamed from sys-fs/aufs2/files/aufs2-standalone.patch)29
-rw-r--r--sys-fs/aufs2/files/aufs2-standalone-29.patch29
-rw-r--r--sys-fs/aufs2/files/aufs2-standalone-30.patch232
4 files changed, 495 insertions, 36 deletions
diff --git a/sys-fs/aufs2/files/aufs2-standalone-27.patch b/sys-fs/aufs2/files/aufs2-standalone-27.patch
new file mode 100644
index 000000000000..52a140be38b4
--- /dev/null
+++ b/sys-fs/aufs2/files/aufs2-standalone-27.patch
@@ -0,0 +1,241 @@
+aufs2 standalone patch for linux-2.6.27
+
+diff --git a/fs/Kconfig b/fs/Kconfig
+index abccb5d..b987e5e 100644
+--- a/fs/Kconfig
++++ b/fs/Kconfig
+@@ -1539,6 +1539,8 @@ config UFS_DEBUG
+ Y here. This will result in _many_ additional debugging messages to be
+ written to the system log.
+
++source "fs/aufs/Kconfig"
++
+ endmenu
+
+ menuconfig NETWORK_FILESYSTEMS
+diff --git a/fs/Makefile b/fs/Makefile
+index a1482a5..aa51c5a 100644
+--- a/fs/Makefile
++++ b/fs/Makefile
+@@ -122,3 +122,4 @@ obj-$(CONFIG_HPPFS) += hppfs/
+ obj-$(CONFIG_DEBUG_FS) += debugfs/
+ obj-$(CONFIG_OCFS2_FS) += ocfs2/
+ obj-$(CONFIG_GFS2_FS) += gfs2/
++obj-$(CONFIG_AUFS_FS) += aufs/
+diff --git a/fs/namei.c b/fs/namei.c
+index 4ea63ed..b207821 100644
+--- a/fs/namei.c
++++ b/fs/namei.c
+@@ -354,6 +354,7 @@ int deny_write_access(struct file * file)
+
+ return 0;
+ }
++EXPORT_SYMBOL(deny_write_access);
+
+ /**
+ * path_get - get a reference to a path
+@@ -1241,7 +1242,7 @@ out:
+ * needs parent already locked. Doesn't follow mounts.
+ * SMP-safe.
+ */
+-static struct dentry *lookup_hash(struct nameidata *nd)
++struct dentry *lookup_hash(struct nameidata *nd)
+ {
+ int err;
+
+@@ -1250,8 +1251,9 @@ static struct dentry *lookup_hash(struct nameidata *nd)
+ return ERR_PTR(err);
+ return __lookup_hash(&nd->last, nd->path.dentry, nd);
+ }
++EXPORT_SYMBOL(lookup_hash);
+
+-static int __lookup_one_len(const char *name, struct qstr *this,
++int __lookup_one_len(const char *name, struct qstr *this,
+ struct dentry *base, int len)
+ {
+ unsigned long hash;
+@@ -1272,6 +1274,7 @@ static int __lookup_one_len(const char *name, struct qstr *this,
+ this->hash = end_name_hash(hash);
+ return 0;
+ }
++EXPORT_SYMBOL(__lookup_one_len);
+
+ /**
+ * lookup_one_len - filesystem helper to lookup single pathname component
+diff --git a/fs/namespace.c b/fs/namespace.c
+index 6e283c9..98f56b9 100644
+--- a/fs/namespace.c
++++ b/fs/namespace.c
+@@ -37,6 +37,9 @@
+
+ /* spinlock for vfsmount related operations, inplace of dcache_lock */
+ __cacheline_aligned_in_smp DEFINE_SPINLOCK(vfsmount_lock);
++#ifdef CONFIG_AUFS_EXPORT
++EXPORT_SYMBOL(vfsmount_lock);
++#endif
+
+ static int event;
+ static DEFINE_IDA(mnt_id_ida);
+diff --git a/fs/open.c b/fs/open.c
+index 07da935..b8e9726 100644
+--- a/fs/open.c
++++ b/fs/open.c
+@@ -222,6 +222,7 @@ int do_truncate(struct dentry *dentry, loff_t length, unsigned int time_attrs,
+ mutex_unlock(&dentry->d_inode->i_mutex);
+ return err;
+ }
++EXPORT_SYMBOL(do_truncate);
+
+ static long do_sys_truncate(const char __user *pathname, loff_t length)
+ {
+diff --git a/fs/splice.c b/fs/splice.c
+index a1e701c..48d7e72 100644
+--- a/fs/splice.c
++++ b/fs/splice.c
+@@ -887,8 +887,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
+ /*
+ * Attempt to initiate a splice from pipe to file.
+ */
+-static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+- loff_t *ppos, size_t len, unsigned int flags)
++long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
++ loff_t *ppos, size_t len, unsigned int flags)
+ {
+ int ret;
+
+@@ -907,13 +907,14 @@ static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+
+ return out->f_op->splice_write(pipe, out, ppos, len, flags);
+ }
++EXPORT_SYMBOL(do_splice_from);
+
+ /*
+ * Attempt to initiate a splice from a file to a pipe.
+ */
+-static long do_splice_to(struct file *in, loff_t *ppos,
+- struct pipe_inode_info *pipe, size_t len,
+- unsigned int flags)
++long do_splice_to(struct file *in, loff_t *ppos,
++ struct pipe_inode_info *pipe, size_t len,
++ unsigned int flags)
+ {
+ int ret;
+
+@@ -929,6 +930,7 @@ static long do_splice_to(struct file *in, loff_t *ppos,
+
+ return in->f_op->splice_read(in, ppos, pipe, len, flags);
+ }
++EXPORT_SYMBOL(do_splice_to);
+
+ /**
+ * splice_direct_to_actor - splices data directly between two non-pipes
+diff --git a/fs/super.c b/fs/super.c
+index e931ae9..141853c 100644
+--- a/fs/super.c
++++ b/fs/super.c
+@@ -270,6 +270,7 @@ int fsync_super(struct super_block *sb)
+ __fsync_super(sb);
+ return sync_blockdev(sb->s_bdev);
+ }
++EXPORT_SYMBOL(fsync_super);
+
+ /**
+ * generic_shutdown_super - common helper for ->kill_sb()
+diff --git a/fs/sync.c b/fs/sync.c
+index 2967562..34040d6 100644
+--- a/fs/sync.c
++++ b/fs/sync.c
+@@ -104,6 +104,7 @@ long do_fsync(struct file *file, int datasync)
+ out:
+ return ret;
+ }
++EXPORT_SYMBOL(do_fsync);
+
+ static long __do_fsync(unsigned int fd, int datasync)
+ {
+diff --git a/include/linux/Kbuild b/include/linux/Kbuild
+index b68ec09..22d182c 100644
+--- a/include/linux/Kbuild
++++ b/include/linux/Kbuild
+@@ -34,6 +34,7 @@ header-y += atmppp.h
+ header-y += atmsap.h
+ header-y += atmsvc.h
+ header-y += atm_zatm.h
++header-y += aufs_type.h
+ header-y += auto_fs4.h
+ header-y += ax25.h
+ header-y += b1lli.h
+diff --git a/include/linux/lockdep.h b/include/linux/lockdep.h
+index 331e5f1..606bf6e 100644
+--- a/include/linux/lockdep.h
++++ b/include/linux/lockdep.h
+@@ -58,7 +58,7 @@ enum lock_usage_bit
+ #define LOCKF_USED_IN_IRQ_READ \
+ (LOCKF_USED_IN_HARDIRQ_READ | LOCKF_USED_IN_SOFTIRQ_READ)
+
+-#define MAX_LOCKDEP_SUBCLASSES 8UL
++#define MAX_LOCKDEP_SUBCLASSES 12UL
+
+ /*
+ * Lock-classes are keyed via unique addresses, by embedding the
+diff --git a/include/linux/namei.h b/include/linux/namei.h
+index 68f8c32..5522432 100644
+--- a/include/linux/namei.h
++++ b/include/linux/namei.h
+@@ -71,6 +71,9 @@ extern struct file *lookup_instantiate_filp(struct nameidata *nd, struct dentry
+ extern struct file *nameidata_to_filp(struct nameidata *nd, int flags);
+ extern void release_open_intent(struct nameidata *);
+
++extern struct dentry *lookup_hash(struct nameidata *nd);
++extern int __lookup_one_len(const char *name, struct qstr *this,
++ struct dentry *base, int len);
+ extern struct dentry *lookup_one_len(const char *, struct dentry *, int);
+ extern struct dentry *lookup_one_noperm(const char *, struct dentry *);
+
+diff --git a/include/linux/splice.h b/include/linux/splice.h
+index 528dcb9..5123bc6 100644
+--- a/include/linux/splice.h
++++ b/include/linux/splice.h
+@@ -71,4 +71,10 @@ extern ssize_t splice_to_pipe(struct pipe_inode_info *,
+ extern ssize_t splice_direct_to_actor(struct file *, struct splice_desc *,
+ splice_direct_actor *);
+
++extern long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
++ loff_t *ppos, size_t len, unsigned int flags);
++extern long do_splice_to(struct file *in, loff_t *ppos,
++ struct pipe_inode_info *pipe, size_t len,
++ unsigned int flags);
++
+ #endif
+diff --git a/security/device_cgroup.c b/security/device_cgroup.c
+index 46f2397..00ec611 100644
+--- a/security/device_cgroup.c
++++ b/security/device_cgroup.c
+@@ -537,6 +537,7 @@ acc_check:
+
+ return -EPERM;
+ }
++EXPORT_SYMBOL(devcgroup_inode_permission);
+
+ int devcgroup_inode_mknod(int mode, dev_t dev)
+ {
+diff --git a/security/security.c b/security/security.c
+index 3a4b4f5..4d7882e 100644
+--- a/security/security.c
++++ b/security/security.c
+@@ -425,6 +425,7 @@ int security_inode_readlink(struct dentry *dentry)
+ return 0;
+ return security_ops->inode_readlink(dentry);
+ }
++EXPORT_SYMBOL(security_inode_readlink);
+
+ int security_inode_follow_link(struct dentry *dentry, struct nameidata *nd)
+ {
+@@ -439,6 +440,7 @@ int security_inode_permission(struct inode *inode, int mask)
+ return 0;
+ return security_ops->inode_permission(inode, mask);
+ }
++EXPORT_SYMBOL(security_inode_permission);
+
+ int security_inode_setattr(struct dentry *dentry, struct iattr *attr)
+ {
diff --git a/sys-fs/aufs2/files/aufs2-standalone.patch b/sys-fs/aufs2/files/aufs2-standalone-28.patch
index aacd3760e849..3cb3ad21a1ab 100644
--- a/sys-fs/aufs2/files/aufs2-standalone.patch
+++ b/sys-fs/aufs2/files/aufs2-standalone-28.patch
@@ -41,16 +41,14 @@ index d34e0f9..2779304 100644
/**
* lookup_one_len - filesystem helper to lookup single pathname component
diff --git a/fs/namespace.c b/fs/namespace.c
-index 65b3dc8..2a51243 100644
+index 65b3dc8..39fbbac 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
-@@ -37,6 +37,9 @@
+@@ -37,6 +37,7 @@
/* spinlock for vfsmount related operations, inplace of dcache_lock */
__cacheline_aligned_in_smp DEFINE_SPINLOCK(vfsmount_lock);
-+#ifdef CONFIG_AUFS_EXPORT
+EXPORT_SYMBOL(vfsmount_lock);
-+#endif
static int event;
static DEFINE_IDA(mnt_id_ida);
@@ -131,19 +129,6 @@ index 2967562..34040d6 100644
static long __do_fsync(unsigned int fd, int datasync)
{
-diff --git a/include/linux/lockdep.h b/include/linux/lockdep.h
-index 29aec6e..dfcb13b 100644
---- a/include/linux/lockdep.h
-+++ b/include/linux/lockdep.h
-@@ -58,7 +58,7 @@ enum lock_usage_bit
- #define LOCKF_USED_IN_IRQ_READ \
- (LOCKF_USED_IN_HARDIRQ_READ | LOCKF_USED_IN_SOFTIRQ_READ)
-
--#define MAX_LOCKDEP_SUBCLASSES 8UL
-+#define MAX_LOCKDEP_SUBCLASSES 12UL
-
- /*
- * Lock-classes are keyed via unique addresses, by embedding the
diff --git a/include/linux/namei.h b/include/linux/namei.h
index 99eb803..f6cdf1c 100644
--- a/include/linux/namei.h
@@ -186,7 +171,7 @@ index 5ba7870..8f880c2 100644
int devcgroup_inode_mknod(int mode, dev_t dev)
{
diff --git a/security/security.c b/security/security.c
-index c0acfa7..b8106c5 100644
+index c0acfa7..812ebf4 100644
--- a/security/security.c
+++ b/security/security.c
@@ -434,6 +434,7 @@ int security_inode_readlink(struct dentry *dentry)
@@ -205,3 +190,11 @@ index c0acfa7..b8106c5 100644
int security_inode_setattr(struct dentry *dentry, struct iattr *attr)
{
+@@ -548,6 +550,7 @@ int security_file_permission(struct file *file, int mask)
+ {
+ return security_ops->file_permission(file, mask);
+ }
++EXPORT_SYMBOL(security_file_permission);
+
+ int security_file_alloc(struct file *file)
+ {
diff --git a/sys-fs/aufs2/files/aufs2-standalone-29.patch b/sys-fs/aufs2/files/aufs2-standalone-29.patch
index 63d6900f57bd..fbe1c7ecdb02 100644
--- a/sys-fs/aufs2/files/aufs2-standalone-29.patch
+++ b/sys-fs/aufs2/files/aufs2-standalone-29.patch
@@ -41,16 +41,14 @@ index bbc15c2..e54d1b2 100644
/**
* lookup_one_len - filesystem helper to lookup single pathname component
diff --git a/fs/namespace.c b/fs/namespace.c
-index 06f8e63..b002ec3 100644
+index 06f8e63..f71793e 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
-@@ -37,6 +37,9 @@
+@@ -37,6 +37,7 @@
/* spinlock for vfsmount related operations, inplace of dcache_lock */
__cacheline_aligned_in_smp DEFINE_SPINLOCK(vfsmount_lock);
-+#ifdef CONFIG_AUFS_EXPORT
+EXPORT_SYMBOL(vfsmount_lock);
-+#endif
static int event;
static DEFINE_IDA(mnt_id_ida);
@@ -119,19 +117,6 @@ index 6ce5014..af66b69 100644
/**
* generic_shutdown_super - common helper for ->kill_sb()
-diff --git a/include/linux/lockdep.h b/include/linux/lockdep.h
-index 23bf02f..49e5b47 100644
---- a/include/linux/lockdep.h
-+++ b/include/linux/lockdep.h
-@@ -58,7 +58,7 @@ enum lock_usage_bit
- #define LOCKF_USED_IN_IRQ_READ \
- (LOCKF_USED_IN_HARDIRQ_READ | LOCKF_USED_IN_SOFTIRQ_READ)
-
--#define MAX_LOCKDEP_SUBCLASSES 8UL
-+#define MAX_LOCKDEP_SUBCLASSES 12UL
-
- /*
- * Lock-classes are keyed via unique addresses, by embedding the
diff --git a/include/linux/namei.h b/include/linux/namei.h
index fc2e035..182d43b 100644
--- a/include/linux/namei.h
@@ -174,7 +159,7 @@ index 3aacd0f..b900dc3 100644
int devcgroup_inode_mknod(int mode, dev_t dev)
{
diff --git a/security/security.c b/security/security.c
-index c3586c0..8b0495f 100644
+index c3586c0..9841a3e 100644
--- a/security/security.c
+++ b/security/security.c
@@ -389,6 +389,7 @@ int security_path_mkdir(struct path *path, struct dentry *dentry, int mode)
@@ -249,3 +234,11 @@ index c3586c0..8b0495f 100644
int security_inode_setattr(struct dentry *dentry, struct iattr *attr)
{
+@@ -620,6 +629,7 @@ int security_file_permission(struct file *file, int mask)
+ {
+ return security_ops->file_permission(file, mask);
+ }
++EXPORT_SYMBOL(security_file_permission);
+
+ int security_file_alloc(struct file *file)
+ {
diff --git a/sys-fs/aufs2/files/aufs2-standalone-30.patch b/sys-fs/aufs2/files/aufs2-standalone-30.patch
new file mode 100644
index 000000000000..1702e1fb909d
--- /dev/null
+++ b/sys-fs/aufs2/files/aufs2-standalone-30.patch
@@ -0,0 +1,232 @@
+aufs2 standalone patch for linux-2.6.30
+
+diff --git a/fs/namei.c b/fs/namei.c
+index 967c3db..64a5060 100644
+--- a/fs/namei.c
++++ b/fs/namei.c
+@@ -337,6 +337,7 @@ int deny_write_access(struct file * file)
+
+ return 0;
+ }
++EXPORT_SYMBOL(deny_write_access);
+
+ /**
+ * path_get - get a reference to a path
+@@ -1200,7 +1201,7 @@ out:
+ * needs parent already locked. Doesn't follow mounts.
+ * SMP-safe.
+ */
+-static struct dentry *lookup_hash(struct nameidata *nd)
++struct dentry *lookup_hash(struct nameidata *nd)
+ {
+ int err;
+
+@@ -1209,8 +1210,9 @@ static struct dentry *lookup_hash(struct nameidata *nd)
+ return ERR_PTR(err);
+ return __lookup_hash(&nd->last, nd->path.dentry, nd);
+ }
++EXPORT_SYMBOL(lookup_hash);
+
+-static int __lookup_one_len(const char *name, struct qstr *this,
++int __lookup_one_len(const char *name, struct qstr *this,
+ struct dentry *base, int len)
+ {
+ unsigned long hash;
+@@ -1231,6 +1233,7 @@ static int __lookup_one_len(const char *name, struct qstr *this,
+ this->hash = end_name_hash(hash);
+ return 0;
+ }
++EXPORT_SYMBOL(__lookup_one_len);
+
+ /**
+ * lookup_one_len - filesystem helper to lookup single pathname component
+diff --git a/fs/namespace.c b/fs/namespace.c
+index 134d494..5a6d038 100644
+--- a/fs/namespace.c
++++ b/fs/namespace.c
+@@ -38,6 +38,7 @@
+
+ /* spinlock for vfsmount related operations, inplace of dcache_lock */
+ __cacheline_aligned_in_smp DEFINE_SPINLOCK(vfsmount_lock);
++EXPORT_SYMBOL(vfsmount_lock);
+
+ static int event;
+ static DEFINE_IDA(mnt_id_ida);
+diff --git a/fs/open.c b/fs/open.c
+index bdfbf03..81c39b3 100644
+--- a/fs/open.c
++++ b/fs/open.c
+@@ -221,6 +221,7 @@ int do_truncate(struct dentry *dentry, loff_t length, unsigned int time_attrs,
+ mutex_unlock(&dentry->d_inode->i_mutex);
+ return err;
+ }
++EXPORT_SYMBOL(do_truncate);
+
+ static long do_sys_truncate(const char __user *pathname, loff_t length)
+ {
+diff --git a/fs/splice.c b/fs/splice.c
+index 666953d..fbc3f77 100644
+--- a/fs/splice.c
++++ b/fs/splice.c
+@@ -905,8 +905,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
+ /*
+ * Attempt to initiate a splice from pipe to file.
+ */
+-static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+- loff_t *ppos, size_t len, unsigned int flags)
++long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
++ loff_t *ppos, size_t len, unsigned int flags)
+ {
+ int ret;
+
+@@ -925,13 +925,14 @@ static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+
+ return out->f_op->splice_write(pipe, out, ppos, len, flags);
+ }
++EXPORT_SYMBOL(do_splice_from);
+
+ /*
+ * Attempt to initiate a splice from a file to a pipe.
+ */
+-static long do_splice_to(struct file *in, loff_t *ppos,
+- struct pipe_inode_info *pipe, size_t len,
+- unsigned int flags)
++long do_splice_to(struct file *in, loff_t *ppos,
++ struct pipe_inode_info *pipe, size_t len,
++ unsigned int flags)
+ {
+ int ret;
+
+@@ -947,6 +948,7 @@ static long do_splice_to(struct file *in, loff_t *ppos,
+
+ return in->f_op->splice_read(in, ppos, pipe, len, flags);
+ }
++EXPORT_SYMBOL(do_splice_to);
+
+ /**
+ * splice_direct_to_actor - splices data directly between two non-pipes
+diff --git a/include/linux/namei.h b/include/linux/namei.h
+index 518098f..42a5279 100644
+--- a/include/linux/namei.h
++++ b/include/linux/namei.h
+@@ -74,6 +74,9 @@ extern struct file *lookup_instantiate_filp(struct nameidata *nd, struct dentry
+ extern struct file *nameidata_to_filp(struct nameidata *nd, int flags);
+ extern void release_open_intent(struct nameidata *);
+
++extern struct dentry *lookup_hash(struct nameidata *nd);
++extern int __lookup_one_len(const char *name, struct qstr *this,
++ struct dentry *base, int len);
+ extern struct dentry *lookup_one_len(const char *, struct dentry *, int);
+ extern struct dentry *lookup_one_noperm(const char *, struct dentry *);
+
+diff --git a/include/linux/splice.h b/include/linux/splice.h
+index 5f3faa9..d2f8660 100644
+--- a/include/linux/splice.h
++++ b/include/linux/splice.h
+@@ -83,4 +83,10 @@ extern ssize_t splice_to_pipe(struct pipe_inode_info *,
+ extern ssize_t splice_direct_to_actor(struct file *, struct splice_desc *,
+ splice_direct_actor *);
+
++extern long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
++ loff_t *ppos, size_t len, unsigned int flags);
++extern long do_splice_to(struct file *in, loff_t *ppos,
++ struct pipe_inode_info *pipe, size_t len,
++ unsigned int flags);
++
+ #endif
+diff --git a/security/device_cgroup.c b/security/device_cgroup.c
+index 5fda7df..440e476 100644
+--- a/security/device_cgroup.c
++++ b/security/device_cgroup.c
+@@ -512,6 +512,7 @@ acc_check:
+
+ return -EPERM;
+ }
++EXPORT_SYMBOL(devcgroup_inode_permission);
+
+ int devcgroup_inode_mknod(int mode, dev_t dev)
+ {
+diff --git a/security/security.c b/security/security.c
+index 5284255..ed62ecd 100644
+--- a/security/security.c
++++ b/security/security.c
+@@ -389,6 +389,7 @@ int security_path_mkdir(struct path *path, struct dentry *dentry, int mode)
+ return 0;
+ return security_ops->path_mkdir(path, dentry, mode);
+ }
++EXPORT_SYMBOL(security_path_mkdir);
+
+ int security_path_rmdir(struct path *path, struct dentry *dentry)
+ {
+@@ -396,6 +397,7 @@ int security_path_rmdir(struct path *path, struct dentry *dentry)
+ return 0;
+ return security_ops->path_rmdir(path, dentry);
+ }
++EXPORT_SYMBOL(security_path_rmdir);
+
+ int security_path_unlink(struct path *path, struct dentry *dentry)
+ {
+@@ -403,6 +405,7 @@ int security_path_unlink(struct path *path, struct dentry *dentry)
+ return 0;
+ return security_ops->path_unlink(path, dentry);
+ }
++EXPORT_SYMBOL(security_path_unlink);
+
+ int security_path_symlink(struct path *path, struct dentry *dentry,
+ const char *old_name)
+@@ -411,6 +414,7 @@ int security_path_symlink(struct path *path, struct dentry *dentry,
+ return 0;
+ return security_ops->path_symlink(path, dentry, old_name);
+ }
++EXPORT_SYMBOL(security_path_symlink);
+
+ int security_path_link(struct dentry *old_dentry, struct path *new_dir,
+ struct dentry *new_dentry)
+@@ -419,6 +423,7 @@ int security_path_link(struct dentry *old_dentry, struct path *new_dir,
+ return 0;
+ return security_ops->path_link(old_dentry, new_dir, new_dentry);
+ }
++EXPORT_SYMBOL(security_path_link);
+
+ int security_path_rename(struct path *old_dir, struct dentry *old_dentry,
+ struct path *new_dir, struct dentry *new_dentry)
+@@ -429,6 +434,7 @@ int security_path_rename(struct path *old_dir, struct dentry *old_dentry,
+ return security_ops->path_rename(old_dir, old_dentry, new_dir,
+ new_dentry);
+ }
++EXPORT_SYMBOL(security_path_rename);
+
+ int security_path_truncate(struct path *path, loff_t length,
+ unsigned int time_attrs)
+@@ -437,6 +443,7 @@ int security_path_truncate(struct path *path, loff_t length,
+ return 0;
+ return security_ops->path_truncate(path, length, time_attrs);
+ }
++EXPORT_SYMBOL(security_path_truncate);
+ #endif
+
+ int security_inode_create(struct inode *dir, struct dentry *dentry, int mode)
+@@ -508,6 +515,7 @@ int security_inode_readlink(struct dentry *dentry)
+ return 0;
+ return security_ops->inode_readlink(dentry);
+ }
++EXPORT_SYMBOL(security_inode_readlink);
+
+ int security_inode_follow_link(struct dentry *dentry, struct nameidata *nd)
+ {
+@@ -522,6 +530,7 @@ int security_inode_permission(struct inode *inode, int mask)
+ return 0;
+ return security_ops->inode_permission(inode, mask);
+ }
++EXPORT_SYMBOL(security_inode_permission);
+
+ int security_inode_setattr(struct dentry *dentry, struct iattr *attr)
+ {
+@@ -622,6 +631,7 @@ int security_file_permission(struct file *file, int mask)
+ {
+ return security_ops->file_permission(file, mask);
+ }
++EXPORT_SYMBOL(security_file_permission);
+
+ int security_file_alloc(struct file *file)
+ {