summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-01-08 16:29:26 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-01-08 16:29:26 +0000
commit04cd622a9e777aade77ea1353044ae5ec5f672a4 (patch)
treef9e3615d43a8eed7b9d2e04275620d93a84f59b8 /sys-fs/clamfs/clamfs-1.0.1.ebuild
parentVersion bump (diff)
downloadhistorical-04cd622a9e777aade77ea1353044ae5ec5f672a4.tar.gz
historical-04cd622a9e777aade77ea1353044ae5ec5f672a4.tar.bz2
historical-04cd622a9e777aade77ea1353044ae5ec5f672a4.zip
Initial import, bug #259863.
Package-Manager: portage-2.1.7.16/cvs/Linux x86_64
Diffstat (limited to 'sys-fs/clamfs/clamfs-1.0.1.ebuild')
-rw-r--r--sys-fs/clamfs/clamfs-1.0.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-fs/clamfs/clamfs-1.0.1.ebuild b/sys-fs/clamfs/clamfs-1.0.1.ebuild
new file mode 100644
index 000000000000..80fd6566e603
--- /dev/null
+++ b/sys-fs/clamfs/clamfs-1.0.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/clamfs/clamfs-1.0.1.ebuild,v 1.1 2010/01/08 16:29:26 matsuu Exp $
+
+EAPI="2"
+inherit eutils linux-info
+
+DESCRIPTION="A FUSE-based user-space file system with on-access anti-virus file scanning"
+HOMEPAGE="http://clamfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/boost-1.33
+ sys-fs/fuse
+ dev-cpp/commoncpp2
+ dev-libs/rlog
+ dev-libs/poco"
+RDEPEND="${DEPEND}
+ app-antivirus/clamav"
+
+CONFIG_CHECK="~FUSE_FS"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+
+ insinto /etc/clamfs
+ doins doc/clamfs.xml || die
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN} || die
+ newconfd "${FILESDIR}/${PN}.confd" ${PN} || die
+
+ dodoc AUTHORS ChangeLog NEWS README TODO || die
+}