summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-03-20 13:56:31 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-03-20 13:56:31 +0000
commitd4e4bcab93658ab5d68496ba77f8aeb6c5605b4f (patch)
treeaa6ae7d925baa9b9ec791c0a79ce96fc03630190 /sys-fs/ext2resize/ext2resize-1.1.17-r1.ebuild
parentinherit eutils for epatch; error check (diff)
downloadhistorical-d4e4bcab93658ab5d68496ba77f8aeb6c5605b4f.tar.gz
historical-d4e4bcab93658ab5d68496ba77f8aeb6c5605b4f.tar.bz2
historical-d4e4bcab93658ab5d68496ba77f8aeb6c5605b4f.zip
Added a patch to solve GCC3.3 compilation issues. Closes bug #45147.
Diffstat (limited to 'sys-fs/ext2resize/ext2resize-1.1.17-r1.ebuild')
-rw-r--r--sys-fs/ext2resize/ext2resize-1.1.17-r1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sys-fs/ext2resize/ext2resize-1.1.17-r1.ebuild b/sys-fs/ext2resize/ext2resize-1.1.17-r1.ebuild
index c3ac257c0d4f..92cb71a0748a 100644
--- a/sys-fs/ext2resize/ext2resize-1.1.17-r1.ebuild
+++ b/sys-fs/ext2resize/ext2resize-1.1.17-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext2resize/ext2resize-1.1.17-r1.ebuild,v 1.3 2004/01/23 15:32:58 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext2resize/ext2resize-1.1.17-r1.ebuild,v 1.4 2004/03/20 13:56:31 plasmaroo Exp $
IUSE="static"
@@ -20,6 +20,10 @@ src_compile() {
econf --exec-prefix="${D}/"|| die "Configure failed"
+ # Fix broken source for non-''old'' GCCs
+ sed -e 's/printf(__FUNCTION__ \"\\n\");/printf(\"%s\\n\", __FUNCTION__);/g' -i src/*.c
+ epatch ${FILESDIR}/ext2resize-1.1.17-gcc3.3.patch
+
emake LDFLAGS="${LDFLAGS}"|| die "Make failed"
}
@@ -29,5 +33,4 @@ src_install() {
dosym /sbin/ext2online /usr/sbin/ext2online
dosym /sbin/ext2prepare /usr/sbin/ext2prepare
dosym /sbin/ext2resize /usr/sbin/ext2resize
-
}