summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-01-09 19:23:19 +0000
committerMike Frysinger <vapier@gentoo.org>2013-01-09 19:23:19 +0000
commit12a3ee26021f897c97ee791e886b9117804418a4 (patch)
tree2e2ea734f7c06e98f9c0fc744c07f2a8e891ea58 /sys-fs/fuse-exfat/fuse-exfat-0.9.8-r1.ebuild
parentVersion bump (diff)
downloadhistorical-12a3ee26021f897c97ee791e886b9117804418a4.tar.gz
historical-12a3ee26021f897c97ee791e886b9117804418a4.tar.bz2
historical-12a3ee26021f897c97ee791e886b9117804418a4.zip
Fix cross-compiling -- patch already in upstream.
Package-Manager: portage-2.2.0_alpha144/cvs/Linux x86_64 Manifest-Sign-Key: 0xFB7C4156
Diffstat (limited to 'sys-fs/fuse-exfat/fuse-exfat-0.9.8-r1.ebuild')
-rw-r--r--sys-fs/fuse-exfat/fuse-exfat-0.9.8-r1.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/sys-fs/fuse-exfat/fuse-exfat-0.9.8-r1.ebuild b/sys-fs/fuse-exfat/fuse-exfat-0.9.8-r1.ebuild
index 39d84322686f..5582a14bdad0 100644
--- a/sys-fs/fuse-exfat/fuse-exfat-0.9.8-r1.ebuild
+++ b/sys-fs/fuse-exfat/fuse-exfat-0.9.8-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse-exfat/fuse-exfat-0.9.8-r1.ebuild,v 1.3 2012/12/11 18:26:24 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse-exfat/fuse-exfat-0.9.8-r1.ebuild,v 1.4 2013/01/09 19:23:14 vapier Exp $
EAPI=4
-inherit scons-utils udev toolchain-funcs
+inherit scons-utils udev toolchain-funcs eutils
DESCRIPTION="exFAT filesystem FUSE module"
HOMEPAGE="http://code.google.com/p/exfat/"
@@ -11,16 +11,19 @@ SRC_URI="http://exfat.googlecode.com/files/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~arm ~amd64 ~x86"
IUSE=""
RDEPEND="sys-fs/fuse"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.9.8-build-vars.patch
+}
src_compile() {
- tc-export CC
- escons CCFLAGS="${CFLAGS}" || die
+ tc-export AR CC RANLIB
+ escons CCFLAGS="${CFLAGS}"
}
src_install() {