summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-12-28 02:16:56 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-12-28 02:16:56 +0000
commit68d76e747b10aff22e3663c5314f2817c97a0ea9 (patch)
tree3451e2a7fab7fc94524484ae0e067fbd563b15e9 /sys-fs/quota/quota-3.15.ebuild
parentFix name of submitter for bug (s/Lasage/Lesage/) (diff)
downloadhistorical-68d76e747b10aff22e3663c5314f2817c97a0ea9.tar.gz
historical-68d76e747b10aff22e3663c5314f2817c97a0ea9.tar.bz2
historical-68d76e747b10aff22e3663c5314f2817c97a0ea9.zip
Fix ldap compile bug #203285.
Package-Manager: portage-2.1.4_rc10
Diffstat (limited to 'sys-fs/quota/quota-3.15.ebuild')
-rw-r--r--sys-fs/quota/quota-3.15.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sys-fs/quota/quota-3.15.ebuild b/sys-fs/quota/quota-3.15.ebuild
index 25637ad375f2..94697c0f1258 100644
--- a/sys-fs/quota/quota-3.15.ebuild
+++ b/sys-fs/quota/quota-3.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-3.15.ebuild,v 1.1 2007/12/24 12:00:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-3.15.ebuild,v 1.2 2007/12/28 02:16:56 robbat2 Exp $
inherit eutils flag-o-matic
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
IUSE="nls tcpd ldap rpc"
-RDEPEND="ldap? ( net-nds/openldap )
+RDEPEND="ldap? ( >=net-nds/openldap-2.3.35 )
tcpd? ( sys-apps/tcp-wrappers )
rpc? ( net-nds/portmap )"
DEPEND="${RDEPEND}
@@ -32,7 +32,9 @@ src_unpack() {
# Don't strip binaries (from Fedora)
epatch "${FILESDIR}"/quota-3.06-no-stripping.patch
- append-cppflags -DLDAP_DEPRECATED=1
+ # This was for openldap-2.2 support before,
+ # Now we only support >=2.3
+ append-cppflags -DLDAP_DEPRECATED=0
sed -i -e "s:,LIBS=\"\$saved_LIBS=\":;LIBS=\"\$saved_LIBS\":" configure
}