summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2005-01-25 17:42:24 +0000
committerStefan Schweizer <genstef@gentoo.org>2005-01-25 17:42:24 +0000
commit1b9cb482fc153f9cdccf7d26cbd051c0a3e89c29 (patch)
tree0bfa97e2c80d90def4eea7fb8d43f962dfed7de9 /sys-fs/submount
parentFix header. (diff)
downloadhistorical-1b9cb482fc153f9cdccf7d26cbd051c0a3e89c29.tar.gz
historical-1b9cb482fc153f9cdccf7d26cbd051c0a3e89c29.tar.bz2
historical-1b9cb482fc153f9cdccf7d26cbd051c0a3e89c29.zip
Conversion to linux-mod
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'sys-fs/submount')
-rw-r--r--sys-fs/submount/ChangeLog7
-rw-r--r--sys-fs/submount/Manifest6
-rw-r--r--sys-fs/submount/submount-0.9-r1.ebuild108
-rw-r--r--sys-fs/submount/submount-0.9.ebuild4
4 files changed, 45 insertions, 80 deletions
diff --git a/sys-fs/submount/ChangeLog b/sys-fs/submount/ChangeLog
index 0ed28e6eb99e..b076a67a2da0 100644
--- a/sys-fs/submount/ChangeLog
+++ b/sys-fs/submount/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-fs/submount
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/submount/ChangeLog,v 1.8 2004/10/13 01:06:10 latexer Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/submount/ChangeLog,v 1.9 2005/01/25 17:42:24 genstef Exp $
+
+ 25 Jan 2005; Stefan Schweizer <genstef@gentoo.org> submount-0.9-r1.ebuild:
+ Conversion to linux-mod
12 Oct 2004; <peter@gentoo.org> submount-0.9-r1.ebuild:
Small logic fix to not fail if using a 2.4 kernel.
diff --git a/sys-fs/submount/Manifest b/sys-fs/submount/Manifest
index 45ec6aa470e7..4d9b6e139f72 100644
--- a/sys-fs/submount/Manifest
+++ b/sys-fs/submount/Manifest
@@ -1,6 +1,6 @@
-MD5 6097e401c04aa5d24eccd4a88d52d623 submount-0.9.ebuild 1375
-MD5 a7281f8ef216fedb2c6f81f0dd72485c submount-0.9-r1.ebuild 1758
-MD5 5fadbb689590444f2e7106b8287a4173 ChangeLog 1091
+MD5 a2019677bbd7710dd6d038446a0b5000 submount-0.9.ebuild 1379
+MD5 e2055f61f5559f5fd7d07cba2edeb12c submount-0.9-r1.ebuild 1341
+MD5 ca237dac30fa478282dc8b9a03b81337 ChangeLog 1195
MD5 c3aedbfe00ee1a825a9d5760b4b4271e metadata.xml 316
MD5 f4303204067c19d5a000a8b0eac1213c files/digest-submount-0.9-r1 63
MD5 f4303204067c19d5a000a8b0eac1213c files/digest-submount-0.9 63
diff --git a/sys-fs/submount/submount-0.9-r1.ebuild b/sys-fs/submount/submount-0.9-r1.ebuild
index a5f3391fc0c7..809027249b4a 100644
--- a/sys-fs/submount/submount-0.9-r1.ebuild
+++ b/sys-fs/submount/submount-0.9-r1.ebuild
@@ -1,97 +1,59 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/submount/submount-0.9-r1.ebuild,v 1.2 2004/10/13 01:06:10 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/submount/submount-0.9-r1.ebuild,v 1.3 2005/01/25 17:42:24 genstef Exp $
-inherit eutils kernel-mod
-
-IUSE=""
+inherit linux-mod
DESCRIPTION="Submount is a new attempt to solve the removable media problem for Linux."
HOMEPAGE="http://submount.sourceforge.net/"
-
-DEPEND="virtual/linux-sources"
-
-SLOT="${KV}"
-
+SRC_URI="mirror://sourceforge/${PN}/${PN}-2.4-${PV}.tar.gz
+ mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
KEYWORDS="~x86 ~alpha ~ppc ~sparc ~amd64"
+IUSE=""
-if [ "${KV_MINOR}" == "4" ]
-then
- EXTRA_V="-2.4"
-else
- EXTRA_V=""
- RESTRICT=nouserpriv
-fi
+MODULE_NAMES="subfs(fs:${S}/subfs-${MY_PV})"
+BUILD_PARAMS="KDIR=${KV_DIR}"
+BUILD_TARGETS="default"
-MY_P="${PN}${EXTRA_V}-${PV}"
-S="${WORKDIR}/${MY_P}"
-KMOD_SOURCES="${MY_P}.tar.gz"
+pkg_setup() {
+ linux-mod_pkg_setup
+ if kernel_is 2 4
+ then
+ MY_PV="2.4-${PV}"
+ elif ! use_m
+ then
+ eerror "This version of submount requires a kernel of 2.6.6 or greater"
+ die "Kernel is too old."
+ else
+ MY_PV="${PV}"
+ fi
-SRC_URI="mirror://sourceforge/${PN}/${KMOD_SOURCES}"
+ MY_P="${PN}-${MY_PV}"
+ S="${WORKDIR}/${MY_P}"
+}
-src_unpack()
-{
+src_unpack() {
unpack ${A}
cd ${S}
- kernel-mod_getversion
-
- if [ "${KV_MINOR}" -gt 5 ]
- then
- if [ "${KV_PATCH}" -gt 5 ]
- then
- sed -i "s:SUBDIRS=:M=:" \
- ${S}/subfs${EXTRA_V}-${PV}/Makefile
- else
- eerror "This version of submount requires a kernel of 2.6.6 or greater"
- die "Too old of a kernel found."
- fi
- fi
+ convert_to_m ${S}/subfs-${MY_PV}/Makefile
}
-src_compile ()
-{
- cd ${S}/subfs${EXTRA_V}-${PV}
- set_arch_to_kernel
- emake KDIR=${ROOT}/usr/src/linux || die
- set_arch_to_portage
-
- cd ${S}/submountd${EXTRA_V}-${PV}
- econf \
- --sbindir=/sbin \
- || die "Confugure error"
+src_compile() {
+ cd ${S}/submountd-${MY_PV}
+ econf || die "econf failed"
+ emake || die "emake failed"
- make || die "Make error"
+ linux-mod_src_compile
}
-src_install ()
-{
- local KV_OBJ
- if [ "${KV_MINOR}" -gt 4 ]
- then
- KV_OBJ=ko
- else
- KV_OBJ=o
- fi
-
- cd ${S}/submountd${EXTRA_V}-${PV}
- make install DESTDIR=${D} mandir=/usr/share/man
+src_install() {
+ cd ${S}/submountd-${MY_PV}
+ make install DESTDIR=${D} mandir=/usr/share/man || die "make install failed"
- cd ${S}/subfs${EXTRA_V}-${PV}
-
- insinto /lib/modules/${KV}/fs/subfs
-
- doins subfs.$KV_OBJ
+ linux-mod_src_install
cd ${S}
./rename-docs ${PV}
dodoc README* COPYING INSTALL*
}
-
-pkg_postinst ()
-{
- if [ "${ROOT}" = / ]
- then
- [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
- fi
-}
diff --git a/sys-fs/submount/submount-0.9.ebuild b/sys-fs/submount/submount-0.9.ebuild
index 8533650441c2..5c85eb7c1a59 100644
--- a/sys-fs/submount/submount-0.9.ebuild
+++ b/sys-fs/submount/submount-0.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/submount/submount-0.9.ebuild,v 1.8 2004/09/27 19:48:24 dsd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/submount/submount-0.9.ebuild,v 1.9 2005/01/25 17:42:24 genstef Exp $
inherit kmod