summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-04-27 11:10:56 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-04-27 11:10:56 +0000
commit507a3b6bd452c7538baeeb19e80f4a5dbfc3cd02 (patch)
tree0f3fdb414f4a55640d7c3dd221ecb5d654e28085 /sys-fs/udev/udev-9999.ebuild
parentTweak DESCRIPTION to remove protocol version info to be lazy and avoid keepin... (diff)
downloadhistorical-507a3b6bd452c7538baeeb19e80f4a5dbfc3cd02.tar.gz
historical-507a3b6bd452c7538baeeb19e80f4a5dbfc3cd02.tar.bz2
historical-507a3b6bd452c7538baeeb19e80f4a5dbfc3cd02.zip
Fix parallel make problem with creation of systemd-udevd.8 manpage alias wrt #467346 by Jaroslav Rakhmatoullin
Package-Manager: portage-2.2.0_alpha173/cvs/Linux x86_64 Manifest-Sign-Key: 0x4868F14D
Diffstat (limited to 'sys-fs/udev/udev-9999.ebuild')
-rw-r--r--sys-fs/udev/udev-9999.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/sys-fs/udev/udev-9999.ebuild b/sys-fs/udev/udev-9999.ebuild
index 71f36e0b4e5a..07c80ce6b241 100644
--- a/sys-fs/udev/udev-9999.ebuild
+++ b/sys-fs/udev/udev-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-9999.ebuild,v 1.224 2013/04/19 09:35:40 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-9999.ebuild,v 1.225 2013/04/27 11:10:43 ssuominen Exp $
EAPI=5
@@ -186,8 +186,9 @@ src_prepare() {
sed -i -e '/error.*secure_getenv/s:.*:#define secure_getenv(x) NULL:' src/shared/missing.h || die
fi
- # link udevd(8) to systemd-udevd.service(8) manpage
+ # link udevd(8) and systemd-udevd(8) manpages to systemd-udevd.service(8) manpage
echo '.so systemd-udevd.service.8' > "${T}"/udevd.8
+ echo '.so systemd-udevd.service.8' > "${T}"/systemd-udevd.8
}
src_configure() {
@@ -263,7 +264,6 @@ src_compile() {
mtd_probe
man/udev.7
man/udevadm.8
- man/systemd-udevd.8
man/systemd-udevd.service.8
)
use keymap && targets+=( keymap )
@@ -316,7 +316,7 @@ src_install() {
lib_LTLIBRARIES="${lib_LTLIBRARIES}"
MANPAGES="man/udev.7 man/udevadm.8 \
man/systemd-udevd.service.8"
- MANPAGES_ALIAS="man/systemd-udevd.8"
+ MANPAGES_ALIAS=""
pkgconfiglib_DATA="${pkgconfiglib_DATA}"
INSTALL_DIRS='$(sysconfdir)/udev/rules.d \
$(sysconfdir)/udev/hwdb.d'
@@ -338,6 +338,7 @@ src_install() {
insinto /lib/udev/rules.d
doins "${T}"/40-gentoo.rules
doman "${T}"/udevd.8
+ doman "${T}"/systemd-udevd.8
# install udevadm compatibility symlink
dosym {../bin,sbin}/udevadm