summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Mylchreest <johnm@gentoo.org>2003-10-30 17:10:56 +0000
committerJohn Mylchreest <johnm@gentoo.org>2003-10-30 17:10:56 +0000
commit524e0d603b63c0b78294486bf1396ddf246fcae6 (patch)
tree1f9e03a0538b190310ffc1a4ddc4cf9332beec41 /sys-kernel/gentoo-dev-sources
parentinitial import (diff)
downloadhistorical-524e0d603b63c0b78294486bf1396ddf246fcae6.tar.gz
historical-524e0d603b63c0b78294486bf1396ddf246fcae6.tar.bz2
historical-524e0d603b63c0b78294486bf1396ddf246fcae6.zip
initial import
Diffstat (limited to 'sys-kernel/gentoo-dev-sources')
-rw-r--r--sys-kernel/gentoo-dev-sources/Manifest3
-rw-r--r--sys-kernel/gentoo-dev-sources/files/digest-gentoo-dev-sources-2.6.0_beta92
-rw-r--r--sys-kernel/gentoo-dev-sources/gentoo-dev-sources-2.6.0_beta9.ebuild131
-rw-r--r--sys-kernel/gentoo-dev-sources/metadata.xml24
4 files changed, 159 insertions, 1 deletions
diff --git a/sys-kernel/gentoo-dev-sources/Manifest b/sys-kernel/gentoo-dev-sources/Manifest
index 4234b8815d9c..dbaee5cd836a 100644
--- a/sys-kernel/gentoo-dev-sources/Manifest
+++ b/sys-kernel/gentoo-dev-sources/Manifest
@@ -1,3 +1,4 @@
-MD5 83eaf44ba5c9afe8fe6c2cdc5e83bfba gentoo-dev-sources-2.6.0_beta9.ebuild 3922
+MD5 0bab319ad097891f32ce75c1ae5bc4d0 gentoo-dev-sources-2.6.0_beta9.ebuild 3878
+MD5 f51db8a96f7b055f1eef5ae9cbaf035a ChangeLog 510
MD5 67f88855f6ec6da22268bad74aa10597 metadata.xml 636
MD5 2c930a031439b36d073cdbadc16a5bbc files/digest-gentoo-dev-sources-2.6.0_beta9 142
diff --git a/sys-kernel/gentoo-dev-sources/files/digest-gentoo-dev-sources-2.6.0_beta9 b/sys-kernel/gentoo-dev-sources/files/digest-gentoo-dev-sources-2.6.0_beta9
new file mode 100644
index 000000000000..88c010031688
--- /dev/null
+++ b/sys-kernel/gentoo-dev-sources/files/digest-gentoo-dev-sources-2.6.0_beta9
@@ -0,0 +1,2 @@
+MD5 52eef08a43aa28689213b8ab5674f73b linux-2.6.0-test9.tar.bz2 33226512
+MD5 0f5a2c79ca17e4a89d7b93c4b36ebabb genpatches-2.6-0.3.tar.bz2 18021
diff --git a/sys-kernel/gentoo-dev-sources/gentoo-dev-sources-2.6.0_beta9.ebuild b/sys-kernel/gentoo-dev-sources/gentoo-dev-sources-2.6.0_beta9.ebuild
new file mode 100644
index 000000000000..4fe34cf1809f
--- /dev/null
+++ b/sys-kernel/gentoo-dev-sources/gentoo-dev-sources-2.6.0_beta9.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-dev-sources/gentoo-dev-sources-2.6.0_beta9.ebuild,v 1.1 2003/10/30 17:10:51 johnm Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#Original Kernel Version before Patches
+# eg: 2.6.0-test8
+OKV=${PV/_beta/-test}
+OKV=${OKV/-r*//}
+
+#version of gentoo patchset
+GPV=0.3
+
+[ ${PR} == "r0" ] && EXTRAVERSION="-gentoo" || EXTRAVERSION="-gentoo-${PR}"
+KV=${OKV}${EXTRAVERSION}
+
+ETYPE="sources"
+IUSE="build"
+
+inherit kernel
+
+DESCRIPTION="Full sources for the development branch of the Linux kernel (2.6)"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+SRC_URI="mirror://kernel/linux/kernel/v2.6/linux-${OKV}.tar.bz2
+ mirror://gentoo/distfiles/genpatches-2.6-${GPV}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="${KV}"
+KEYWORDS="-* x86 amd64 ~mips ~hppa ~sparc ~alpha"
+PROVIDE="virtual/linux-sources virtual/alsa"
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 dev-lang/perl
+ sys-devel/make
+ sys-apps/module-init-tools"
+fi
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die "Unable to move source tree to ${KV}."
+ cd ${S}
+
+ # apply gentoo patches
+ epatch ${DISTDIR}/genpatches-2.6-${GPV}.tar.bz2
+
+ #-----
+ ## Current kernel_universal_unpack is broken with 2.6
+ ## using this until the issue has been rectified.
+ #kernel_universal_unpack
+
+ # remove all tilde suffixed files
+ find . -iname "*~" -exec rm {} \;
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ # also fix the EXTRAVERSION
+ mv Makefile Makefile.orig
+ sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+ -e "s:^\(EXTRAVERSION =\).*:\1 -$(echo ${KV} | cut -d- -f2,3,4,5):" \
+ Makefile.orig > Makefile || die # test, remove me if Makefile ok
+ rm Makefile.orig
+
+ cd ${S}/Documentation/DocBook
+ sed -e "s:db2:docbook2:g" Makefile > Makefile.new \
+ && mv Makefile.new Makefile
+ cd ${S}
+
+ if [ ${ETYPE} == "headers" ]
+ then
+ MY_ARCH=${ARCH}
+ unset ${ARCH}
+ make mrproper || die "make mrproper died"
+ ARCH=${MY_ARCH}
+ fi
+}
+
+pkg_install() {
+ ## Using this until kernel_src_unpack works with 2.6
+ #
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R root:root *
+ chmod -R a+r-w+X,u+w *
+
+ cd ${S}
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ if [ -d "${WORKDIR}/${KV}/docs/" ]
+ then
+ for file in $(ls -1 ${WORKDIR}/${KV}/docs/)
+ do
+ echo "XX_${file}*" >> patches.txt
+ cat ${WORKDIR}/${KV}/docs/${file} >> patches.txt
+ done
+ fi
+ if [ -f patches.txt ]; then
+ dodoc patches.txt
+ fi
+ mv ${WORKDIR}/linux* ${D}/usr/src
+ else
+ #linux-headers
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_postinst() {
+ kernel_pkg_postinst
+
+ echo
+ eerror "IMPORTANT:"
+ eerror "ptyfs support has now been dropped from devfs and as a"
+ eerror "result you are now required to compile this support into"
+ eerror "the kernel. You can do so by enabling the following option"
+ eerror " File systems -> Pseudo filesystems -> /dev/pts filesystem."
+ echo
+ eerror "To prevent the problem while uncompressing the kernel image"
+ eerror "you should also enable:"
+ eerror " Input Devices (Input Device Support -> Input Devices),"
+ eerror " Virtual Terminal (Character Devices -> Virtual Terminal),"
+ eerror " vga_console (Graphics Support -> Console... -> VGA Text Console)"
+ eerror " vt_console (Character Devices -> Support for Console...)."
+ echo
+}
diff --git a/sys-kernel/gentoo-dev-sources/metadata.xml b/sys-kernel/gentoo-dev-sources/metadata.xml
new file mode 100644
index 000000000000..d9c9bbeea611
--- /dev/null
+++ b/sys-kernel/gentoo-dev-sources/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x86-kernel</herd>
+<herd>alpha-kernel</herd>
+<herd>hppa-kernel</herd>
+<herd>mips-kernel</herd>
+<herd>ppc-kernel</herd>
+<herd>sparc-kernel</herd>
+
+<maintainer>
+ <email>johnm@gentoo.org</email>
+ <name>John Mylchreest</name>
+</maintainer>
+<maintainer>
+ <email>brad_mssw@gentoo.org</email>
+ <name>Brad House</name>
+</maintainer>
+
+<longdescription>
+These sources are the 2.6 release kernels patched for gentoo.
+They are designed to be the up and coming gentoo-sources-2.6*.
+</longdescription>
+</pkgmetadata>