summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2003-06-09 21:21:40 +0000
committerMichael Imhof <tantive@gentoo.org>2003-06-09 21:21:40 +0000
commitf92143b2e47c552e2cb7efb8ba8cc34b5db9abfc (patch)
tree6c84278137dfef939eb4cb1052a2e11d2c4bf369 /sys-kernel/openmosix-sources
parentBugfix release (diff)
downloadhistorical-f92143b2e47c552e2cb7efb8ba8cc34b5db9abfc.tar.gz
historical-f92143b2e47c552e2cb7efb8ba8cc34b5db9abfc.tar.bz2
historical-f92143b2e47c552e2cb7efb8ba8cc34b5db9abfc.zip
Bugfix release
Diffstat (limited to 'sys-kernel/openmosix-sources')
-rw-r--r--sys-kernel/openmosix-sources/Manifest2
-rw-r--r--sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.20-r62
-rw-r--r--sys-kernel/openmosix-sources/openmosix-sources-2.4.20-r6.ebuild106
3 files changed, 109 insertions, 1 deletions
diff --git a/sys-kernel/openmosix-sources/Manifest b/sys-kernel/openmosix-sources/Manifest
index 97f2f8caabf0..b6dd99373c53 100644
--- a/sys-kernel/openmosix-sources/Manifest
+++ b/sys-kernel/openmosix-sources/Manifest
@@ -1,4 +1,4 @@
-MD5 ce68d102377600c44b97771671fdd0d4 openmosix-sources-2.4.20-r6.ebuild 3198
+MD5 2baf3a70602d45cf08b466989175cb5a openmosix-sources-2.4.20-r6.ebuild 3198
MD5 139536498ac2981d424ae1628d0935fe openmosix-sources-2.4.20-r1.ebuild 3318
MD5 9f1f6507b5b24fe752321906f4835a3d openmosix-sources-2.4.20-r3.ebuild 3198
MD5 3eec695f0481b07db403de0e580062eb openmosix-sources-2.4.20-r5.ebuild 3197
diff --git a/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.20-r6 b/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.20-r6
new file mode 100644
index 000000000000..4300571b7e2a
--- /dev/null
+++ b/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.20-r6
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 7b593d35115e0d3bead25c47353d8999 openMosix-2.4.20-3.gz 305185
diff --git a/sys-kernel/openmosix-sources/openmosix-sources-2.4.20-r6.ebuild b/sys-kernel/openmosix-sources/openmosix-sources-2.4.20-r6.ebuild
new file mode 100644
index 000000000000..13abc7da71d4
--- /dev/null
+++ b/sys-kernel/openmosix-sources/openmosix-sources-2.4.20-r6.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openmosix-sources/openmosix-sources-2.4.20-r6.ebuild,v 1.1 2003/06/09 21:21:22 tantive Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=2.4.20
+[ "${PR}" == "r0" ] && KV=${OKV}-openmosix || KV=${OKV}-openmosix-${PR}
+EXTRAVERSION="`echo ${KV}|sed -e 's:[0-9]\+\.[0-9]\+\.[0-9]\+\(.*\):\1:'`"
+S=${WORKDIR}/linux-${KV}
+ETYPE="sources"
+
+# What's in this kernel?
+
+# INCLUDED:
+# 2.4.20, plus:
+# 2.4.20 openmosix-2.4.20-3
+
+DESCRIPTION="Full sources for the Gentoo openMosix Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 mirror://sourceforge/openmosix/openMosix-2.4.20-3.gz"
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/ http://www.openmosix.org/"
+LICENSE="GPL-2"
+SLOT="${KV}"
+KEYWORDS="x86 -ppc -sparc -alpha"
+
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 dev-lang/perl virtual/modutils sys-devel/make"
+fi
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+ cd ${S}
+ cat ${DISTDIR}/openMosix-2.4.20-3.gz | gzip -d | patch -p1 || die
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+ -e "s:^\(EXTRAVERSION =\).*:\1 ${EXTRAVERSION}:" \
+ Makefile.orig > Makefile || die # test, remove me if Makefile ok
+ rm Makefile.orig
+# rm Makefile~
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #this file is required for other things to build properly, so we autogenerate it
+ make include/linux/version.h || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R root:root *
+ chmod -R a+r-w+X,u+w *
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ if [ ! -e ${ROOT}usr/src/linux ]
+ then
+ rm -f ${ROOT}usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
+ fi
+}