summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryon Roche <kain@gentoo.org>2002-05-05 06:47:41 +0000
committerBryon Roche <kain@gentoo.org>2002-05-05 06:47:41 +0000
commitc4d04a627959f498d637bb905e56be24b83fd3d6 (patch)
tree67b12491568b377c61b5d985329dd376ac731f98 /sys-kernel/ppc-sources
parentmac-on-linux ebuild added (diff)
downloadhistorical-c4d04a627959f498d637bb905e56be24b83fd3d6.tar.gz
historical-c4d04a627959f498d637bb905e56be24b83fd3d6.tar.bz2
historical-c4d04a627959f498d637bb905e56be24b83fd3d6.zip
ebuild fixes + new kernel
Diffstat (limited to 'sys-kernel/ppc-sources')
-rw-r--r--sys-kernel/ppc-sources/ChangeLog19
-rw-r--r--sys-kernel/ppc-sources/files/digest-ppc-sources-2.4.19-r32
-rw-r--r--sys-kernel/ppc-sources/ppc-sources-2.4.19-r3.ebuild126
3 files changed, 139 insertions, 8 deletions
diff --git a/sys-kernel/ppc-sources/ChangeLog b/sys-kernel/ppc-sources/ChangeLog
index dbf8987f76d0..ebe5d7233513 100644
--- a/sys-kernel/ppc-sources/ChangeLog
+++ b/sys-kernel/ppc-sources/ChangeLog
@@ -1,15 +1,18 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Id: ChangeLog,v 1.1 2002/04/27 13:12:31 pvdabeel Exp $
+# $Id: ChangeLog,v 1.2 2002/05/05 06:47:41 kain Exp $
+
+*ppc-sources-2.4.19-r3 <kain@kain.org> :
+
+ Second official ppc kernel release:
+
+ More drivers in the defconfig for the cdrom image have been integrated;
+ We also have the drm-kernel from the ati.2 drivers at gatos.sf.net integrated
+ in. These work better on the TiBook rev2 (I don't know about rev3).
+
+ Fixes also in the ebuild
*ppc-sources-2.4.19 <pvdabeel@gentoo.org> :
First official ppc kernel release
-1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
diff --git a/sys-kernel/ppc-sources/files/digest-ppc-sources-2.4.19-r3 b/sys-kernel/ppc-sources/files/digest-ppc-sources-2.4.19-r3
new file mode 100644
index 000000000000..a9bd824b57cb
--- /dev/null
+++ b/sys-kernel/ppc-sources/files/digest-ppc-sources-2.4.19-r3
@@ -0,0 +1,2 @@
+MD5 ad92859baaa837847b34d842b9f39d38 linux-2.4.18.tar.bz2 24161675
+MD5 dfc47caf0d063319752f88eb37fc4ccd linux-gentoo-ppc-2.4.19-r3.patch.bz2 4779186
diff --git a/sys-kernel/ppc-sources/ppc-sources-2.4.19-r3.ebuild b/sys-kernel/ppc-sources/ppc-sources-2.4.19-r3.ebuild
new file mode 100644
index 000000000000..e828f3c61bcc
--- /dev/null
+++ b/sys-kernel/ppc-sources/ppc-sources-2.4.19-r3.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Kain X <kain@gentoo.org>
+# $Id: ppc-sources-2.4.19-r3.ebuild,v 1.1 2002/05/05 06:47:41 kain Exp $
+
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=2.4.18
+KV=${PVR}
+S=${WORKDIR}/linux-${KV}
+ETYPE="sources"
+
+# What's in this kernel?
+
+# INCLUDED:
+# 2.4.19-pre7-ben0
+# ati.2 Xfree86 4.2.0 DRM
+# Selected pre6aa1 patches:
+# 00_lowlatency-fixes-5
+# 70_xfs-1.1-0
+# 71_xfs-kiobuf-slab-1
+# 72_xfs-O_DIRECT-1
+# 73_xfs-blksize-PAGE_SIZE-1
+# Ani Joshi's rivafb bigendian fixes from YDL: I think these are in benh now
+
+
+DESCRIPTION="Full sources for the Gentoo Linux PPC kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://ftp.sunsite.dk/projects/gentooppc/distfiles/linux-gentoo-ppc-${KV}.patch.bz2"
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+LICENSE="GPL-2"
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
+fi
+
+GENTOOPATCH=${DISTDIR}/linux-gentoo-ppc-${KV}.patch.bz2
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux linux-${KV} || die
+ cd ${S}
+ pwd
+ bzcat ${GENTOOPATCH} | patch -p1 || die # Patch the kernel
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #this file is required for other things to build properly, so we autogenerate it
+ make include/linux/version.h || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+ Makefile.orig >Makefile || die # test, remove me if Makefile ok
+ rm Makefile.orig
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ cd ${S}
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ make dep
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-ppc/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ cd ${ROOT}usr/src/linux-${KV}
+ if [ -e "${ROOT}usr/src/linux/.config" ]
+ then
+ cp "${ROOT}usr/src/linux/.config" .config
+ #The default setting will be selected.
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ make dep
+ else
+ cp "${ROOT}usr/src/linux-${KV}/arch/ppc/defconfig" .config
+ fi
+ #remove /usr/src/linux symlink
+ rm -f ${ROOT}/usr/src/linux
+ #set up a new one
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
+}