summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-12-26 23:43:38 +0000
committerMichael Weber <xmw@gentoo.org>2013-12-26 23:43:38 +0000
commitcb9adcf6983c0602e303c987964595025a26ac62 (patch)
tree36d986e4aa3f9eb1165060ecf1448ed226341b1e /sys-kernel/raspberrypi-sources/raspberrypi-sources-3.12.9999.ebuild
parentAdd epatch_user call to make patch testing easier. (diff)
downloadhistorical-cb9adcf6983c0602e303c987964595025a26ac62.tar.gz
historical-cb9adcf6983c0602e303c987964595025a26ac62.tar.bz2
historical-cb9adcf6983c0602e303c987964595025a26ac62.zip
Add 3.12 slot
Package-Manager: portage-2.2.7/cvs/Linux x86_64 Manifest-Sign-Key: 0x62EEF090
Diffstat (limited to 'sys-kernel/raspberrypi-sources/raspberrypi-sources-3.12.9999.ebuild')
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-3.12.9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-3.12.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-3.12.9999.ebuild
new file mode 100644
index 000000000000..a410af0cfb90
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-3.12.9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/raspberrypi-sources/raspberrypi-sources-3.12.9999.ebuild,v 1.1 2013/12/26 23:43:10 xmw Exp $
+
+EAPI=5
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+EXTRAVERSION="-${PN}/-*"
+inherit kernel-2
+detect_version
+detect_arch
+
+inherit git-2 versionator
+EGIT_REPO_URI=https://github.com/raspberrypi/linux.git
+EGIT_PROJECT="raspberrypi-linux.git"
+EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
+
+DESCRIPTION="Raspberry PI kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+
+KEYWORDS=""
+
+src_unpack() {
+ git-2_src_unpack
+ unpack_set_extraversion
+}