summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2003-01-09 19:53:14 +0000
committerChristian Birchinger <joker@gentoo.org>2003-01-09 19:53:14 +0000
commit195dda37dd5d6320b4d9d75ba459a85d28c3685f (patch)
treec303cab8bf2f4e222008a5c9e5034fa7018a40ab /sys-kernel/sparc-sources
parentmasked again (diff)
downloadhistorical-195dda37dd5d6320b4d9d75ba459a85d28c3685f.tar.gz
historical-195dda37dd5d6320b4d9d75ba459a85d28c3685f.tar.bz2
historical-195dda37dd5d6320b4d9d75ba459a85d28c3685f.zip
Added sparc-sources-2.4.20-r2 which contains additionl netfilter fixes.
Diffstat (limited to 'sys-kernel/sparc-sources')
-rw-r--r--sys-kernel/sparc-sources/ChangeLog9
-rw-r--r--sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.20-r22
-rw-r--r--sys-kernel/sparc-sources/sparc-sources-2.4.20-r2.ebuild46
3 files changed, 56 insertions, 1 deletions
diff --git a/sys-kernel/sparc-sources/ChangeLog b/sys-kernel/sparc-sources/ChangeLog
index 723f6a4730c4..436eeb3a01fd 100644
--- a/sys-kernel/sparc-sources/ChangeLog
+++ b/sys-kernel/sparc-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/sparc-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.9 2003/01/07 14:02:11 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.10 2003/01/09 19:53:14 joker Exp $
+
+*sparc-sources-2.4.20-r2 (09 Jan 2003)
+
+ 09 Jan 2003; Christian Birchinger <joker@gentoo.org>:
+ sparc-sources-2.4.20-r2.ebuild files/digest-sparc-sources-2.4.20-r2 :
+
+ Added a sparc64 netfilter patch
*sparc-sources-2.4.20-r1 (07 Jan 2003)
diff --git a/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.20-r2 b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.20-r2
new file mode 100644
index 000000000000..2d2ad86d425f
--- /dev/null
+++ b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.20-r2
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 2fd18305cbd0cce78000e93954a26268 patches-2.4.20-r2-sparc.tar.bz2 115627
diff --git a/sys-kernel/sparc-sources/sparc-sources-2.4.20-r2.ebuild b/sys-kernel/sparc-sources/sparc-sources-2.4.20-r2.ebuild
new file mode 100644
index 000000000000..f571c53e952c
--- /dev/null
+++ b/sys-kernel/sparc-sources/sparc-sources-2.4.20-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/sparc-sources-2.4.20-r2.ebuild,v 1.1 2003/01/09 19:53:14 joker Exp $
+
+IUSE="build"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the
+# same.
+KV=${PV}
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+# This kernel also has support for the local USE flag acpi4linux which
+# activates the latest code from acpi.sourceforge.net instead of the
+# very out of date vanilla version
+
+ETYPE="sources"
+
+inherit kernel || die
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/sparc-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://gentoo/patches-${PVR}-sparc.tar.bz2"
+KEYWORDS="~x86 -ppc ~sparc"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ kernel_src_unpack
+}