summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-01-28 03:11:39 +0000
committerMike Gilbert <floppym@gentoo.org>2012-01-28 03:11:39 +0000
commit817050ca45e9eebded0ae747836d48e78000a75e (patch)
treef6dab88ede02b4c9fd69bbd45908847f83e2278e /sys-kernel/spl
parentx86 stable wrt #399847 (diff)
downloadhistorical-817050ca45e9eebded0ae747836d48e78000a75e.tar.gz
historical-817050ca45e9eebded0ae747836d48e78000a75e.tar.bz2
historical-817050ca45e9eebded0ae747836d48e78000a75e.zip
Use autotools-utils for the hell of it.
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64
Diffstat (limited to 'sys-kernel/spl')
-rw-r--r--sys-kernel/spl/ChangeLog5
-rw-r--r--sys-kernel/spl/Manifest10
-rw-r--r--sys-kernel/spl/spl-9999.ebuild27
3 files changed, 19 insertions, 23 deletions
diff --git a/sys-kernel/spl/ChangeLog b/sys-kernel/spl/ChangeLog
index 264a42e3d673..655686bfafd2 100644
--- a/sys-kernel/spl/ChangeLog
+++ b/sys-kernel/spl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-kernel/spl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/spl/ChangeLog,v 1.2 2012/01/27 22:51:06 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/spl/ChangeLog,v 1.3 2012/01/28 03:11:39 floppym Exp $
+
+ 28 Jan 2012; Mike Gilbert <floppym@gentoo.org> spl-9999.ebuild:
+ Use autotools-utils for the hell of it.
27 Jan 2012; Mike Gilbert <floppym@gentoo.org> spl-9999.ebuild:
Call default phase functions for src_compile and src_install.
diff --git a/sys-kernel/spl/Manifest b/sys-kernel/spl/Manifest
index 31832ed9c1b2..0cab5c3af790 100644
--- a/sys-kernel/spl/Manifest
+++ b/sys-kernel/spl/Manifest
@@ -1,13 +1,13 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256
-EBUILD spl-9999.ebuild 792 RMD160 35980def51f636d9dffdf31081eba77cb4ac2aa4 SHA1 0269521813664cf8eb2545fc874c0473837b5036 SHA256 77ea72b487c1e4d8df64739b3565d8c9b8f5b67bc9608cb504a6da8a3fc30209
-MISC ChangeLog 458 RMD160 14269ddb26ea19f50b856776c10a38b7c3208cbb SHA1 f7ca5d992f3d3a7f18fe6c92b165e018a6e06523 SHA256 60cfd4118843be05604c3cbb003d334a33cc68e604c5a6b90493143e96d335e8
+EBUILD spl-9999.ebuild 807 RMD160 f0b2a78752970eff6e7fd8e6056be6493249c7f2 SHA1 db96ed444a9ccf5ac296faafdd9d4d86413e7157 SHA256 1a2c01c4ce98f650fb263ee652af4836e9b6f79cf497601c697db20832ee0af6
+MISC ChangeLog 567 RMD160 2bcbd9dac03153705d6944f445e4cb9c88266029 SHA1 be4bd59e635ed45b18a0444738ef75ca81c0c3cc SHA256 d9defd26fe2e0ff2d985f927b3090315d41925ce6f667cef0bfb049efc2554d7
MISC metadata.xml 374 RMD160 a315b0ad1a5c228cb9406628cbce49afa38f6f18 SHA1 f33356682408f0f0a177702b4e33660a351973be SHA256 ae971627d7a77740537ab8c64cee66385a19127b8e62ad472374c1c940ae24e8
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.17 (GNU/Linux)
-iF4EAREIAAYFAk8jKmAACgkQC77qH+pIQ6R0JwD/fB0+cmGuQjLBOLbefwt/VQ1e
-nqlDj04aD4IxOfBe/0kA/RZ2I2JwytgRrlKwSDS9OZSV9ToEr+A2IdaVhQvZfytU
-=LRoj
+iF4EAREIAAYFAk8jZ3EACgkQC77qH+pIQ6QTlwEAlzYinFFvg63g+rmEoI4wlMIP
+y7lFXC/rqflvhhyMXWAA/R1wIK4maTFg8Jaz/qCF+5PNQZ3+A+M2WMW+Lu5EcWpF
+=ShQQ
-----END PGP SIGNATURE-----
diff --git a/sys-kernel/spl/spl-9999.ebuild b/sys-kernel/spl/spl-9999.ebuild
index ec9aad393b34..e08fd73431b7 100644
--- a/sys-kernel/spl/spl-9999.ebuild
+++ b/sys-kernel/spl/spl-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/spl/spl-9999.ebuild,v 1.2 2012/01/27 22:51:06 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/spl/spl-9999.ebuild,v 1.3 2012/01/28 03:11:39 floppym Exp $
EAPI="4"
-inherit autotools git-2 linux-mod
+inherit git-2 linux-mod autotools-utils
DESCRIPTION="The Solaris Porting Layer is a Linux kernel module which provides many of the Solaris kernel APIs"
HOMEPAGE="http://zfsonlinux.org/"
@@ -18,23 +18,16 @@ IUSE=""
RDEPEND="!sys-devel/spl"
-src_prepare() {
- AT_M4DIR="config"
- eautoreconf
-}
+AT_M4DIR="config"
+AUTOTOOLS_AUTORECONF="1"
+AUTOTOOLS_IN_SOURCE_BUILD="1"
src_configure() {
set_arch_to_kernel
- econf \
- --with-config=all \
- --with-linux="${KV_DIR}" \
+ local myeconfargs=(
+ --with-config=all
+ --with-linux="${KV_DIR}"
--with-linux-obj="${KV_OUT}"
-}
-
-src_compile() {
- default
-}
-
-src_install() {
- default
+ )
+ autotools-utils_src_configure
}