summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Brindle <method@gentoo.org>2003-04-19 19:37:49 +0000
committerJoshua Brindle <method@gentoo.org>2003-04-19 19:37:49 +0000
commit12e822809ca7fd95fe03a18486e15156039a3f50 (patch)
tree9f7df458d8e1c91ea6e3c897c6965bc1d1a1449e /sys-libs/glibc/glibc-2.3.1-r4.ebuild
parentadded die if both sandbox and -fstack-protector are chosen (diff)
downloadhistorical-12e822809ca7fd95fe03a18486e15156039a3f50.tar.gz
historical-12e822809ca7fd95fe03a18486e15156039a3f50.tar.bz2
historical-12e822809ca7fd95fe03a18486e15156039a3f50.zip
added die if both sandbox and -fstack-protector are chosen
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.1-r4.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.1-r4.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/sys-libs/glibc/glibc-2.3.1-r4.ebuild b/sys-libs/glibc/glibc-2.3.1-r4.ebuild
index 9030775b16f4..1a347b4c1a13 100644
--- a/sys-libs/glibc/glibc-2.3.1-r4.ebuild
+++ b/sys-libs/glibc/glibc-2.3.1-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.1-r4.ebuild,v 1.6 2003/04/06 18:49:02 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.1-r4.ebuild,v 1.7 2003/04/19 19:37:34 method Exp $
IUSE="nls pic build"
@@ -73,6 +73,15 @@ pkg_config() {
}
src_unpack() {
+
+ if [ `is-flag "-fstack-protector"` -a `has "sandbox" $FEATURES` ]
+ then
+ eerror "You have both -fstack-protector and sandbox enabled"
+ eerror "glibc will not compile correctly with both of these enabled"
+ eerror "Please disable sandbox by calling emerge with FEATURES=\"-sandbox\""
+ die
+ fi
+
unpack glibc-${PV}.tar.gz || die
# Extract pre-made man pages. Otherwise we need perl, which is a no-no.
mkdir -p ${S}/man; cd ${S}/man