summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-09-08 02:39:01 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-09-08 02:39:01 +0000
commiteae70e6a63d0f504785f16846de535906c4c48e5 (patch)
treeb1bb4cbab5e6ed9b3f753e6100ac7ee21a240f51 /sys-libs/libcap
parentrepoman: header fix (diff)
downloadhistorical-eae70e6a63d0f504785f16846de535906c4c48e5.tar.gz
historical-eae70e6a63d0f504785f16846de535906c4c48e5.tar.bz2
historical-eae70e6a63d0f504785f16846de535906c4c48e5.zip
repoman: header fix; whitespace cleanup
Diffstat (limited to 'sys-libs/libcap')
-rw-r--r--sys-libs/libcap/Manifest6
-rw-r--r--sys-libs/libcap/libcap-1.10-r1.ebuild46
-rw-r--r--sys-libs/libcap/libcap-1.10-r2.ebuild12
-rw-r--r--sys-libs/libcap/libcap-1.10.ebuild46
4 files changed, 55 insertions, 55 deletions
diff --git a/sys-libs/libcap/Manifest b/sys-libs/libcap/Manifest
index 0b02db552d82..f4842423a3c8 100644
--- a/sys-libs/libcap/Manifest
+++ b/sys-libs/libcap/Manifest
@@ -1,7 +1,7 @@
MD5 b28ac686b2594896d11de0899dc08a74 ChangeLog 1138
-MD5 b49510e6faba18c82eb4675c285b39dc libcap-1.10.ebuild 1676
-MD5 c38f289d739c132affcc6386bf5eb78f libcap-1.10-r1.ebuild 1732
-MD5 a456db10573c3b010823ec52de5b3d18 libcap-1.10-r2.ebuild 1641
+MD5 e39142483197954188068ef4d1aa04d3 libcap-1.10.ebuild 1541
+MD5 f48047d308b92702400fc3f9b4ffbd2b libcap-1.10-r1.ebuild 1604
+MD5 ed6226e8fe588205d95160290ad6ea13 libcap-1.10-r2.ebuild 1615
MD5 f55c8f8c068940da50e21f4d4b840422 files/digest-libcap-1.10 63
MD5 8f279ebf325d1b8efb6ad3c3a0d8cb5d files/libcap-1.10-python.patch 3353
MD5 f55c8f8c068940da50e21f4d4b840422 files/digest-libcap-1.10-r1 63
diff --git a/sys-libs/libcap/libcap-1.10-r1.ebuild b/sys-libs/libcap/libcap-1.10-r1.ebuild
index be9dcda463f4..9423892b63a9 100644
--- a/sys-libs/libcap/libcap-1.10-r1.ebuild
+++ b/sys-libs/libcap/libcap-1.10-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/libcap-1.10-r1.ebuild,v 1.2 2003/09/07 00:22:30 msterret Exp $
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/libcap-1.10-r1.ebuild,v 1.3 2003/09/08 02:38:54 msterret Exp $
inherit base
@@ -14,40 +14,40 @@ IUSE="python"
#patch is in recent 2.2 kernels so it works there
DEPEND="virtual/glibc
- virtual/os-headers
- python? ( >=virtual/python-2.2.1 >=dev-lang/swig-1.3.10 )"
+ virtual/os-headers
+ python? ( >=virtual/python-2.2.1 >=dev-lang/swig-1.3.10 )"
RDEPEND="python? ( >=virtual/python-2.2.1 )"
S=${WORKDIR}/${P}
src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/libcap-1.10-python.patch
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/libcap-1.10-python.patch
}
PYTHONVER="`python -V 2>&1 | sed 's/^Python //'|sed 's/\([0-9]*\.[0-9]*\).*/\1/'`"
src_compile() {
- local myflags
+ local myflags
myflags=""
- if [ "`use python`" ]; then
- myflags="${myflags} PYTHON=1 PYTHONMODDIR=/usr/lib/python${PYTHONVER}/site-packages"
- CFLAGS="${CFLAGS} -I/usr/include/python${PYTHONVER}"
- fi
+ if [ "`use python`" ]; then
+ myflags="${myflags} PYTHON=1 PYTHONMODDIR=/usr/lib/python${PYTHONVER}/site-packages"
+ CFLAGS="${CFLAGS} -I/usr/include/python${PYTHONVER}"
+ fi
- # all 64 bit platforms need to get -fPIC
- use alpha || use mips && append-flags -fPIC
+ # all 64 bit platforms need to get -fPIC
+ use alpha || use mips && append-flags -fPIC
- emake COPTFLAG="${CFLAGS}" DEBUG="" ${myflags} || die
+ emake COPTFLAG="${CFLAGS}" DEBUG="" ${myflags} || die
}
src_install() {
- local myflags
- myflags=""
- if [ "`use python`" ]; then
- myflags="${myflags} PYTHON=1 PYTHONMODDIR=${D}/usr/lib/python${PYTHONVER}/site-packages"
- fi
- make install FAKEROOT="${D}" man_prefix=/usr/share ${myflags} || die
- dodoc CHANGELOG README License pgp.keys.asc doc/capability.notes
+ local myflags
+ myflags=""
+ if [ "`use python`" ]; then
+ myflags="${myflags} PYTHON=1 PYTHONMODDIR=${D}/usr/lib/python${PYTHONVER}/site-packages"
+ fi
+ make install FAKEROOT="${D}" man_prefix=/usr/share ${myflags} || die
+ dodoc CHANGELOG README License pgp.keys.asc doc/capability.notes
}
diff --git a/sys-libs/libcap/libcap-1.10-r2.ebuild b/sys-libs/libcap/libcap-1.10-r2.ebuild
index fc48f034d9c8..a48cf639f52a 100644
--- a/sys-libs/libcap/libcap-1.10-r2.ebuild
+++ b/sys-libs/libcap/libcap-1.10-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/libcap-1.10-r2.ebuild,v 1.5 2003/09/07 00:22:30 msterret Exp $
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/libcap-1.10-r2.ebuild,v 1.6 2003/09/08 02:38:54 msterret Exp $
inherit base
@@ -14,10 +14,10 @@ IUSE="python"
#patch is in recent 2.2 kernels so it works there
DEPEND="virtual/glibc
- virtual/os-headers
- python? ( >=virtual/python-2.2.1 >=dev-lang/swig-1.3.10 )"
+ virtual/os-headers
+ python? ( >=virtual/python-2.2.1 >=dev-lang/swig-1.3.10 )"
RDEPEND="python? ( >=virtual/python-2.2.1 )
- virtual/glibc"
+ virtual/glibc"
S=${WORKDIR}/${P}
diff --git a/sys-libs/libcap/libcap-1.10.ebuild b/sys-libs/libcap/libcap-1.10.ebuild
index 6b08d7ea00b0..e8fc602bef8b 100644
--- a/sys-libs/libcap/libcap-1.10.ebuild
+++ b/sys-libs/libcap/libcap-1.10.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/libcap-1.10.ebuild,v 1.4 2003/09/07 00:22:30 msterret Exp $
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/libcap-1.10.ebuild,v 1.5 2003/09/08 02:38:54 msterret Exp $
inherit base
@@ -14,37 +14,37 @@ IUSE="python"
#patch is in recent 2.2 kernels so it works there
DEPEND="virtual/glibc
- >=virtual/linux-sources-2.2
- python? ( >=virtual/python-2.2.1 >=dev-lang/swig-1.3.10 )"
+ >=virtual/linux-sources-2.2
+ python? ( >=virtual/python-2.2.1 >=dev-lang/swig-1.3.10 )"
RDEPEND=">=virtual/linux-sources-2.2
- python? ( >=virtual/python-2.2.1 )"
+ python? ( >=virtual/python-2.2.1 )"
S=${WORKDIR}/${P}
src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PF}-python.patch
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PF}-python.patch
}
PYTHONVER="`python -V 2>&1 | sed 's/^Python //'|sed 's/\([0-9]*\.[0-9]*\).*/\1/'`"
src_compile() {
- local myflags
- myflags=""
- if [ "`use python`" ]; then
- myflags="${myflags} PYTHON=1 PYTHONMODDIR=/usr/lib/python${PYTHONVER}/site-packages"
- CFLAGS="${CFLAGS} -I/usr/include/python${PYTHONVER}"
- fi
- emake COPTFLAG="${CFLAGS}" DEBUG="" ${myflags} || die
+ local myflags
+ myflags=""
+ if [ "`use python`" ]; then
+ myflags="${myflags} PYTHON=1 PYTHONMODDIR=/usr/lib/python${PYTHONVER}/site-packages"
+ CFLAGS="${CFLAGS} -I/usr/include/python${PYTHONVER}"
+ fi
+ emake COPTFLAG="${CFLAGS}" DEBUG="" ${myflags} || die
}
src_install() {
- local myflags
- myflags=""
- if [ "`use python`" ]; then
- myflags="${myflags} PYTHON=1 PYTHONMODDIR=${D}/usr/lib/python${PYTHONVER}/site-packages"
- fi
- make install FAKEROOT="${D}" man_prefix=/usr/share ${myflags} || die
- dodoc CHANGELOG README License pgp.keys.asc doc/capability.notes
+ local myflags
+ myflags=""
+ if [ "`use python`" ]; then
+ myflags="${myflags} PYTHON=1 PYTHONMODDIR=${D}/usr/lib/python${PYTHONVER}/site-packages"
+ fi
+ make install FAKEROOT="${D}" man_prefix=/usr/share ${myflags} || die
+ dodoc CHANGELOG README License pgp.keys.asc doc/capability.notes
}