summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-30 12:07:55 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-30 12:07:55 +0000
commit03bc6c6e1283f7566696529a9621fe4db0df3c1f (patch)
treec5b56d95516b7539b28aa746420d39757ccf9fa9 /sys-libs/readline
parentreadline dependency update (diff)
downloadhistorical-03bc6c6e1283f7566696529a9621fe4db0df3c1f.tar.gz
historical-03bc6c6e1283f7566696529a9621fe4db0df3c1f.tar.bz2
historical-03bc6c6e1283f7566696529a9621fe4db0df3c1f.zip
version bump
Diffstat (limited to 'sys-libs/readline')
-rw-r--r--sys-libs/readline/ChangeLog9
-rw-r--r--sys-libs/readline/files/digest-readline-4.31
-rw-r--r--sys-libs/readline/readline-4.3.ebuild50
3 files changed, 59 insertions, 1 deletions
diff --git a/sys-libs/readline/ChangeLog b/sys-libs/readline/ChangeLog
index fec2220ea707..0c192d184bf2 100644
--- a/sys-libs/readline/ChangeLog
+++ b/sys-libs/readline/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-libs/readline
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.3 2002/07/16 03:47:31 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.4 2002/08/30 12:07:55 seemant Exp $
+
+*readline-4.3 (30 Aug 2002)
+
+ 30 Aug 2002; Seemant Kulleen <seemant@gentoo.org> readline-4.3.ebuild
+ files/digest-readline-4.3 :
+
+ Version bump -- required by bash-2.05b (USE dependent, of course)
*readline-4.1-r4 (21 Mar 2002)
diff --git a/sys-libs/readline/files/digest-readline-4.3 b/sys-libs/readline/files/digest-readline-4.3
new file mode 100644
index 000000000000..cf6a67a2379a
--- /dev/null
+++ b/sys-libs/readline/files/digest-readline-4.3
@@ -0,0 +1 @@
+MD5 f86f7cb717ab321fe15f1bbcb058c11e readline-4.3.tar.gz 961662
diff --git a/sys-libs/readline/readline-4.3.ebuild b/sys-libs/readline/readline-4.3.ebuild
new file mode 100644
index 000000000000..b14492beb44c
--- /dev/null
+++ b/sys-libs/readline/readline-4.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-4.3.ebuild,v 1.1 2002/08/30 12:07:55 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Another cute console display library"
+SRC_URI="ftp://ftp.gnu.org/gnu/readline/${P}.tar.gz
+ ftp://gatekeeper.dec.com/pub/GNU/readline/${P}.tar.gz"
+HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc sparc64"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+
+src_compile() {
+
+ econf --with-curses || die
+ emake ${MAKEOPTS} || die
+ cd shlib
+ emake ${MAKEOPTS} || die
+
+}
+
+
+src_install() {
+
+ make prefix=${D}/usr mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info install || die
+ cd shlib
+ make prefix=${D}/usr mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info install || die
+
+ cd ..
+
+ dodir /lib
+ mv ${D}/usr/lib/*.so* ${D}/lib
+ dosym libhistory.so.${PV/a/} /lib/libhistory.so
+ dosym libreadline.so.${PV/a/} /lib/libreadline.so
+ # Needed because make install uses ${D} for the link
+ dosym libhistory.so.${PV/a/} /lib/libhistory.so.4
+ dosym libreadline.so.${PV/a/} /lib/libreadline.so.4
+ chmod 755 ${D}/lib/*.${PV/a/}
+
+ dodoc CHANGELOG CHANGES COPYING MANIFEST README USAGE
+ docinto ps
+ dodoc doc/*.ps
+ dohtml -r doc
+}