summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-27 23:27:18 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-27 23:27:18 +0000
commitd9a13f6f44d199c50778d83fc1e9b29beedb6549 (patch)
tree2ff0c6fdefa6fd878e0997f3de8d894e3d904946 /sys-libs
parentInitial import. Fixes #45993. (diff)
downloadhistorical-d9a13f6f44d199c50778d83fc1e9b29beedb6549.tar.gz
historical-d9a13f6f44d199c50778d83fc1e9b29beedb6549.tar.bz2
historical-d9a13f6f44d199c50778d83fc1e9b29beedb6549.zip
arm KEYWORDS
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/slang/ChangeLog6
-rw-r--r--sys-libs/slang/slang-1.4.9.ebuild20
2 files changed, 9 insertions, 17 deletions
diff --git a/sys-libs/slang/ChangeLog b/sys-libs/slang/ChangeLog
index c47ff1b72fec..12209f2ff497 100644
--- a/sys-libs/slang/ChangeLog
+++ b/sys-libs/slang/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/slang
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/ChangeLog,v 1.23 2004/01/22 19:54:08 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/ChangeLog,v 1.24 2004/04/27 23:27:18 vapier Exp $
+
+ 27 Apr 2004; Mike Frysinger <vapier@gentoo.org> slang-1.4.9.ebuild :
+ Mark arm stable and remove the trimming of the gcc/slang.h stuff since
+ this has been fixed in latest gcc's.
22 Jan 2004; Guy Martin <gmsoft@gentoo.org> slang-1.4.9.ebuild :
Marked stable on hppa.
diff --git a/sys-libs/slang/slang-1.4.9.ebuild b/sys-libs/slang/slang-1.4.9.ebuild
index 3987f9421f69..e2658b8d729c 100644
--- a/sys-libs/slang/slang-1.4.9.ebuild
+++ b/sys-libs/slang/slang-1.4.9.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/slang-1.4.9.ebuild,v 1.17 2004/03/02 16:43:47 iggy Exp $
-
-inherit gcc
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/slang-1.4.9.ebuild,v 1.18 2004/04/27 23:27:18 vapier Exp $
DESCRIPTION="Console display library used by most text viewer"
HOMEPAGE="http://space.mit.edu/~davis/slang/"
@@ -10,13 +8,13 @@ SRC_URI="ftp://space.mit.edu/pub/davis/slang/v1.4/${P}.tar.bz2"
LICENSE="GPL-2 | Artistic"
SLOT="0"
-KEYWORDS="x86 ~ppc sparc alpha mips hppa amd64 ia64 ppc64 s390"
+KEYWORDS="x86 ~ppc sparc mips alpha arm hppa amd64 ia64 ppc64 s390"
IUSE="cjk"
DEPEND=">=sys-libs/ncurses-5.2-r2"
src_compile() {
- if [ -n "`use cjk`" ]
+ if use cjk
then
# enable Kanji Support
cp src/sl-feat.h src/sl-feat.h.bak
@@ -33,17 +31,7 @@ src_install() {
( cd ${D}/usr/lib ; chmod 755 libslang.so.* )
# remove the documentation... we want to install it ourselves
rm -rf ${D}/usr/doc
- dodoc COPYING* NEWS README *.txt
+ dodoc NEWS README *.txt
dodoc doc/*.txt doc/internal/*.txt doc/text/*.txt
dohtml doc/*.html
}
-
-pkg_postinst() {
- # ensure gcc uses the most recent slang.h (#16678)
- if [ "`gcc-major-version`" = "3" ]; then
- if [ -f "`gcc-libpath`/include/slang.h" ]; then
- einfo "Removing gcc buffered slang.h to avoid conflicts"
- rm -f `gcc-libpath`/include/slang.h
- fi
- fi
-}