summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-03-04 23:24:54 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-03-04 23:24:54 +0000
commit94ce95e761a09229b641094b22a5ee51b44cec21 (patch)
treee69d2e08322c01a6c5ddfcf48f7382159c3532b0 /sys-process/cronbase/cronbase-0.3.ebuild
parentAdding keyword ~alpha for testing. (diff)
downloadhistorical-94ce95e761a09229b641094b22a5ee51b44cec21.tar.gz
historical-94ce95e761a09229b641094b22a5ee51b44cec21.tar.bz2
historical-94ce95e761a09229b641094b22a5ee51b44cec21.zip
Move sys-apps/cronbase -> sys-process/cronbase
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'sys-process/cronbase/cronbase-0.3.ebuild')
-rw-r--r--sys-process/cronbase/cronbase-0.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-process/cronbase/cronbase-0.3.ebuild b/sys-process/cronbase/cronbase-0.3.ebuild
new file mode 100644
index 000000000000..645489bac78c
--- /dev/null
+++ b/sys-process/cronbase/cronbase-0.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/cronbase/cronbase-0.3.ebuild,v 1.1 2005/03/04 23:24:54 ciaranm Exp $
+
+IUSE=""
+
+DESCRIPTION="base for all cron ebuilds"
+HOMEPAGE="http://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc ppc64 sparc mips alpha arm hppa amd64 ia64 s390"
+
+src_install() {
+ exeinto /usr/sbin
+ newexe ${FILESDIR}/run-crons-${PV} run-crons || die
+
+ diropts -m0750; keepdir /etc/cron.hourly
+ diropts -m0750; keepdir /etc/cron.daily
+ diropts -m0750; keepdir /etc/cron.weekly
+ diropts -m0750; keepdir /etc/cron.monthly
+
+ diropts -m0750 -o root -g cron; keepdir /var/spool/cron
+
+ diropts -m0750; keepdir /var/spool/cron/lastrun
+
+ dodoc ${FILESDIR}/README
+}