summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-07-29 15:56:00 +0000
committerChristian Heim <phreak@gentoo.org>2007-07-29 15:56:00 +0000
commit0fc11780f44d085df158cdbc80a72cfefc2dc63a (patch)
tree3bb44a9286b67fb8e253f39412039a0be152a5d6 /www-apache/mod_auth_mysql/mod_auth_mysql-3.0.0-r2.ebuild
parentMoving net-www/mod_auth_kerb to www-apache/mod_auth_kerb (#81244). (diff)
downloadhistorical-0fc11780f44d085df158cdbc80a72cfefc2dc63a.tar.gz
historical-0fc11780f44d085df158cdbc80a72cfefc2dc63a.tar.bz2
historical-0fc11780f44d085df158cdbc80a72cfefc2dc63a.zip
Moving net-www/mod_auth_mysql to www-apache/mod_auth_mysql (#81244).
Package-Manager: portage-2.1.3_rc9
Diffstat (limited to 'www-apache/mod_auth_mysql/mod_auth_mysql-3.0.0-r2.ebuild')
-rw-r--r--www-apache/mod_auth_mysql/mod_auth_mysql-3.0.0-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/www-apache/mod_auth_mysql/mod_auth_mysql-3.0.0-r2.ebuild b/www-apache/mod_auth_mysql/mod_auth_mysql-3.0.0-r2.ebuild
new file mode 100644
index 000000000000..9aea1bbc6736
--- /dev/null
+++ b/www-apache/mod_auth_mysql/mod_auth_mysql-3.0.0-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_mysql/mod_auth_mysql-3.0.0-r2.ebuild,v 1.1 2007/07/29 15:56:00 phreak Exp $
+
+inherit apache-module eutils
+
+DESCRIPTION="Basic authentication for Apache using a MySQL database."
+HOMEPAGE="http://modauthmysql.sourceforge.net/"
+SRC_URI="mirror://sourceforge/modauthmysql/${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/mysql
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+APXS1_ARGS="-DENABLE=0 -c -I/usr/include/mysql -lmysqlclient -lm -lz ${PN}.c"
+APACHE1_MOD_CONF="12_mod_auth_mysql"
+APACHE1_MOD_DEFINE="AUTH_MYSQL"
+
+APXS2_ARGS="-c -I/usr/include/mysql -lmysqlclient -lm -lz ${PN}.c"
+APACHE2_MOD_CONF="12_mod_auth_mysql"
+APACHE2_MOD_DEFINE="AUTH_MYSQL"
+
+DOCFILES="README"
+
+need_apache
+
+src_unpack() {
+ unpack ${A}
+ EPATCH_OPTS="-d ${S} -p1" epatch "${FILESDIR}/${P}-apache-2.2.patch"
+ EPATCH_OPTS="-d ${S} -p1" epatch "${FILESDIR}/${P}-htpasswd2-auth-style.patch"
+}
+
+pkg_postinst() {
+ if ! useq apache2 ; then
+ elog "With regard to bug #132391 the behaviour of ${PN}"
+ elog "has changed for Apache-1.3.XX."
+ elog
+ elog "You now need to enable ${PN} in your .htaccess"
+ elog "files explicitely using:"
+ elog
+ elog " AuthMySQLEnable On"
+ fi
+}