summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-07-06 11:32:19 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-07-06 11:32:19 +0000
commit0b29bf917ffd413cc609b18773771f5c87b6ea96 (patch)
tree100b64a90784002e9a881fd016594231511a9d42 /www-apache/mod_caucho/files
parentVersion bump, uses new Java build system. Closes bug #63246. (diff)
downloadhistorical-0b29bf917ffd413cc609b18773771f5c87b6ea96.tar.gz
historical-0b29bf917ffd413cc609b18773771f5c87b6ea96.tar.bz2
historical-0b29bf917ffd413cc609b18773771f5c87b6ea96.zip
Initial version - bug #89158.
Package-Manager: portage-2.1.1_pre2-r4
Diffstat (limited to 'www-apache/mod_caucho/files')
-rw-r--r--www-apache/mod_caucho/files/88_mod_caucho.conf25
-rw-r--r--www-apache/mod_caucho/files/digest-mod_caucho-3.0.193
-rw-r--r--www-apache/mod_caucho/files/mod_caucho-3.0.19-gentoo.patch17
3 files changed, 45 insertions, 0 deletions
diff --git a/www-apache/mod_caucho/files/88_mod_caucho.conf b/www-apache/mod_caucho/files/88_mod_caucho.conf
new file mode 100644
index 000000000000..079791061ccc
--- /dev/null
+++ b/www-apache/mod_caucho/files/88_mod_caucho.conf
@@ -0,0 +1,25 @@
+#
+# mod_caucho Resin Configuration
+#
+
+<IfDefine CAUCHO>
+
+ # Load module:
+ LoadModule caucho_module modules/mod_caucho.so
+
+ # Define first Resin server:
+ ResinConfigServer localhost 6802
+
+ # If you want to use load balancing add more hosts:
+ # ResinConfigServer host1.example.com 6802
+ # ResinConfigServer host2.example.com 6802
+
+ # This enables status page of server: http://localhost/caucho-status
+ CauchoStatus yes
+
+ # To use this module:
+ #<Location /webapp/*>
+ # SetHandler caucho-request
+ #</Location>
+
+</IfDefine>
diff --git a/www-apache/mod_caucho/files/digest-mod_caucho-3.0.19 b/www-apache/mod_caucho/files/digest-mod_caucho-3.0.19
new file mode 100644
index 000000000000..26edb4c85522
--- /dev/null
+++ b/www-apache/mod_caucho/files/digest-mod_caucho-3.0.19
@@ -0,0 +1,3 @@
+MD5 7e50a5393752e9002d456758a228b45c resin-3.0.19-src.tar.gz 5031722
+RMD160 691fd9c6a47c93dd10ba356901901a3d736ffbf9 resin-3.0.19-src.tar.gz 5031722
+SHA256 d8d0210e098f370d499439a695c68033d3fbe3e2cacf4d0da884e6891f3defd3 resin-3.0.19-src.tar.gz 5031722
diff --git a/www-apache/mod_caucho/files/mod_caucho-3.0.19-gentoo.patch b/www-apache/mod_caucho/files/mod_caucho-3.0.19-gentoo.patch
new file mode 100644
index 000000000000..cc6cc81d0045
--- /dev/null
+++ b/www-apache/mod_caucho/files/mod_caucho-3.0.19-gentoo.patch
@@ -0,0 +1,17 @@
+diff -Nru resin-3.0.19.vanilla/modules/c/src/apache2/Makefile.in resin-3.0.19/modules/c/src/apache2/Makefile.in
+--- resin-3.0.19.vanilla/modules/c/src/apache2/Makefile.in 2006-05-27 17:14:41.000000000 +0200
++++ resin-3.0.19/modules/c/src/apache2/Makefile.in 2006-05-27 17:16:58.000000000 +0200
+@@ -36,11 +36,8 @@
+ $(CC) -c $(INCLUDES) $(CFLAGS) $<
+
+ install : mod_caucho.la
+- $(LIBTOOL) --mode=install $(CP) mod_caucho.la $(apache_libexec)
+- - rm -f $(apache_libexec)/mod_caucho.la
+- - rm -f $(apache_libexec)/mod_caucho.a
+- sh install.sh -conf $(apache_conf) -libexec $(apache_libexec) \
+- -resin_home $(resin_home)
++ mkdir -p $(DESTDIR)$(apache_libexec)
++ $(LIBTOOL) --mode=install $(CP) mod_caucho.la $(DESTDIR)$(apache_libexec)
+
+ clean :
+ - rm -r *.o *.lo *.la *.so .libs