summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLim Swee Tat <st_lim@gentoo.org>2005-11-15 08:47:37 +0000
committerLim Swee Tat <st_lim@gentoo.org>2005-11-15 08:47:37 +0000
commitf41b59dacd194571a0ac74478a6b67189f0b7916 (patch)
treef54af26ae1a2517a6cef52506404abca4ef0f84b /www-apps/dspam-web
parentPatch removed (diff)
downloadhistorical-f41b59dacd194571a0ac74478a6b67189f0b7916.tar.gz
historical-f41b59dacd194571a0ac74478a6b67189f0b7916.tar.bz2
historical-f41b59dacd194571a0ac74478a6b67189f0b7916.zip
Version bump
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'www-apps/dspam-web')
-rw-r--r--www-apps/dspam-web/ChangeLog7
-rw-r--r--www-apps/dspam-web/Manifest4
-rw-r--r--www-apps/dspam-web/dspam-web-3.6.1.ebuild158
-rw-r--r--www-apps/dspam-web/files/digest-dspam-web-3.6.12
4 files changed, 169 insertions, 2 deletions
diff --git a/www-apps/dspam-web/ChangeLog b/www-apps/dspam-web/ChangeLog
index e30a6ea22193..9e0e7113c6ac 100644
--- a/www-apps/dspam-web/ChangeLog
+++ b/www-apps/dspam-web/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/dspam-web
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/dspam-web/ChangeLog,v 1.18 2005/11/06 04:14:16 st_lim Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/dspam-web/ChangeLog,v 1.19 2005/11/15 08:47:37 st_lim Exp $
+
+*dspam-web-3.6.1 (15 Nov 2005)
+
+ 15 Nov 2005; Lim Swee Tat <st_lim@gentoo.org> +dspam-web-3.6.1.ebuild:
+ Version bump
06 Nov 2005; Lim Swee Tat <st_lim@gentoo.org> dspam-web-3.6.0.ebuild:
Fixed bug #103398
diff --git a/www-apps/dspam-web/Manifest b/www-apps/dspam-web/Manifest
index 3b600c51d91c..53bbb6b977b8 100644
--- a/www-apps/dspam-web/Manifest
+++ b/www-apps/dspam-web/Manifest
@@ -1,10 +1,12 @@
-MD5 51161c6fc666a6d8d8404d8b44471b65 ChangeLog 3173
+MD5 e4c9d4ffcf435941fab8f329716d7b25 ChangeLog 3294
MD5 03096ac1ea250450da7db871a098de1a dspam-web-3.2.7.ebuild 5253
MD5 b03f7e094bd7bedf29e20baff13ca420 dspam-web-3.4.9.ebuild 5064
MD5 dd8731eb3e2b022fc6de7a4d8df368df dspam-web-3.6.0.ebuild 5214
+MD5 1e6db0a8cace60d0859f8ec4d683c6f2 dspam-web-3.6.1.ebuild 5214
MD5 7735956f416bd58bfcbeee99af43bea0 files/digest-dspam-web-3.2.7 63
MD5 c26bf920b2afa7ae432ac6b6d96fb9b4 files/digest-dspam-web-3.4.9 63
MD5 03b69dda833751bdda04e5413a9305e0 files/digest-dspam-web-3.6.0 129
+MD5 5a495629f2b3fbcfabc0f4ae4a9b4e4b files/digest-dspam-web-3.6.1 129
MD5 ffdfc8d816078f4c58b75b9bed07503f files/htaccess 135
MD5 b4099a94a52af9abd4ade48d82914c3c files/htpasswd 19
MD5 f1ea445d6b4ddf81c55a4e886bc04218 metadata.xml 341
diff --git a/www-apps/dspam-web/dspam-web-3.6.1.ebuild b/www-apps/dspam-web/dspam-web-3.6.1.ebuild
new file mode 100644
index 000000000000..ada5121f338f
--- /dev/null
+++ b/www-apps/dspam-web/dspam-web-3.6.1.ebuild
@@ -0,0 +1,158 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/dspam-web/dspam-web-3.6.1.ebuild,v 1.1 2005/11/15 08:47:37 st_lim Exp $
+
+inherit webapp eutils
+
+MY_PN=${PN/-web/}
+MY_P=${MY_PN}-${PV}
+
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Web based administration and user controls for dspam"
+SRC_URI="http://dspam.nuclearelephant.com/sources/${MY_P}.tar.gz
+ http://dspam.nuclearelephant.com/sources/extras/dspam_sa_trainer.tar.gz"
+HOMEPAGE="http://dspam.nuclearelephant.com/"
+LICENSE="GPL-2"
+
+IUSE="clamav debug large-domain logrotate mysql neural oci8 postgres sqlite virtual-users"
+DEPEND=">=mail-filter/dspam-${PV}
+ clamav? ( >=app-antivirus/clamav-0.86 )
+ mysql? ( >=dev-db/mysql-3.23 )
+ sqlite? ( dev-db/sqlite )
+ postgres? ( >=dev-db/postgresql-7.4.3 )
+ >=sys-libs/db-4.0
+ >=net-www/apache-1.3
+ >=dev-lang/perl-5.8.2
+ >=dev-perl/GD-2.0
+ dev-perl/GD-Graph3d
+ dev-perl/GDGraph
+ dev-perl/GDTextUtil"
+KEYWORDS="~x86 ~ppc ~amd64"
+
+# some FHS-like structure
+HOMEDIR="/var/spool/dspam"
+CONFDIR="/etc/mail/dspam"
+LOGDIR="/var/log/dspam"
+
+src_compile() {
+ local myconf
+
+ myconf="${myconf} --enable-long-username"
+ myconf="${myconf} --with-delivery-agent=/usr/bin/procmail"
+ use large-domain && myconf="${myconf} --enable-large-scale" ||\
+ myconf="${myconf} --enable-domain-scale"
+
+ myconf="${myconf} --with-dspam-home=${HOMEDIR}"
+ myconf="${myconf} --sysconfdir=${CONFDIR}"
+ use virtual-users || myconf="${myconf} --enable-homedir"
+ use clamav || myconf="${myconf} --enable-clamav"
+
+ # enables support for debugging (touch /etc/dspam/.debug to turn on)
+ # optional: even MORE debugging output, use with extreme caution!
+ use debug && myconf="${myconf} --enable-debug --enable-verbose-debug"
+
+ # select storage driver
+ if use sqlite ; then
+ myconf="${myconf} --with-storage-driver=sqlite_drv"
+ myconf="${myconf} --enable-virtual-users"
+ elif use mysql; then
+ myconf="${myconf} --with-storage-driver=mysql_drv"
+ myconf="${myconf} --with-mysql-includes=/usr/include/mysql"
+ myconf="${myconf} --with-mysql-libraries=/usr/lib/mysql"
+ myconf="${myconf} --enable-preferences-extension"
+
+ if has_version ">sys-kernel/linux-headers-2.6"; then
+ myconf="${myconf} --enable-daemon"
+ fi
+
+ use virtual-users && myconf="${myconf} --enable-virtual-users"
+ # an experimental feature available with MySQL and PgSQL backend
+ use neural && myconf="${myconf} --enable-neural-networking"
+ elif use postgres ; then
+ myconf="${myconf} --with-storage-driver=pgsql_drv"
+ myconf="${myconf} --with-pgsql-includes=/usr/include/postgresql"
+ myconf="${myconf} --with-pgsql-libraries=/usr/lib/postgresql"
+ myconf="${myconf} --enable-preferences-extension"
+
+ if has_version ">sys-kernel/linux-headers-2.6"; then
+ myconf="${myconf} --enable-daemon"
+ fi
+
+ use virtual-users && myconf="${myconf} --enable-virtual-users"
+ # an experimental feature available with MySQL and PgSQL backend
+ use neural && myconf="${myconf} --enable-neural-networking"
+ elif use oci8 ; then
+ myconf="${myconf} --with-storage-driver=ora_drv"
+ myconf="${myconf} --with-oracle-home=${ORACLE_HOME}"
+ myconf="${myconf} --enable-virtual-users"
+
+ # I am in no way a Oracle specialist. If someone knows
+ # how to query the version of Oracle, then let me know.
+ if (expr ${ORACLE_HOME/*\/} : 10 1>/dev/null 2>&1); then
+ myconf="${myconf} --with-oracle-version=10"
+ fi
+ else
+ myconf="${myconf} --with-storage-driver=libdb4_drv"
+ fi
+
+ econf ${myconf} || die
+ cd ${S}/webui
+ make
+}
+
+src_install () {
+ cd ${S}/webui
+ webapp_src_preinst
+
+ sed -e 's,/var/dspam,/etc/mail/dspam,' \
+ -e 's,/usr/local,/usr,' \
+ -i ${S}/webui/cgi-bin/admin.cgi
+ sed -e 's,/var/dspam,/etc/mail/dspam,' \
+ -e 's,/usr/local,/usr,' \
+ -i ${S}/webui/cgi-bin/dspam.cgi
+
+ cp -r ${S}/webui/htdocs/* ${D}/${MY_HTDOCSDIR} || die
+ cp -r ${S}/webui/cgi-bin/* ${D}/${MY_CGIBINDIR} || die
+ insinto ${MY_HTDOCSDIR}
+ insopts -m644 -o apache -g apache
+
+ newins ${FILESDIR}/htaccess .htaccess
+ newins ${FILESDIR}/htpasswd .htpasswd
+
+ #All files must be owned by server
+ cd ${D}/${MY_HTDOCSDIR}
+ for file in `find -type d -printf "%p/* "`; do
+ webapp_serverowned "${MY_HTDOCSDIR}/${file}"
+ done
+
+ #All files must be owned by server
+ cd ${D}/${MY_CGIBINDIR}
+ for file in `find -type d -printf "%p/* "`; do
+ webapp_serverowned "${MY_CGIBINDIR}/${file}"
+ done
+
+ webapp_src_install
+}
+
+pkg_config () {
+ # add apache to the dspam group so the CGIs can access the data
+
+ local groups
+ groups=`groups apache`
+ groups=`echo ${groups} | sed -e 's/ /,/g'`
+ usermod -G "${groups},dspam" apache
+}
+
+pkg_postinst () {
+ einfo "The CGIs need to be executed as group dspam in order to write"
+ einfo "to the dspam data directory. You will need to configure apache"
+ einfo "manually to do this. Another option is to add the user apache"
+ einfo "to the dspam group. You can do this automatically by running:"
+ echo
+ einfo "ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config"
+ echo
+ einfo "This app requires basic auth in order to operate properly."
+ einfo "You will need to add dspam users to the .htpasswd file or"
+ einfo "configure a different authentication mechanism for the user"
+ einfo "accounts."
+}
diff --git a/www-apps/dspam-web/files/digest-dspam-web-3.6.1 b/www-apps/dspam-web/files/digest-dspam-web-3.6.1
new file mode 100644
index 000000000000..5fb43c4d30da
--- /dev/null
+++ b/www-apps/dspam-web/files/digest-dspam-web-3.6.1
@@ -0,0 +1,2 @@
+MD5 6aad568823f297852dff4989da332e22 dspam-3.6.1.tar.gz 739389
+MD5 8ffe9d41e6104a4c6d19067528193145 dspam_sa_trainer.tar.gz 1230