summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2006-04-20 17:22:28 +0000
committerRenat Lumpau <rl03@gentoo.org>2006-04-20 17:22:28 +0000
commitf7782f26c599c44bd8e100e3af921fe8daf99fc0 (patch)
treea97e66104e3e0246b5e0a9e7d8dc1494d9870465 /www-apps/gallery/gallery-1.5.3.ebuild
parentVersion bump. (diff)
downloadhistorical-f7782f26c599c44bd8e100e3af921fe8daf99fc0.tar.gz
historical-f7782f26c599c44bd8e100e3af921fe8daf99fc0.tar.bz2
historical-f7782f26c599c44bd8e100e3af921fe8daf99fc0.zip
Version bump to 1.5.3 (security bug #130623).
Package-Manager: portage-2.1_pre9-r1
Diffstat (limited to 'www-apps/gallery/gallery-1.5.3.ebuild')
-rw-r--r--www-apps/gallery/gallery-1.5.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/www-apps/gallery/gallery-1.5.3.ebuild b/www-apps/gallery/gallery-1.5.3.ebuild
new file mode 100644
index 000000000000..7ff2e74f5efe
--- /dev/null
+++ b/www-apps/gallery/gallery-1.5.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/gallery-1.5.3.ebuild,v 1.1 2006/04/20 17:22:28 rl03 Exp $
+
+inherit webapp
+
+DESCRIPTION="Web based (PHP Script) photo album viewer/creator"
+HOMEPAGE="http://gallery.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="imagemagick netpbm unzip zip"
+
+RDEPEND=">=net-www/apache-1.3.24-r1
+ virtual/php
+ media-libs/jpeg
+ netpbm? ( >=media-libs/netpbm-9.12 >=media-gfx/jhead-2.2 )
+ imagemagick? ( >=media-gfx/imagemagick-5.4.9.1-r1 )
+ unzip? ( app-arch/unzip )
+ zip? ( app-arch/zip )"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ webapp_src_preinst
+
+ cp -R * ${D}/${MY_HTDOCSDIR}
+ for file in AUTHORS ChangeLog README ChangeLog.archive.gz; do
+ dodoc ${file}
+ rm -f ${D}/${MY_HTDOCSDIR}/${file}
+ done
+ dohtml docs/*
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ webapp_src_install
+}