summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2008-02-26 07:14:12 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2008-02-26 07:14:12 +0000
commit4ffe56884401ea178449d149afe7375367e7e730 (patch)
tree54a780db76ff717560f9a4234fa2d4498546fe35 /www-apps/moinmoin/moinmoin-1.5.8.ebuild
parentRemove vulnerable version (sec issue #207757) and fix dependencies (#208584). (diff)
downloadhistorical-4ffe56884401ea178449d149afe7375367e7e730.tar.gz
historical-4ffe56884401ea178449d149afe7375367e7e730.tar.bz2
historical-4ffe56884401ea178449d149afe7375367e7e730.zip
Removed vulnerable version (sec issue #209133)
Package-Manager: portage-2.1.4_rc7
Diffstat (limited to 'www-apps/moinmoin/moinmoin-1.5.8.ebuild')
-rw-r--r--www-apps/moinmoin/moinmoin-1.5.8.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/www-apps/moinmoin/moinmoin-1.5.8.ebuild b/www-apps/moinmoin/moinmoin-1.5.8.ebuild
deleted file mode 100644
index 24d6cf5f9d61..000000000000
--- a/www-apps/moinmoin/moinmoin-1.5.8.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/moinmoin/moinmoin-1.5.8.ebuild,v 1.5 2007/06/02 20:44:08 nixnut Exp $
-
-inherit webapp
-
-MY_PN="moin"
-S=${WORKDIR}/${MY_PN}-${PV}
-
-DESCRIPTION="Python WikiClone"
-SRC_URI="mirror://sourceforge/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-HOMEPAGE="http://moinmoin.wikiwikiweb.de"
-KEYWORDS="amd64 ppc sparc x86"
-LICENSE="GPL-2"
-IUSE="rss"
-
-SLOT="0"
-WEBAPP_MANUAL_SLOT="yes"
-
-DEPEND=">=dev-lang/python-2.3"
-RDEPEND="${DEPEND}
- >=dev-python/docutils-0.4
- rss? ( >=dev-python/pyxml-0.8.4 )"
-
-src_compile() {
- python setup.py build || die "python build failed"
-}
-
-src_install () {
- webapp_src_preinst
-
- python setup.py install --root=${D} --prefix=/usr install || die "python install failed"
-
- dodoc ChangeLog README docs/CHANGES* docs/HACKS docs/README.migration
- dohtml docs/INSTALL.html
- dodir ${MY_HOSTROOTDIR}/${PF}
-
- cd ${D}/usr/share/moin
- cp -r htdocs/* server/moin.cgi ${D}/${MY_HTDOCSDIR}
- chmod +x ${D}/${MY_HTDOCSDIR}/moin.cgi
- cp -r data underlay config/wikiconfig.py ${D}/${MY_HOSTROOTDIR}/${PF}
- cp -r config ${D}/${MY_HOSTROOTDIR}/${PF}/altconfigs
- cp -r server ${D}/${MY_HOSTROOTDIR}/${PF}/altserver
-
- # data needs to be serverowned per moin devs
- cd ${D}/${MY_HOSTROOTDIR}/${PF}
- for file in $(find data underlay); do
- webapp_serverowned "${MY_HOSTROOTDIR}/${PF}/${file}"
- done
-
- webapp_configfile ${MY_HOSTROOTDIR}/${PF}/wikiconfig.py
- webapp_hook_script ${FILESDIR}/reconfig-2
- webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
-
- webapp_src_install
-}
-
-pkg_postinst() {
- ewarn "If you are upgrading from 1.3.x, please read"
- ewarn "/usr/share/doc/${PF}/README.migration.gz"
- ewarn "and http://moinmoin.wikiwikiweb.de/HelpOnUpdating"
- webapp_pkg_postinst
-}