summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Allanos <dju@gentoo.org>2006-02-07 19:09:40 +0000
committerJulien Allanos <dju@gentoo.org>2006-02-07 19:09:40 +0000
commitdfa78d10b57e41756ae0d4e51020581aba679c4c (patch)
tree1aceab846bfdf426c087c090674a170f8e8b9aad /www-apps/trac
parentMarked ppc-macos stable (bug #118349) (diff)
downloadhistorical-dfa78d10b57e41756ae0d4e51020581aba679c4c.tar.gz
historical-dfa78d10b57e41756ae0d4e51020581aba679c4c.tar.bz2
historical-dfa78d10b57e41756ae0d4e51020581aba679c4c.zip
Check if subversion was built with USE python. Added contrib/ dir to docs, closes bug #121601.
Package-Manager: portage-2.0.54
Diffstat (limited to 'www-apps/trac')
-rw-r--r--www-apps/trac/ChangeLog6
-rw-r--r--www-apps/trac/Manifest4
-rw-r--r--www-apps/trac/trac-0.9.3.ebuild18
3 files changed, 21 insertions, 7 deletions
diff --git a/www-apps/trac/ChangeLog b/www-apps/trac/ChangeLog
index 6c6105ea6f3b..d7845b4ce6b0 100644
--- a/www-apps/trac/ChangeLog
+++ b/www-apps/trac/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apps/trac
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/trac/ChangeLog,v 1.29 2006/01/12 22:44:53 dju Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/trac/ChangeLog,v 1.30 2006/02/07 19:09:40 dju Exp $
+
+ 07 Feb 2006; Julien Allanos <dju@gentoo.org> trac-0.9.3.ebuild:
+ Check if subversion was built with USE python. Added contrib/ dir
+ to docs, closes bug #121601.
12 Jan 2006; Julien Allanos <dju@gentoo.org> -files/0.8.1-postinst-en.txt,
-trac-0.8.2.ebuild:
diff --git a/www-apps/trac/Manifest b/www-apps/trac/Manifest
index 833fb6d1564d..fc2c2c6445e4 100644
--- a/www-apps/trac/Manifest
+++ b/www-apps/trac/Manifest
@@ -1,8 +1,8 @@
-MD5 71c5e4a9c57a5e2b3de6dbd97be15c00 ChangeLog 5859
+MD5 738dd774ab36c41f65c4b2f97a92877b ChangeLog 6025
MD5 469236380f880bdb92903ecee4587ae3 files/0.8.4-postinst-en.txt 1035
MD5 1ef68ae7232130e8152d6e007afc4352 files/0.9.3-postinst-en.txt 2275
MD5 8923e5fb9575c109266bbab2350940ff files/digest-trac-0.8.4 62
MD5 34f51a4e22b9c551e4d20d56daf45c85 files/digest-trac-0.9.3 62
MD5 fc3b5dec4ccef02547c54bf840024aa6 metadata.xml 220
MD5 f605a49aef73a61cbcc7527da21fd418 trac-0.8.4.ebuild 1511
-MD5 4f69d12070fc1fc01b56bc79b7a712fe trac-0.9.3.ebuild 2210
+MD5 77a1c85e49192f2beab5eaed1a331785 trac-0.9.3.ebuild 2486
diff --git a/www-apps/trac/trac-0.9.3.ebuild b/www-apps/trac/trac-0.9.3.ebuild
index d90c4088e347..44a404a0cdef 100644
--- a/www-apps/trac/trac-0.9.3.ebuild
+++ b/www-apps/trac/trac-0.9.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/trac/trac-0.9.3.ebuild,v 1.3 2006/01/11 14:29:05 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/trac/trac-0.9.3.ebuild,v 1.4 2006/02/07 19:09:40 dju Exp $
inherit distutils webapp
@@ -20,7 +20,7 @@ WEBAPP_MANUAL_SLOT="yes"
# we need to depend on virtual/httpd-fcgi to bring mod_fastcgi/lighttpd/whatever in when USE fastcgi
# we need to depend on virtual/httpd-python to bring mod_python/whatever in when USE python (python
# is rather confusing here, as dev-lang/python is a required dependency, but httpd-python isn't)
-DEPEND="$DEPEND
+DEPEND="${DEPEND}
>=dev-lang/python-2.3
app-text/pytextile
>=dev-python/docutils-0.3.3
@@ -35,14 +35,21 @@ pkg_setup () {
if ! use postgres && ! use sqlite ; then
eerror "You must select at least one database backend,"
eerror "using sqlite or postgres USE flags."
- die "no database backend selected!"
+ die "no database backend selected"
+ fi
+
+ if ! built_with_use dev-util/subversion python ; then
+ eerror "Your subversion has been built without python bindings,"
+ eerror "please enable the 'python' useflag and recompile"
+ eerror "dev-util/subversion."
+ die "pkg_setup failed"
fi
webapp_pkg_setup
}
src_install () {
- # project databases might go in here
+ # project environments might go in here
keepdir /var/lib/trac
webapp_src_preinst
@@ -52,6 +59,9 @@ src_install () {
rm ${D}/usr/share/doc/${P}/MANIFEST.in.gz
rm ${D}/usr/share/doc/${P}/PKG-INFO.gz
+ docinto contrib
+ dodoc contrib/*
+
# if needed, install cgi/fcgi scripts for webapp-config
local my_dir=${D}/usr/share/trac
if use cgi ; then