summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2007-08-14 06:33:11 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2007-08-14 06:33:11 +0000
commita9ce0606452a92bc80ab3eaca0b747c02685711e (patch)
tree3bab423652210e53fb4603634059c2eafed8c820 /www-apps/websvn/websvn-2.0.ebuild
parentamd64 stable, bug #188564 (diff)
downloadhistorical-a9ce0606452a92bc80ab3eaca0b747c02685711e.tar.gz
historical-a9ce0606452a92bc80ab3eaca0b747c02685711e.tar.bz2
historical-a9ce0606452a92bc80ab3eaca0b747c02685711e.zip
Added websvn-2.0 to the tree, removed older, insecure ebuilds.
Package-Manager: portage-2.1.2.11
Diffstat (limited to 'www-apps/websvn/websvn-2.0.ebuild')
-rw-r--r--www-apps/websvn/websvn-2.0.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/www-apps/websvn/websvn-2.0.ebuild b/www-apps/websvn/websvn-2.0.ebuild
new file mode 100644
index 000000000000..cabac1f8c2e2
--- /dev/null
+++ b/www-apps/websvn/websvn-2.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/websvn/websvn-2.0.ebuild,v 1.1 2007/08/14 06:33:11 wrobel Exp $
+
+inherit depend.php eutils webapp
+
+MY_PV="${PV//_/}"
+DESCRIPTION="Web-based browsing tool for Subversion (SVN) repositories in PHP"
+HOMEPAGE="http://websvn.tigris.org/"
+SRC_URI="http://websvn.tigris.org/files/documents/1380/39378/websvn-${MY_PV}.tar.gz"
+RESTRICT="nomirror"
+LICENSE="GPL-2"
+IUSE="enscript"
+KEYWORDS="~amd64 ~sparc ~x86"
+
+RDEPEND="virtual/php
+ dev-util/subversion
+ sys-apps/sed
+ enscript? ( app-text/enscript )"
+
+S="${WORKDIR}/websvn-${MY_PV}"
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ if ! has_version "=dev-lang/php-5*" ; then
+ require_php_with_use expat
+ else
+ require_php_with_use xml
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+}
+
+src_compile() {
+ mv "${S}"/include/distconfig.php "${S}"/include/config.php
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local doc docs="licence.txt changes.txt doc/*"
+
+ dodoc ${docs}
+ for doc in ${docs}; do
+ rm -f "${doc}"
+ done
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r *
+ webapp_configfile "${MY_HTDOCSDIR}"/include/config.php
+
+ # This is the multiview config file
+ webapp_configfile "${MY_HTDOCSDIR}"/wsvn.php
+
+ # The cache directory needs to be writeable
+ webapp_serverowned "${MY_HTDOCSDIR}"/cache
+
+ webapp_src_install
+}