summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-02-11 14:25:41 +0000
committerPacho Ramos <pacho@gentoo.org>2012-02-11 14:25:41 +0000
commit75fc25c4fa4c7f068e7481963a17712384cf845d (patch)
tree0c510992b1bfa573bf75c4400e571d407b06960c /www-client/httrack/httrack-3.44.5.ebuild
parentAdd missing die wrt #403161 (diff)
downloadhistorical-75fc25c4fa4c7f068e7481963a17712384cf845d.tar.gz
historical-75fc25c4fa4c7f068e7481963a17712384cf845d.tar.bz2
historical-75fc25c4fa4c7f068e7481963a17712384cf845d.zip
Version bump (should fix bug #351813 by Michael Orlitzky and Xavier Roche), install docs in proper place (bug #241466 by flameeyes and Gef Lebster). Drop old.
Package-Manager: portage-2.1.10.45/cvs/Linux x86_64
Diffstat (limited to 'www-client/httrack/httrack-3.44.5.ebuild')
-rw-r--r--www-client/httrack/httrack-3.44.5.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/www-client/httrack/httrack-3.44.5.ebuild b/www-client/httrack/httrack-3.44.5.ebuild
new file mode 100644
index 000000000000..6c99104b61ba
--- /dev/null
+++ b/www-client/httrack/httrack-3.44.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/httrack/httrack-3.44.5.ebuild,v 1.1 2012/02/11 14:25:41 pacho Exp $
+
+EAPI="4"
+inherit eutils
+
+DESCRIPTION="HTTrack Website Copier, Open Source Offline Browser"
+HOMEPAGE="http://www.httrack.com/"
+SRC_URI="http://download.httrack.com/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND=">=sys-libs/zlib-1.2.5.1-r1"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS README greetings.txt history.txt )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.44.1+zlib-1.2.5.1.patch
+
+ sed -i \
+ "/^HelpHtml.*dir/s:${PN}:${PF}:" \
+ "${S}"/html/Makefile.in || die
+}
+
+src_configure() {
+ econf $(use_enable static-libs static) \
+ --docdir=/usr/share/doc/${PF} \
+ --htmldir=/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+ rm -rf "${ED}"/usr/share/doc/"${PN}" || die
+}