summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-08-14 21:19:05 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-08-14 21:19:05 +0000
commitea40c45dae37cead63d963921728207115378588 (patch)
tree4fba9aae73cfc5f7bb0cf48ee739f1168b9512c5 /www-servers/resin/files
parentAdded net-mail/mailbase dependency. maildrop needs /var/spool/mail to exist. (diff)
downloadhistorical-ea40c45dae37cead63d963921728207115378588.tar.gz
historical-ea40c45dae37cead63d963921728207115378588.tar.bz2
historical-ea40c45dae37cead63d963921728207115378588.zip
Version bump, cleaned up old versions.
Package-Manager: portage-2.1.1_pre5
Diffstat (limited to 'www-servers/resin/files')
-rw-r--r--www-servers/resin/files/3.0.21/resin-3.0.21-gentoo.patch252
-rw-r--r--www-servers/resin/files/3.0.21/resin.conf27
-rw-r--r--www-servers/resin/files/3.0.21/resin.init21
-rw-r--r--www-servers/resin/files/digest-resin-3.0.213
4 files changed, 303 insertions, 0 deletions
diff --git a/www-servers/resin/files/3.0.21/resin-3.0.21-gentoo.patch b/www-servers/resin/files/3.0.21/resin-3.0.21-gentoo.patch
new file mode 100644
index 000000000000..80581892ed44
--- /dev/null
+++ b/www-servers/resin/files/3.0.21/resin-3.0.21-gentoo.patch
@@ -0,0 +1,252 @@
+diff -Nru resin-3.0.21.vanilla/Makefile.in resin-3.0.21/Makefile.in
+--- resin-3.0.21.vanilla/Makefile.in 2006-08-14 22:44:11.000000000 +0200
++++ resin-3.0.21/Makefile.in 2006-08-14 22:45:48.000000000 +0200
+@@ -1,6 +1,6 @@
+ PREFIX=@prefix@
+
+-all :
++all :
+ (cd modules/c/src; $(MAKE))
+
+ clean :
+@@ -8,20 +8,20 @@
+
+ install :
+ (cd modules/c/src; $(MAKE) install)
+- if test $(PREFIX) != `pwd`; then \
+- mkdir -p $(PREFIX)/lib; \
+- mkdir -p $(PREFIX)/libexec; \
+- cp -r libexec/* $(PREFIX)/libexec; \
+- cp lib/*.jar $(PREFIX)/lib; \
+- mkdir -p $(PREFIX)/bin; \
+- cp bin/* $(PREFIX)/bin; \
+- mkdir -p $(PREFIX)/webapps; \
+- cp -r webapps/* $(PREFIX)/webapps; \
+- mkdir -p $(PREFIX)/conf; \
+- cp conf/resin.conf $(PREFIX)/conf/resin.conf.orig; \
+- cp conf/app-default.xml $(PREFIX)/conf/app-default.xml.orig; \
+- if test ! -r $(PREFIX)/conf/resin.conf; then \
+- cp conf/resin.conf $(PREFIX)/conf/resin.conf; \
+- cp conf/app-default.xml $(PREFIX)/conf/app-default.xml; \
++ if test $(DESTDIR)$(PREFIX) != `pwd`; then \
++ mkdir -p $(DESTDIR)$(PREFIX)/lib; \
++ mkdir -p $(DESTDIR)$(PREFIX)/libexec; \
++ cp -r libexec/* $(DESTDIR)$(PREFIX)/libexec; \
++ cp lib/*.jar $(DESTDIR)$(PREFIX)/lib; \
++ mkdir -p $(DESTDIR)$(PREFIX)/bin; \
++ cp bin/* $(DESTDIR)$(PREFIX)/bin; \
++ mkdir -p $(DESTDIR)$(PREFIX)/webapps; \
++ cp -r webapps/* $(DESTDIR)$(PREFIX)/webapps; \
++ mkdir -p $(DESTDIR)$(PREFIX)/conf; \
++ cp conf/resin.conf $(DESTDIR)$(PREFIX)/conf/resin.conf.orig; \
++ cp conf/app-default.xml $(DESTDIR)$(PREFIX)/conf/app-default.xml.orig; \
++ if test ! -r $(DESTDIR)$(PREFIX)/conf/resin.conf; then \
++ cp conf/resin.conf $(DESTDIR)$(PREFIX)/conf/resin.conf; \
++ cp conf/app-default.xml $(DESTDIR)$(PREFIX)/conf/app-default.xml; \
+ fi; \
+ fi
+diff -Nru resin-3.0.21.vanilla/bin/wrapper.pl resin-3.0.21/bin/wrapper.pl
+--- resin-3.0.21.vanilla/bin/wrapper.pl 2006-08-14 22:44:03.000000000 +0200
++++ resin-3.0.21/bin/wrapper.pl 2006-08-14 22:46:33.000000000 +0200
+@@ -447,9 +447,6 @@
+ $pid=`cat $pid_file`;
+ chop($pid);
+
+- if ($cmd eq "stop") {
+- print("Stopping ${name}\n");
+- }
+ $signal = 15;
+ $count = 10;
+ while (kill($signal, $pid) && $count-- > 0) {
+@@ -565,8 +562,6 @@
+ $SIG{CHLD} = 'IGNORE';
+ }
+
+- print "\n\nResin wrapper.pl closing.\n\n";
+-
+ close(S);
+ close(C); # closing the accepted socket should start orderly shutdown
+ # unlink needs to happen relatively soon so restart's pid won't
+@@ -743,8 +738,6 @@
+ $date = `date`;
+ chop($date);
+
+- print "Resin $name $cmd at $date\n";
+-
+ # create a keepalive socket
+ # when the wrapper dies, the httpd class will detect that and
+ # close gracefully
+diff -Nru resin-3.0.21.vanilla/bin/wrapper.pl.in resin-3.0.21/bin/wrapper.pl.in
+--- resin-3.0.21.vanilla/bin/wrapper.pl.in 2006-08-14 22:44:03.000000000 +0200
++++ resin-3.0.21/bin/wrapper.pl.in 2006-08-14 22:46:54.000000000 +0200
+@@ -447,9 +447,6 @@
+ $pid=`cat $pid_file`;
+ chop($pid);
+
+- if ($cmd eq "stop") {
+- print("Stopping ${name}\n");
+- }
+ $signal = 15;
+ $count = 10;
+ while (kill($signal, $pid) && $count-- > 0) {
+@@ -565,8 +562,6 @@
+ $SIG{CHLD} = 'IGNORE';
+ }
+
+- print "\n\nResin wrapper.pl closing.\n\n";
+-
+ close(S);
+ close(C); # closing the accepted socket should start orderly shutdown
+ # unlink needs to happen relatively soon so restart's pid won't
+@@ -743,8 +738,6 @@
+ $date = `date`;
+ chop($date);
+
+- print "Resin $name $cmd at $date\n";
+-
+ # create a keepalive socket
+ # when the wrapper dies, the httpd class will detect that and
+ # close gracefully
+diff -Nru resin-3.0.21.vanilla/build.xml resin-3.0.21/build.xml
+--- resin-3.0.21.vanilla/build.xml 2006-08-14 22:44:11.000000000 +0200
++++ resin-3.0.21/build.xml 2006-08-14 23:04:43.000000000 +0200
+@@ -7,7 +7,6 @@
+
+ <property name="modules" location="${basedir}/modules"/>
+ <property name="src" location="${basedir}/src"/>
+- <property name="ext" location="${basedir}/modules/ext"/>
+ <property name="doc" location="${basedir}/doc"/>
+
+ <property name="build" location="${install}/build"/>
+@@ -17,14 +16,12 @@
+
+
+ <property name="javac.verbose" value="off"/>
+- <property name="javac.debug" value="on"/>
++ <property name="javac.debug" value="off"/>
+ <property name="javac.optimize" value="off"/>
+ <property name="javac.deprecation" value="off"/>
+ <property name="javac.nowarn" value="on"/>
+ <property name="javac.memoryMaximumSize" value="256m"/>
+
+- <property name="javac.source" value="1.4"/>
+-
+ <property name="jar.compress" value="false"/>
+ <property name="jar.index" value="true"/>
+ <property name="jar.update" value="false"/>
+@@ -66,7 +63,7 @@
+ </target>
+
+ <target name="compile"
+- depends="init, ejb, ejb30, j2ee-deploy, j2ee-management, jaxrpc, jca, jms, jmx, jsdk, jstl, jta, portlet, script, resin-jdk15, resin, quercus, webutil, deploy, conf, ext">
++ depends="init, ejb, ejb30, j2ee-deploy, j2ee-management, jaxrpc, jca, jms, jmx, jsdk, jstl, jta, portlet, script, resin-jdk15, resin, quercus, webutil, deploy, conf">
+ </target>
+
+ <target name="ejb" depends="init, jta">
+@@ -80,7 +77,6 @@
+ <antcall target="module" inheritRefs="true">
+ <param name="module.name" value="ejb30"/>
+ <param name="module.jar" value="ejb-30.jar"/>
+- <param name="javac.source" value="1.5"/>
+ </antcall>
+ </target>
+
+@@ -102,7 +98,6 @@
+ <antcall target="module" inheritRefs="true">
+ <param name="module.name" value="jaxrpc"/>
+ <param name="module.jar" value="jaxrpc.jar"/>
+- <param name="javac.source" value="1.5"/>
+ </antcall>
+ </target>
+
+@@ -116,7 +111,6 @@
+ <target name="resin-jdk15" depends="init">
+ <antcall target="module" inheritRefs="true">
+ <param name="module.name" value="resin-jdk15"/>
+- <param name="javac.source" value="1.5"/>
+ </antcall>
+ </target>
+
+@@ -217,7 +211,6 @@
+
+ <antcall target="module" inheritRefs="true">
+ <param name="module.name" value="resin"/>
+- <param name="javac.source" value="1.5"/>
+ </antcall>
+ </target>
+
+@@ -242,14 +235,12 @@
+ <target name="webutil" depends="init, resin">
+ <antcall target="module" inheritRefs="true">
+ <param name="module.name" value="webutil"/>
+- <param name="javac.source" value="1.5"/>
+ </antcall>
+ </target>
+
+ <target name="quercus-dev" depends="init">
+ <antcall target="module" inheritRefs="true">
+ <param name="module.name" value="quercus"/>
+- <param name="javac.source" value="1.5"/>
+ </antcall>
+ </target>
+
+@@ -282,16 +273,15 @@
+ verbose="${javac.verbose}"
+ debug="${javac.debug}" optimize="${javac.optimize}"
+ deprecation="${javac.deprecation}" nowarn="${javac.nowarn}"
+- source="${javac.source}"
+ excludes="**/.svn/**"
+ memoryMaximumSize="${javac.memoryMaximumSize}">
+ <classpath>
+ <dirset dir="${modules}">
+ <include name="*/classes"/>
+ </dirset>
+- <fileset dir="${ext}">
+- <include name="**/*.jar"/>
+- </fileset>
++ <fileset dir="lib">
++ <include name="*.jar" />
++ </fileset>
+ </classpath>
+ </javac>
+
+@@ -355,13 +345,6 @@
+ </copy>
+ </target>
+
+- <target name="ext" depends="init, resin">
+- <copy todir="${install}/lib" preservelastmodified="true">
+- <fileset dir="${ext}">
+- </fileset>
+- </copy>
+- </target>
+-
+ <target name="webapps" depends="init, doc, quercus">
+ </target>
+
+@@ -500,9 +483,6 @@
+ <dirset dir="${modules}">
+ <include name="*/classes"/>
+ </dirset>
+- <fileset dir="${modules}/ext">
+- <include name="**/*.jar"/>
+- </fileset>
+ </classpath>
+ </java>
+
+diff -Nru resin-3.0.21.vanilla/modules/resin/src/com/caucho/server/resin/Resin.java resin-3.0.21/modules/resin/src/com/caucho/server/resin/Resin.java
+--- resin-3.0.21.vanilla/modules/resin/src/com/caucho/server/resin/Resin.java 2006-08-14 22:44:09.000000000 +0200
++++ resin-3.0.21/modules/resin/src/com/caucho/server/resin/Resin.java 2006-08-14 22:50:20.000000000 +0200
+@@ -700,10 +700,10 @@
+ throw new ConfigException(L().l("The following system property must be set:\n -Djava.util.logging.manager=com.caucho.log.LogManagerImpl\nThe JDK 1.4 Logging manager must be set to Resin's log manager."));
+ }
+
+- validatePackage("javax.servlet.Servlet", new String[] {"2.4", "1.4"});
++ validatePackage("javax.servlet.Servlet", new String[] {"2.4", "1.5"});
+ validatePackage("javax.servlet.jsp.jstl.core.Config", new String[] {"1.1"});
+ validatePackage("javax.management.MBeanServer", new String[] { "1.2", "1.5" });
+- validatePackage("javax.resource.spi.ResourceAdapter", new String[] {"1.5", "1.4"});
++ validatePackage("javax.resource.spi.ResourceAdapter", new String[] {"1.5", "1.5"});
+ }
+
+ /**
diff --git a/www-servers/resin/files/3.0.21/resin.conf b/www-servers/resin/files/3.0.21/resin.conf
new file mode 100644
index 000000000000..99210edc27b9
--- /dev/null
+++ b/www-servers/resin/files/3.0.21/resin.conf
@@ -0,0 +1,27 @@
+# JVM Runtime
+# Using the default setting, it will determine your JVM from the system-vm
+# set using java-config.
+# See java-config(1) manual page for assistance in determining this value.
+#
+# You can override this value with whatever path you wish.
+# Example: JAVA_HOME=/opt/sun-jdk-1.4.1.01
+
+JAVA_HOME=`java-config -O`
+
+# (Optional) Java runtime options.
+# WARNING! Prepend each option with -J, so -Xmx512m should be -J-Xmx512m
+# JAVA_OPTS=""
+
+# Where your Resin is installed
+RESIN_HOME=/usr/lib/resin
+
+# Resin Log Locations
+RESIN_OUT=/var/log/resin/resin_out.log
+RESIN_ERR=/var/log/resin/resin_err.log
+
+# The CLASSPATH for Resin to use, plus any others you need.
+CLASSPATH=$(java-config -p resin)
+
+# START/STOP settings
+RESIN_START="start"
+RESIN_STOP="stop"
diff --git a/www-servers/resin/files/3.0.21/resin.init b/www-servers/resin/files/3.0.21/resin.init
new file mode 100644
index 000000000000..2d0c5b3aff13
--- /dev/null
+++ b/www-servers/resin/files/3.0.21/resin.init
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/resin/files/3.0.21/resin.init,v 1.1 2006/08/14 21:19:05 nelchael Exp $
+
+depend() {
+ need net
+ use dns logger mysql postgresql
+}
+
+start() {
+ ebegin "Starting Resin"
+ su - resin -c "${RESIN_HOME}/bin/httpd.sh ${JAVA_OPTS} -pid-dir /var/run/resin/ -java_home ${JAVA_HOME} -resin_home ${RESIN_HOME} -cp ${CLASSPATH} -stdout ${RESIN_OUT} -stderr ${RESIN_ERR} ${RESIN_START}"
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Resin"
+ su - resin -c "${RESIN_HOME}/bin/httpd.sh ${JAVA_OPTS} -pid-dir /var/run/resin/ ${RESIN_STOP}"
+ eend $?
+}
diff --git a/www-servers/resin/files/digest-resin-3.0.21 b/www-servers/resin/files/digest-resin-3.0.21
new file mode 100644
index 000000000000..be883f386363
--- /dev/null
+++ b/www-servers/resin/files/digest-resin-3.0.21
@@ -0,0 +1,3 @@
+MD5 e7d7f91479e3931f86afea52d32ca1fa resin-3.0.21-src.tar.gz 5401440
+RMD160 1f4d90a28aa772a4dc14259816325285ffea1957 resin-3.0.21-src.tar.gz 5401440
+SHA256 c9de627433fbe3ec940507fd604a4a2409e70a16342994ffab881a51f8db1055 resin-3.0.21-src.tar.gz 5401440