summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2005-08-08 06:28:13 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2005-08-08 06:28:13 +0000
commit9320443950a24564d84da3dfc93e586fdfc657b1 (patch)
tree985eef46960083a3b1d79db48f04c8de8b4a1423 /x11-apps/xload
parentversion bump (diff)
downloadhistorical-9320443950a24564d84da3dfc93e586fdfc657b1.tar.gz
historical-9320443950a24564d84da3dfc93e586fdfc657b1.tar.bz2
historical-9320443950a24564d84da3dfc93e586fdfc657b1.zip
Initial commit for modular X.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'x11-apps/xload')
-rw-r--r--x11-apps/xload/ChangeLog9
-rw-r--r--x11-apps/xload/Manifest2
-rw-r--r--x11-apps/xload/files/digest-xload-0.99.01
-rw-r--r--x11-apps/xload/xload-0.99.0.ebuild22
4 files changed, 34 insertions, 0 deletions
diff --git a/x11-apps/xload/ChangeLog b/x11-apps/xload/ChangeLog
new file mode 100644
index 000000000000..edc79d150e38
--- /dev/null
+++ b/x11-apps/xload/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for x11-apps/xload
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xload/ChangeLog,v 1.1 2005/08/08 06:28:11 spyderous Exp $
+
+*xload-0.99.0 (08 Aug 2005)
+
+ 08 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>; +xload-0.99.0.ebuild:
+ Initial commit for modular X.
+
diff --git a/x11-apps/xload/Manifest b/x11-apps/xload/Manifest
new file mode 100644
index 000000000000..38bbb1f04a4b
--- /dev/null
+++ b/x11-apps/xload/Manifest
@@ -0,0 +1,2 @@
+MD5 e388edaf48dd018305ca1348f5a00655 xload-0.99.0.ebuild 492
+MD5 7932be82168fa056e6752643ad445cd8 files/digest-xload-0.99.0 64
diff --git a/x11-apps/xload/files/digest-xload-0.99.0 b/x11-apps/xload/files/digest-xload-0.99.0
new file mode 100644
index 000000000000..8e1d911e1e4d
--- /dev/null
+++ b/x11-apps/xload/files/digest-xload-0.99.0
@@ -0,0 +1 @@
+MD5 0ed1a80505222d1eb8a931bed57f38f3 xload-0.99.0.tar.bz2 64035
diff --git a/x11-apps/xload/xload-0.99.0.ebuild b/x11-apps/xload/xload-0.99.0.ebuild
new file mode 100644
index 000000000000..ae72e0531b53
--- /dev/null
+++ b/x11-apps/xload/xload-0.99.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xload/xload-0.99.0.ebuild,v 1.1 2005/08/08 06:28:11 spyderous Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xload application"
+KEYWORDS="~x86"
+IUSE="xprint"
+RDEPEND="x11-libs/libXaw"
+DEPEND="${RDEPEND}"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}