summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-08-18 17:20:37 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-08-18 17:20:37 +0000
commita5d01b7f9a0fa448c8bd388f430db113499e1e5c (patch)
tree11a63d96e6af16a27a9b8df7783fc12ea517ee66 /x11-base/xorg-x11/xorg-x11-7.0-r1.ebuild
parentModular X: mask video cards for architectures on which they aren't available (diff)
downloadhistorical-a5d01b7f9a0fa448c8bd388f430db113499e1e5c.tar.gz
historical-a5d01b7f9a0fa448c8bd388f430db113499e1e5c.tar.bz2
historical-a5d01b7f9a0fa448c8bd388f430db113499e1e5c.zip
Move architecture-specific video driver defaults into profiles.
Package-Manager: portage-2.1.1_pre4-r4
Diffstat (limited to 'x11-base/xorg-x11/xorg-x11-7.0-r1.ebuild')
-rw-r--r--x11-base/xorg-x11/xorg-x11-7.0-r1.ebuild372
1 files changed, 83 insertions, 289 deletions
diff --git a/x11-base/xorg-x11/xorg-x11-7.0-r1.ebuild b/x11-base/xorg-x11/xorg-x11-7.0-r1.ebuild
index 0adf74281280..688973ade88f 100644
--- a/x11-base/xorg-x11/xorg-x11-7.0-r1.ebuild
+++ b/x11-base/xorg-x11/xorg-x11-7.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/xorg-x11-7.0-r1.ebuild,v 1.28 2006/07/19 18:25:34 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/xorg-x11-7.0-r1.ebuild,v 1.29 2006/08/18 17:16:46 dberkholz Exp $
inherit eutils
@@ -141,299 +141,93 @@ RDEPEND="${RDEPEND}
>=sys-apps/portage-2.1_pre4"
# Drivers
-###############################################################################
-###############################################################################
-## ##
-## REMEMBER TO EDIT USE.MASK FILES IF CHANGING ARCHITECTURE DEPENDENCIES ##
-## ##
-###############################################################################
-###############################################################################
RDEPEND="${RDEPEND}
- || (
- (
- input_devices_acecad? ( x11-drivers/xf86-input-acecad )
- input_devices_aiptek? ( x11-drivers/xf86-input-aiptek )
- input_devices_calcomp? ( x11-drivers/xf86-input-calcomp )
- input_devices_citron? ( x11-drivers/xf86-input-citron )
- input_devices_digitaledge? ( x11-drivers/xf86-input-digitaledge )
- input_devices_dmc? ( x11-drivers/xf86-input-dmc )
- input_devices_dynapro? ( x11-drivers/xf86-input-dynapro )
- input_devices_elo2300? ( x11-drivers/xf86-input-elo2300 )
- input_devices_elographics? ( x11-drivers/xf86-input-elographics )
- input_devices_evdev? ( x11-drivers/xf86-input-evdev )
- input_devices_fpit? ( x11-drivers/xf86-input-fpit )
- input_devices_hyperpen? ( x11-drivers/xf86-input-hyperpen )
- input_devices_jamstudio? ( x11-drivers/xf86-input-jamstudio )
- input_devices_joystick? ( x11-drivers/xf86-input-joystick )
- input_devices_keyboard? ( x11-drivers/xf86-input-keyboard )
- input_devices_magellan? ( x11-drivers/xf86-input-magellan )
- input_devices_magictouch? ( x11-drivers/xf86-input-magictouch )
- input_devices_microtouch? ( x11-drivers/xf86-input-microtouch )
- input_devices_mouse? ( x11-drivers/xf86-input-mouse )
- input_devices_mutouch? ( x11-drivers/xf86-input-mutouch )
- input_devices_palmax? ( x11-drivers/xf86-input-palmax )
- input_devices_penmount? ( x11-drivers/xf86-input-penmount )
- input_devices_spaceorb? ( x11-drivers/xf86-input-spaceorb )
- input_devices_summa? ( x11-drivers/xf86-input-summa )
- input_devices_tek4957? ( x11-drivers/xf86-input-tek4957 )
- input_devices_ur98? ( x11-drivers/xf86-input-ur98 )
- input_devices_vmmouse? ( x11-drivers/xf86-input-vmmouse )
- input_devices_void? ( x11-drivers/xf86-input-void )
+ input_devices_acecad? ( x11-drivers/xf86-input-acecad )
+ input_devices_aiptek? ( x11-drivers/xf86-input-aiptek )
+ input_devices_calcomp? ( x11-drivers/xf86-input-calcomp )
+ input_devices_citron? ( x11-drivers/xf86-input-citron )
+ input_devices_digitaledge? ( x11-drivers/xf86-input-digitaledge )
+ input_devices_dmc? ( x11-drivers/xf86-input-dmc )
+ input_devices_dynapro? ( x11-drivers/xf86-input-dynapro )
+ input_devices_elo2300? ( x11-drivers/xf86-input-elo2300 )
+ input_devices_elographics? ( x11-drivers/xf86-input-elographics )
+ input_devices_evdev? ( x11-drivers/xf86-input-evdev )
+ input_devices_fpit? ( x11-drivers/xf86-input-fpit )
+ input_devices_hyperpen? ( x11-drivers/xf86-input-hyperpen )
+ input_devices_jamstudio? ( x11-drivers/xf86-input-jamstudio )
+ input_devices_joystick? ( x11-drivers/xf86-input-joystick )
+ input_devices_keyboard? ( x11-drivers/xf86-input-keyboard )
+ input_devices_magellan? ( x11-drivers/xf86-input-magellan )
+ input_devices_magictouch? ( x11-drivers/xf86-input-magictouch )
+ input_devices_microtouch? ( x11-drivers/xf86-input-microtouch )
+ input_devices_mouse? ( x11-drivers/xf86-input-mouse )
+ input_devices_mutouch? ( x11-drivers/xf86-input-mutouch )
+ input_devices_palmax? ( x11-drivers/xf86-input-palmax )
+ input_devices_penmount? ( x11-drivers/xf86-input-penmount )
+ input_devices_spaceorb? ( x11-drivers/xf86-input-spaceorb )
+ input_devices_summa? ( x11-drivers/xf86-input-summa )
+ input_devices_tek4957? ( x11-drivers/xf86-input-tek4957 )
+ input_devices_ur98? ( x11-drivers/xf86-input-ur98 )
+ input_devices_vmmouse? ( x11-drivers/xf86-input-vmmouse )
+ input_devices_void? ( x11-drivers/xf86-input-void )
- input_devices_synaptics? ( x11-drivers/synaptics )
- input_devices_wacom? ( x11-misc/linuxwacom )
- )
- (
- x11-drivers/xf86-input-acecad
- x11-drivers/xf86-input-calcomp
- x11-drivers/xf86-input-citron
- x11-drivers/xf86-input-digitaledge
- x11-drivers/xf86-input-dmc
- x11-drivers/xf86-input-dynapro
- x11-drivers/xf86-input-elo2300
- x11-drivers/xf86-input-elographics
- x11-drivers/xf86-input-fpit
- x11-drivers/xf86-input-hyperpen
- x11-drivers/xf86-input-jamstudio
- x11-drivers/xf86-input-joystick
- x11-drivers/xf86-input-keyboard
- x11-drivers/xf86-input-magellan
- x11-drivers/xf86-input-magictouch
- x11-drivers/xf86-input-microtouch
- x11-drivers/xf86-input-mouse
- x11-drivers/xf86-input-mutouch
- x11-drivers/xf86-input-palmax
- x11-drivers/xf86-input-penmount
- x11-drivers/xf86-input-spaceorb
- x11-drivers/xf86-input-summa
- x11-drivers/xf86-input-tek4957
- x11-drivers/xf86-input-void
+ input_devices_synaptics? ( x11-drivers/synaptics )
+ input_devices_wacom? ( x11-misc/linuxwacom )
- kernel_linux? (
- x11-drivers/xf86-input-aiptek
- x11-drivers/xf86-input-evdev
- x11-drivers/xf86-input-ur98
- )
+ video_cards_apm? ( x11-drivers/xf86-video-apm )
+ video_cards_ark? ( x11-drivers/xf86-video-ark )
+ video_cards_chips? ( x11-drivers/xf86-video-chips )
+ video_cards_cirrus? ( x11-drivers/xf86-video-cirrus )
+ video_cards_cyrix? ( x11-drivers/xf86-video-cyrix )
+ video_cards_dummy? ( x11-drivers/xf86-video-dummy )
+ video_cards_fbdev? ( x11-drivers/xf86-video-fbdev )
+ video_cards_glint? ( x11-drivers/xf86-video-glint )
+ video_cards_i128? ( x11-drivers/xf86-video-i128 )
+ video_cards_i740? ( x11-drivers/xf86-video-i740 )
+ video_cards_i810? ( x11-drivers/xf86-video-i810 )
+ video_cards_imstt? ( x11-drivers/xf86-video-imstt )
+ video_cards_mach64? ( x11-drivers/xf86-video-ati )
+ video_cards_mga? ( x11-drivers/xf86-video-mga )
+ video_cards_neomagic? ( x11-drivers/xf86-video-neomagic )
+ video_cards_newport? ( x11-drivers/xf86-video-newport )
+ video_cards_nsc? ( x11-drivers/xf86-video-nsc )
+ video_cards_nv? ( x11-drivers/xf86-video-nv )
+ video_cards_r128? ( x11-drivers/xf86-video-ati )
+ video_cards_radeon? ( x11-drivers/xf86-video-ati )
+ video_cards_rendition? ( x11-drivers/xf86-video-rendition )
+ video_cards_s3? ( x11-drivers/xf86-video-s3 )
+ video_cards_s3virge? ( x11-drivers/xf86-video-s3virge )
+ video_cards_savage? ( x11-drivers/xf86-video-savage )
+ video_cards_siliconmotion? ( x11-drivers/xf86-video-siliconmotion )
+ video_cards_sis? ( x11-drivers/xf86-video-sis )
+ video_cards_sisusb? ( x11-drivers/xf86-video-sisusb )
+ video_cards_sunbw2? ( x11-drivers/xf86-video-sunbw2 )
+ video_cards_suncg14? ( x11-drivers/xf86-video-suncg14 )
+ video_cards_suncg3? ( x11-drivers/xf86-video-suncg3 )
+ video_cards_suncg6? ( x11-drivers/xf86-video-suncg6 )
+ video_cards_sunffb? ( x11-drivers/xf86-video-sunffb )
+ video_cards_sunleo? ( x11-drivers/xf86-video-sunleo )
+ video_cards_suntcx? ( x11-drivers/xf86-video-suntcx )
+ video_cards_tdfx? ( x11-drivers/xf86-video-tdfx )
+ video_cards_tga? ( x11-drivers/xf86-video-tga )
+ video_cards_trident? ( x11-drivers/xf86-video-trident )
+ video_cards_tseng? ( x11-drivers/xf86-video-tseng )
+ video_cards_v4l? ( x11-drivers/xf86-video-v4l )
+ video_cards_vesa? ( x11-drivers/xf86-video-vesa )
+ video_cards_vga? ( x11-drivers/xf86-video-vga )
+ video_cards_via? ( x11-drivers/xf86-video-via )
+ video_cards_vmware? ( x11-drivers/xf86-video-vmware )
+ video_cards_voodoo? ( x11-drivers/xf86-video-voodoo )
- x86? ( x11-drivers/xf86-input-vmmouse
- x11-drivers/synaptics
- x11-misc/linuxwacom
- )
- x86-fbsd? ( x11-drivers/xf86-input-vmmouse )
- amd64? ( x11-drivers/xf86-input-vmmouse
- x11-drivers/synaptics
- x11-misc/linuxwacom
- )
- ppc? ( x11-drivers/synaptics
- x11-misc/linuxwacom
- )
- ppc64? ( x11-drivers/synaptics
- x11-misc/linuxwacom
- )
- )
+ video_cards_tdfx? ( 3dfx? ( >=media-libs/glide-v3-3.10 ) )
+ video_cards_nvidia? (
+ || (
+ media-video/nvidia-glx
+ x11-drivers/nvidia-drivers
+ x11-drivers/nvidia-legacy-drivers
)
- input_devices_synaptics? ( >=x11-drivers/synaptics-0.14.4-r2 )
- || (
- (
- video_cards_apm? ( x11-drivers/xf86-video-apm )
- video_cards_ark? ( x11-drivers/xf86-video-ark )
- video_cards_chips? ( x11-drivers/xf86-video-chips )
- video_cards_cirrus? ( x11-drivers/xf86-video-cirrus )
- video_cards_cyrix? ( x11-drivers/xf86-video-cyrix )
- video_cards_dummy? ( x11-drivers/xf86-video-dummy )
- video_cards_fbdev? ( x11-drivers/xf86-video-fbdev )
- video_cards_glint? ( x11-drivers/xf86-video-glint )
- video_cards_i128? ( x11-drivers/xf86-video-i128 )
- video_cards_i740? ( x11-drivers/xf86-video-i740 )
- video_cards_i810? ( x11-drivers/xf86-video-i810 )
- video_cards_imstt? ( x11-drivers/xf86-video-imstt )
- video_cards_mach64? ( x11-drivers/xf86-video-ati )
- video_cards_mga? ( x11-drivers/xf86-video-mga )
- video_cards_neomagic? ( x11-drivers/xf86-video-neomagic )
- video_cards_newport? ( x11-drivers/xf86-video-newport )
- video_cards_nsc? ( x11-drivers/xf86-video-nsc )
- video_cards_nv? ( x11-drivers/xf86-video-nv )
- video_cards_r128? ( x11-drivers/xf86-video-ati )
- video_cards_radeon? ( x11-drivers/xf86-video-ati )
- video_cards_rendition? ( x11-drivers/xf86-video-rendition )
- video_cards_s3? ( x11-drivers/xf86-video-s3 )
- video_cards_s3virge? ( x11-drivers/xf86-video-s3virge )
- video_cards_savage? ( x11-drivers/xf86-video-savage )
- video_cards_siliconmotion? ( x11-drivers/xf86-video-siliconmotion )
- video_cards_sis? ( x11-drivers/xf86-video-sis )
- video_cards_sisusb? ( x11-drivers/xf86-video-sisusb )
- video_cards_sunbw2? ( x11-drivers/xf86-video-sunbw2 )
- video_cards_suncg14? ( x11-drivers/xf86-video-suncg14 )
- video_cards_suncg3? ( x11-drivers/xf86-video-suncg3 )
- video_cards_suncg6? ( x11-drivers/xf86-video-suncg6 )
- video_cards_sunffb? ( x11-drivers/xf86-video-sunffb )
- video_cards_sunleo? ( x11-drivers/xf86-video-sunleo )
- video_cards_suntcx? ( x11-drivers/xf86-video-suntcx )
- video_cards_tdfx? ( x11-drivers/xf86-video-tdfx )
- video_cards_tga? ( x11-drivers/xf86-video-tga )
- video_cards_trident? ( x11-drivers/xf86-video-trident )
- video_cards_tseng? ( x11-drivers/xf86-video-tseng )
- video_cards_v4l? ( x11-drivers/xf86-video-v4l )
- video_cards_vesa? ( x11-drivers/xf86-video-vesa )
- video_cards_vga? ( x11-drivers/xf86-video-vga )
- video_cards_via? ( x11-drivers/xf86-video-via )
- video_cards_vmware? ( x11-drivers/xf86-video-vmware )
- video_cards_voodoo? ( x11-drivers/xf86-video-voodoo )
-
- video_cards_tdfx? ( 3dfx? ( >=media-libs/glide-v3-3.10 ) )
- video_cards_nvidia? ( || ( media-video/nvidia-glx
- x11-drivers/nvidia-drivers
- x11-drivers/nvidia-legacy-drivers ) )
- video_cards_fglrx? ( x11-drivers/ati-drivers )
- )
- (
- x11-drivers/xf86-video-dummy
- x11-drivers/xf86-video-fbdev
-
- !hppa? (
- x11-drivers/xf86-video-ati
- x11-drivers/xf86-video-mga
-
- x11-drivers/xf86-video-sisusb
- kernel_linux? ( x11-drivers/xf86-video-v4l )
- )
-
- 3dfx? ( >=media-libs/glide-v3-3.10 )
-
- alpha? ( x11-drivers/xf86-video-cirrus
- x11-drivers/xf86-video-glint
- x11-drivers/xf86-video-nv
- x11-drivers/xf86-video-rendition
- x11-drivers/xf86-video-s3
- x11-drivers/xf86-video-s3virge
- x11-drivers/xf86-video-savage
- x11-drivers/xf86-video-siliconmotion
- x11-drivers/xf86-video-tdfx
- x11-drivers/xf86-video-tga
- x11-drivers/xf86-video-vga
- x11-drivers/xf86-video-voodoo )
- amd64? ( x11-drivers/xf86-video-apm
- x11-drivers/xf86-video-ark
- x11-drivers/xf86-video-chips
- x11-drivers/xf86-video-cirrus
- x11-drivers/xf86-video-cyrix
- x11-drivers/xf86-video-glint
- x11-drivers/xf86-video-i128
- x11-drivers/xf86-video-i810
- x11-drivers/xf86-video-neomagic
- x11-drivers/xf86-video-nv
- x11-drivers/xf86-video-rendition
- x11-drivers/xf86-video-s3
- x11-drivers/xf86-video-s3virge
- x11-drivers/xf86-video-savage
- x11-drivers/xf86-video-siliconmotion
- x11-drivers/xf86-video-sis
- x11-drivers/xf86-video-tdfx
- x11-drivers/xf86-video-tga
- x11-drivers/xf86-video-trident
- x11-drivers/xf86-video-tseng
- x11-drivers/xf86-video-vesa
- x11-drivers/xf86-video-vga
- x11-drivers/xf86-video-via
- x11-drivers/xf86-video-vmware
- x11-drivers/xf86-video-voodoo )
- arm? ( x11-drivers/xf86-video-chips
- x11-drivers/xf86-video-glint
- x11-drivers/xf86-video-nv
- x11-drivers/xf86-video-s3
- x11-drivers/xf86-video-s3virge
- x11-drivers/xf86-video-savage
- x11-drivers/xf86-video-sis
- x11-drivers/xf86-video-tdfx
- x11-drivers/xf86-video-trident
- x11-drivers/xf86-video-vga
- x11-drivers/xf86-video-voodoo )
- ia64? ( x11-drivers/xf86-video-apm
- x11-drivers/xf86-video-ark
- x11-drivers/xf86-video-chips
- x11-drivers/xf86-video-cirrus
- x11-drivers/xf86-video-cyrix
- x11-drivers/xf86-video-glint
- x11-drivers/xf86-video-i128
- x11-drivers/xf86-video-i740
- x11-drivers/xf86-video-i810
- x11-drivers/xf86-video-imstt
- x11-drivers/xf86-video-neomagic
- x11-drivers/xf86-video-nv
- x11-drivers/xf86-video-rendition
- x11-drivers/xf86-video-s3
- x11-drivers/xf86-video-s3virge
- x11-drivers/xf86-video-savage
- x11-drivers/xf86-video-siliconmotion
- x11-drivers/xf86-video-sis
- x11-drivers/xf86-video-tdfx
- x11-drivers/xf86-video-tga
- x11-drivers/xf86-video-trident
- x11-drivers/xf86-video-tseng
- x11-drivers/xf86-video-vesa
- x11-drivers/xf86-video-vga
- x11-drivers/xf86-video-via
- x11-drivers/xf86-video-voodoo )
- mips? ( x11-drivers/xf86-video-newport )
- ppc? ( x11-drivers/xf86-video-chips
- x11-drivers/xf86-video-glint
- x11-drivers/xf86-video-imstt
- x11-drivers/xf86-video-nv
- x11-drivers/xf86-video-s3
- x11-drivers/xf86-video-s3virge
- x11-drivers/xf86-video-savage
- x11-drivers/xf86-video-sis
- x11-drivers/xf86-video-tdfx
- x11-drivers/xf86-video-trident
- x11-drivers/xf86-video-vga
- x11-drivers/xf86-video-voodoo )
- ppc64? ( x11-drivers/xf86-video-nv )
- sparc? (
- x11-drivers/xf86-video-glint
- x11-drivers/xf86-video-savage
- x11-drivers/xf86-video-sunbw2
- x11-drivers/xf86-video-suncg14
- x11-drivers/xf86-video-suncg3
- x11-drivers/xf86-video-suncg6
- x11-drivers/xf86-video-sunffb
- x11-drivers/xf86-video-sunleo
- x11-drivers/xf86-video-suntcx
- x11-drivers/xf86-video-tdfx
- x11-drivers/xf86-video-vesa
- x11-drivers/xf86-video-vga
- x11-drivers/xf86-video-voodoo )
- x86? ( x11-drivers/xf86-video-apm
- x11-drivers/xf86-video-ark
- x11-drivers/xf86-video-chips
- x11-drivers/xf86-video-cirrus
- x11-drivers/xf86-video-cyrix
- x11-drivers/xf86-video-glint
- x11-drivers/xf86-video-i128
- x11-drivers/xf86-video-i740
- x11-drivers/xf86-video-i810
- x11-drivers/xf86-video-imstt
- x11-drivers/xf86-video-neomagic
- x11-drivers/xf86-video-nsc
- x11-drivers/xf86-video-nv
- x11-drivers/xf86-video-rendition
- x11-drivers/xf86-video-s3
- x11-drivers/xf86-video-s3virge
- x11-drivers/xf86-video-savage
- x11-drivers/xf86-video-siliconmotion
- x11-drivers/xf86-video-sis
- x11-drivers/xf86-video-tdfx
- x11-drivers/xf86-video-tga
- x11-drivers/xf86-video-trident
- x11-drivers/xf86-video-tseng
- x11-drivers/xf86-video-vesa
- x11-drivers/xf86-video-vga
- x11-drivers/xf86-video-via
- x11-drivers/xf86-video-vmware
- x11-drivers/xf86-video-voodoo )
- x86-fbsd? (
- x11-drivers/xf86-video-vmware )
- )
- )"
+ )
+ video_cards_fglrx? ( x11-drivers/ati-drivers )"
DEPEND="${RDEPEND}"