summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-05-04 15:17:31 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-05-04 15:17:31 +0000
commit246d1e468bd336646967fc983b59cb22d5c903d4 (patch)
tree380fb59bb646e76ed87498f905407b2afbab8671 /x11-libs/libX11
parentMove use_ functions out of global scope. (diff)
downloadhistorical-246d1e468bd336646967fc983b59cb22d5c903d4.tar.gz
historical-246d1e468bd336646967fc983b59cb22d5c903d4.tar.bz2
historical-246d1e468bd336646967fc983b59cb22d5c903d4.zip
Move use_ functions out of global scope.
Package-Manager: portage-2.1.6.13/cvs/Linux x86_64
Diffstat (limited to 'x11-libs/libX11')
-rw-r--r--x11-libs/libX11/ChangeLog7
-rw-r--r--x11-libs/libX11/libX11-1.1.2-r1.ebuild14
-rw-r--r--x11-libs/libX11/libX11-1.1.3-r1.ebuild16
-rw-r--r--x11-libs/libX11/libX11-1.1.3.ebuild14
-rw-r--r--x11-libs/libX11/libX11-1.1.4.ebuild12
-rw-r--r--x11-libs/libX11/libX11-1.1.5.ebuild12
6 files changed, 45 insertions, 30 deletions
diff --git a/x11-libs/libX11/ChangeLog b/x11-libs/libX11/ChangeLog
index c34e21a9e98b..c1fb9fde843c 100644
--- a/x11-libs/libX11/ChangeLog
+++ b/x11-libs/libX11/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libX11
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/ChangeLog,v 1.110 2009/04/16 01:56:01 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/ChangeLog,v 1.111 2009/05/04 15:09:18 ssuominen Exp $
+
+ 04 May 2009; Samuli Suominen <ssuominen@gentoo.org>
+ libX11-1.1.2-r1.ebuild, libX11-1.1.3.ebuild, libX11-1.1.3-r1.ebuild,
+ libX11-1.1.4.ebuild, libX11-1.1.5.ebuild:
+ Move use_ functions out of global scope.
16 Apr 2009; Jeroen Roovers <jer@gentoo.org> libX11-1.1.5.ebuild:
Stable for HPPA (bug #251832).
diff --git a/x11-libs/libX11/libX11-1.1.2-r1.ebuild b/x11-libs/libX11/libX11-1.1.2-r1.ebuild
index 904f0987ae69..85ec43a2e0a9 100644
--- a/x11-libs/libX11/libX11-1.1.2-r1.ebuild
+++ b/x11-libs/libX11/libX11-1.1.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/libX11-1.1.2-r1.ebuild,v 1.10 2008/05/28 13:45:53 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/libX11-1.1.2-r1.ebuild,v 1.11 2009/05/04 15:09:18 ssuominen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -25,10 +25,12 @@ DEPEND="${RDEPEND}
x11-proto/xcmiscproto
>=x11-misc/util-macros-0.99.0_p20051007"
-CONFIGURE_OPTIONS="$(use_enable ipv6)
- $(use_with xcb)"
-# xorg really doesn't like xlocale disabled.
-# $(use_enable nls xlocale)
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable ipv6)
+ $(use_with xcb)"
+ # xorg really doesn't like xlocale disabled.
+ # $(use_enable nls xlocale)
+}
PATCHES="${FILESDIR}/libX11-1.1.2-XGetMotionEvents-order-fix.patch
${FILESDIR}/libX11-1.1.2-XimGetWindowEventmask-fix.patch"
diff --git a/x11-libs/libX11/libX11-1.1.3-r1.ebuild b/x11-libs/libX11/libX11-1.1.3-r1.ebuild
index c34308331c0b..49970bcc7776 100644
--- a/x11-libs/libX11/libX11-1.1.3-r1.ebuild
+++ b/x11-libs/libX11/libX11-1.1.3-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/libX11-1.1.3-r1.ebuild,v 1.1 2008/02/28 19:39:20 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/libX11-1.1.3-r1.ebuild,v 1.2 2009/05/04 15:09:18 ssuominen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -25,9 +25,11 @@ DEPEND="${RDEPEND}
x11-proto/xcmiscproto
>=x11-misc/util-macros-0.99.0_p20051007"
-CONFIGURE_OPTIONS="$(use_enable ipv6)
- $(use_with xcb)"
-PATCHES="${FILESDIR}/libX11-1.1.3-xcb-locking.patch"
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable ipv6)
+ $(use_with xcb)"
+ # xorg really doesn't like xlocale disabled.
+ # $(use_enable nls xlocale)
+}
-# xorg really doesn't like xlocale disabled.
-# $(use_enable nls xlocale)
+PATCHES="${FILESDIR}/libX11-1.1.3-xcb-locking.patch"
diff --git a/x11-libs/libX11/libX11-1.1.3.ebuild b/x11-libs/libX11/libX11-1.1.3.ebuild
index 1cf0156511b9..a95d3b2c4554 100644
--- a/x11-libs/libX11/libX11-1.1.3.ebuild
+++ b/x11-libs/libX11/libX11-1.1.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/libX11-1.1.3.ebuild,v 1.8 2008/01/13 09:23:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/libX11-1.1.3.ebuild,v 1.9 2009/05/04 15:09:18 ssuominen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -25,7 +25,9 @@ DEPEND="${RDEPEND}
x11-proto/xcmiscproto
>=x11-misc/util-macros-0.99.0_p20051007"
-CONFIGURE_OPTIONS="$(use_enable ipv6)
- $(use_with xcb)"
-# xorg really doesn't like xlocale disabled.
-# $(use_enable nls xlocale)
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable ipv6)
+ $(use_with xcb)"
+ # xorg really doesn't like xlocale disabled.
+ # $(use_enable nls xlocale)
+}
diff --git a/x11-libs/libX11/libX11-1.1.4.ebuild b/x11-libs/libX11/libX11-1.1.4.ebuild
index 5f9cd7dfec50..b8ff9601168e 100644
--- a/x11-libs/libX11/libX11-1.1.4.ebuild
+++ b/x11-libs/libX11/libX11-1.1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/libX11-1.1.4.ebuild,v 1.11 2009/02/20 18:11:15 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/libX11-1.1.4.ebuild,v 1.12 2009/05/04 15:09:18 ssuominen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -25,10 +25,12 @@ DEPEND="${RDEPEND}
x11-proto/xcmiscproto
>=x11-misc/util-macros-0.99.0_p20051007"
-CONFIGURE_OPTIONS="$(use_enable ipv6)
- $(use_with xcb)"
-# xorg really doesn't like xlocale disabled.
-# $(use_enable nls xlocale)
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable ipv6)
+ $(use_with xcb)"
+ # xorg really doesn't like xlocale disabled.
+ # $(use_enable nls xlocale)
+}
x-modular_src_compile() {
x-modular_src_configure
diff --git a/x11-libs/libX11/libX11-1.1.5.ebuild b/x11-libs/libX11/libX11-1.1.5.ebuild
index 7e8e721de49b..3f127951e061 100644
--- a/x11-libs/libX11/libX11-1.1.5.ebuild
+++ b/x11-libs/libX11/libX11-1.1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/libX11-1.1.5.ebuild,v 1.8 2009/04/16 01:56:01 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/libX11-1.1.5.ebuild,v 1.9 2009/05/04 15:09:18 ssuominen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -25,10 +25,12 @@ DEPEND="${RDEPEND}
x11-proto/xcmiscproto
>=x11-misc/util-macros-0.99.0_p20051007"
-CONFIGURE_OPTIONS="$(use_enable ipv6)
- $(use_with xcb)"
-# xorg really doesn't like xlocale disabled.
-# $(use_enable nls xlocale)
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable ipv6)
+ $(use_with xcb)"
+ # xorg really doesn't like xlocale disabled.
+ # $(use_enable nls xlocale)
+}
x-modular_src_compile() {
x-modular_src_configure