summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-01 04:14:59 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-01 04:14:59 +0000
commitb160fdafbbedeb5ce6277256c4c16b943e931faa (patch)
tree4fa26b507a5209625e8d8cc1c44d1f8d888b24d3 /x11-libs/libast/libast-0.6.1-r1.ebuild
parentinitial commit - ebuild submitted by Matija Suklje via bug #93056 (diff)
downloadhistorical-b160fdafbbedeb5ce6277256c4c16b943e931faa.tar.gz
historical-b160fdafbbedeb5ce6277256c4c16b943e931faa.tar.bz2
historical-b160fdafbbedeb5ce6277256c4c16b943e931faa.zip
Fix bogus version warnings with patch from upstream CVS #94479 by Alexander Jenisch.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'x11-libs/libast/libast-0.6.1-r1.ebuild')
-rw-r--r--x11-libs/libast/libast-0.6.1-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-libs/libast/libast-0.6.1-r1.ebuild b/x11-libs/libast/libast-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..348c39ec103f
--- /dev/null
+++ b/x11-libs/libast/libast-0.6.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/libast-0.6.1-r1.ebuild,v 1.1 2005/06/01 04:14:59 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="LIBrary of Assorted Spiffy Things"
+HOMEPAGE="http://www.eterm.org/download/"
+SRC_URI="http://www.eterm.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="imlib mmx pcre"
+
+DEPEND="virtual/x11
+ =media-libs/freetype-2*
+ imlib? ( media-libs/imlib2 )
+ pcre? ( dev-libs/libpcre )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-config-warning.patch #94479
+}
+
+src_compile() {
+ local myregexp="posix"
+ use pcre && myregexp="pcre"
+ econf \
+ $(use_with imlib) \
+ $(use_enable mmx) \
+ --with-regexp=${myregexp} \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc README DESIGN ChangeLog
+}