summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-03-20 17:48:10 +0000
committerFabian Groffen <grobian@gentoo.org>2010-03-20 17:48:10 +0000
commit683a03afeca830f1406c04d2dc303805d4d1b84e (patch)
tree683e4edd487a4a5a303385c64640f8c63b05cba2 /x11-libs/openmotif/openmotif-2.3.3.ebuild
parentnet-misc/noarp removal (pending 2010-03-09) see bug #239773 for reference (diff)
downloadhistorical-683a03afeca830f1406c04d2dc303805d4d1b84e.tar.gz
historical-683a03afeca830f1406c04d2dc303805d4d1b84e.tar.bz2
historical-683a03afeca830f1406c04d2dc303805d4d1b84e.zip
Add patch to fix compilation on Mac OS X using patch grabbed from upstream bugtracker
Package-Manager: portage-2.2.00.15819-prefix/cvs/Darwin powerpc
Diffstat (limited to 'x11-libs/openmotif/openmotif-2.3.3.ebuild')
-rw-r--r--x11-libs/openmotif/openmotif-2.3.3.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/x11-libs/openmotif/openmotif-2.3.3.ebuild b/x11-libs/openmotif/openmotif-2.3.3.ebuild
index 64916e98827a..24405739c8d6 100644
--- a/x11-libs/openmotif/openmotif-2.3.3.ebuild
+++ b/x11-libs/openmotif/openmotif-2.3.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.3.3.ebuild,v 1.1 2010/03/19 00:25:59 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.3.3.ebuild,v 1.2 2010/03/20 17:48:09 grobian Exp $
-EAPI=3
+EAPI="3"
inherit autotools eutils flag-o-matic multilib
@@ -79,6 +79,7 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.3.2-darwin.patch"
epatch "${FILESDIR}/${PN}-2.3.2-sanitise-paths.patch"
epatch "${FILESDIR}/${PN}-2.3.2-libpng14.patch"
[[ ${CHOST} == *-solaris2.11 ]] \
@@ -123,11 +124,11 @@ src_configure() {
}
src_compile() {
- emake -j1 MWMRCDIR=/etc/X11/mwm || die "emake failed"
+ emake -j1 MWMRCDIR="${EPREFIX}"/etc/X11/mwm || die "emake failed"
}
src_install() {
- emake -j1 DESTDIR="${D}" MWMRCDIR=/etc/X11/mwm install \
+ emake -j1 DESTDIR="${D}" MWMRCDIR="${EPREFIX}"/etc/X11/mwm install \
|| die "emake install failed"
# mwm default configs