summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn N. Laliberte <allanonjl@gentoo.org>2006-06-30 17:40:53 +0000
committerJohn N. Laliberte <allanonjl@gentoo.org>2006-06-30 17:40:53 +0000
commit9e127157c446bcdcdc6e0eb9312f0e3ba39ce269 (patch)
tree275c1a3e9f9b4dc46f4d11a307518b1935a2e742 /x11-libs/pango
parentNew nightlie. (diff)
downloadhistorical-9e127157c446bcdcdc6e0eb9312f0e3ba39ce269.tar.gz
historical-9e127157c446bcdcdc6e0eb9312f0e3ba39ce269.tar.bz2
historical-9e127157c446bcdcdc6e0eb9312f0e3ba39ce269.zip
new version.
Package-Manager: portage-2.1.1_pre1-r2
Diffstat (limited to 'x11-libs/pango')
-rw-r--r--x11-libs/pango/ChangeLog8
-rw-r--r--x11-libs/pango/files/digest-pango-1.12.33
-rw-r--r--x11-libs/pango/pango-1.12.3.ebuild73
3 files changed, 83 insertions, 1 deletions
diff --git a/x11-libs/pango/ChangeLog b/x11-libs/pango/ChangeLog
index 30e42fdcea38..cf6ee4057ec4 100644
--- a/x11-libs/pango/ChangeLog
+++ b/x11-libs/pango/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/pango
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.137 2006/06/25 20:28:46 the_paya Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.138 2006/06/30 17:40:53 allanonjl Exp $
+
+*pango-1.12.3 (30 Jun 2006)
+
+ 30 Jun 2006; <allanonl@gentoo.org> -pango-1.12.2.ebuild,
+ +pango-1.12.3.ebuild:
+ new version.
25 Jun 2006; Javier Villavicencio <the_paya@gentoo.org>
pango-1.12.2.ebuild:
diff --git a/x11-libs/pango/files/digest-pango-1.12.3 b/x11-libs/pango/files/digest-pango-1.12.3
new file mode 100644
index 000000000000..0c9460cba8db
--- /dev/null
+++ b/x11-libs/pango/files/digest-pango-1.12.3
@@ -0,0 +1,3 @@
+MD5 c8178e11a895166d86990bb2c38d831b pango-1.12.3.tar.bz2 1226579
+RMD160 7692828276e9b5a54b0b8c32fa07d7db6ac45bed pango-1.12.3.tar.bz2 1226579
+SHA256 73ac1b956ff16df41c41355231aae3f757500c83ab912108370ea7b70c43fd18 pango-1.12.3.tar.bz2 1226579
diff --git a/x11-libs/pango/pango-1.12.3.ebuild b/x11-libs/pango/pango-1.12.3.ebuild
new file mode 100644
index 000000000000..88baec9815e9
--- /dev/null
+++ b/x11-libs/pango/pango-1.12.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.12.3.ebuild,v 1.1 2006/06/30 17:40:53 allanonjl Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="Text rendering and layout library"
+HOMEPAGE="http://www.pango.org/"
+
+LICENSE="LGPL-2 FTL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND="|| ( (
+ x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXft
+ )
+ virtual/x11 )
+ >=dev-libs/glib-2.10.0
+ >=media-libs/fontconfig-1.0.1
+ >=media-libs/freetype-2
+ >x11-libs/cairo-1.0.0"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ || ( x11-proto/xproto virtual/x11 )
+ doc? (
+ >=dev-util/gtk-doc-1
+ ~app-text/docbook-xml-dtd-4.1.2 )"
+
+DOCS="AUTHORS ChangeLog* NEWS README TODO*"
+
+src_unpack() {
+
+ unpack "${A}"
+ cd "${S}"
+
+ # Some enhancements from Redhat
+ # These NEED to go upstream.
+ epatch ${FILESDIR}/pango-1.11.3-xfonts.patch
+ epatch ${FILESDIR}/${PN}-1.10.2-slighthint.patch
+
+ # make config file location host specific so that a 32bit and 64bit pango
+ # wont fight with each other on a multilib system
+ use amd64 && epatch ${FILESDIR}/pango-1.2.5-lib64.patch
+ # and this line is just here to make building emul-linux-x86-gtklibs a bit
+ # easier, so even this should be amd64 specific.
+ use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && epatch ${FILESDIR}/pango-1.2.5-lib64.patch
+
+ epunt_cxx
+}
+
+src_install() {
+
+ gnome2_src_install
+
+ rm ${D}/etc/pango/pango.modules
+}
+
+pkg_postinst() {
+
+ if [ "${ROOT}" == "/" ] ; then
+ einfo "Generating modules listing..."
+ use amd64 && PANGO_CONFDIR="/etc/pango/${CHOST}"
+ use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && PANGO_CONFDIR="/etc/pango/${CHOST}"
+ PANGO_CONFDIR=${PANGO_CONFDIR:=/etc/pango}
+ mkdir -p ${PANGO_CONFDIR}
+ pango-querymodules > ${PANGO_CONFDIR}/pango.modules
+ fi
+
+}