summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2014-10-22 17:15:56 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2014-10-22 17:15:56 +0000
commit3e335c62a4950d5abc35579cd8870fe3db82b219 (patch)
treef16d834d2235bf13e4c8bc8b43cf18ce7324821d /x11-libs/pixman/pixman-0.32.6.ebuild
parentgrub:0 - Only apply -fuse-ld=bfd when gcc is new enough to support it, bug 52... (diff)
downloadhistorical-3e335c62a4950d5abc35579cd8870fe3db82b219.tar.gz
historical-3e335c62a4950d5abc35579cd8870fe3db82b219.tar.bz2
historical-3e335c62a4950d5abc35579cd8870fe3db82b219.zip
Version bump.
Package-Manager: portage-2.2.8-r2/cvs/Linux x86_64 Manifest-Sign-Key: 0x2324E7B566DF2611!
Diffstat (limited to 'x11-libs/pixman/pixman-0.32.6.ebuild')
-rw-r--r--x11-libs/pixman/pixman-0.32.6.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-libs/pixman/pixman-0.32.6.ebuild b/x11-libs/pixman/pixman-0.32.6.ebuild
new file mode 100644
index 000000000000..7802f87b4e90
--- /dev/null
+++ b/x11-libs/pixman/pixman-0.32.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pixman/pixman-0.32.6.ebuild,v 1.1 2014/10/22 17:15:49 chithanh Exp $
+
+EAPI=5
+XORG_MULTILIB=yes
+inherit xorg-2 toolchain-funcs versionator
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/pixman"
+DESCRIPTION="Low-level pixel manipulation routines"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="altivec iwmmxt loongson2f mmxext neon sse2 ssse3"
+RDEPEND="abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtklibs-20131008
+ !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ )"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable mmxext mmx)
+ $(use_enable sse2)
+ $(use_enable ssse3)
+ $(use_enable altivec vmx)
+ $(use_enable neon arm-neon)
+ $(use_enable iwmmxt arm-iwmmxt)
+ $(use_enable loongson2f loongson-mmi)
+ --disable-gtk
+ --disable-libpng
+ )
+ xorg-2_src_configure
+}