summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-09-19 00:19:07 +0000
committerBen de Groot <yngwin@gentoo.org>2008-09-19 00:19:07 +0000
commite58d212d41657b20cf06cc1a0d39b98350c85814 (patch)
treea627dcfd8d78d895e18c6f25752847d4fc7b9f11 /x11-libs/qt-opengl
parentVersion bump. (diff)
downloadhistorical-e58d212d41657b20cf06cc1a0d39b98350c85814.tar.gz
historical-e58d212d41657b20cf06cc1a0d39b98350c85814.tar.bz2
historical-e58d212d41657b20cf06cc1a0d39b98350c85814.zip
qt-4.4.2 version bump
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.26.5 i686
Diffstat (limited to 'x11-libs/qt-opengl')
-rw-r--r--x11-libs/qt-opengl/ChangeLog7
-rw-r--r--x11-libs/qt-opengl/qt-opengl-4.4.2.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/x11-libs/qt-opengl/ChangeLog b/x11-libs/qt-opengl/ChangeLog
index b24bf535c6ef..6a900a0f0fd9 100644
--- a/x11-libs/qt-opengl/ChangeLog
+++ b/x11-libs/qt-opengl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-opengl
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/ChangeLog,v 1.12 2008/08/16 03:27:46 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/ChangeLog,v 1.13 2008/09/19 00:13:03 yngwin Exp $
+
+*qt-opengl-4.4.2 (19 Sep 2008)
+
+ 19 Sep 2008; Ben de Groot <yngwin@gentoo.org> +qt-opengl-4.4.2.ebuild:
+ Version bump
16 Aug 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/x11-libs/qt-opengl/qt-opengl-4.4.2.ebuild b/x11-libs/qt-opengl/qt-opengl-4.4.2.ebuild
new file mode 100644
index 000000000000..e7692e1ad75a
--- /dev/null
+++ b/x11-libs/qt-opengl/qt-opengl-4.4.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/qt-opengl-4.4.2.ebuild,v 1.1 2008/09/19 00:13:03 yngwin Exp $
+
+EAPI="1"
+inherit qt4-build
+
+DESCRIPTION="The OpenGL module for the Qt toolkit."
+HOMEPAGE="http://www.trolltech.com/"
+
+LICENSE="|| ( GPL-3 GPL-2 )"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+qt3support"
+
+DEPEND="~x11-libs/qt-gui-${PV}
+ !<=x11-libs/qt-4.4.0_alpha:${SLOT}
+ virtual/opengl
+ virtual/glu"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/opengl"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}"
+QCONFIG_ADD="opengl"
+QCONFIG_DEFINE="QT_OPENGL"
+
+pkg_setup() {
+ use qt3support && QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK}
+ ~x11-libs/qt-core-${PV} qt3support"
+ qt4-build_pkg_setup
+}
+
+src_compile() {
+ local myconf
+ myconf="${myconf} -opengl
+ $(qt_use qt3support)"
+
+ # Not building tools/designer/src/plugins/tools/view3d as it's commented out of the build in the source
+ qt4-build_src_compile
+}