summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-09-12 14:04:55 +0000
committerPacho Ramos <pacho@gentoo.org>2011-09-12 14:04:55 +0000
commit1812fc29b6dec34c8020693e3e7caeec3f03aea8 (patch)
tree002c4cd76c7d9191a66b00b2c778cc655f8efd8d /x11-libs/rep-gtk/rep-gtk-0.90.7.ebuild
parentQA: avoid creating empty directory; the udev rules are not installed in /udev... (diff)
downloadhistorical-1812fc29b6dec34c8020693e3e7caeec3f03aea8.tar.gz
historical-1812fc29b6dec34c8020693e3e7caeec3f03aea8.tar.bz2
historical-1812fc29b6dec34c8020693e3e7caeec3f03aea8.zip
Version bump, drop .la files.
Package-Manager: portage-2.1.10.15/cvs/Linux x86_64
Diffstat (limited to 'x11-libs/rep-gtk/rep-gtk-0.90.7.ebuild')
-rw-r--r--x11-libs/rep-gtk/rep-gtk-0.90.7.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-libs/rep-gtk/rep-gtk-0.90.7.ebuild b/x11-libs/rep-gtk/rep-gtk-0.90.7.ebuild
new file mode 100644
index 000000000000..a9823c3055c1
--- /dev/null
+++ b/x11-libs/rep-gtk/rep-gtk-0.90.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/rep-gtk-0.90.7.ebuild,v 1.1 2011/09/12 14:04:55 pacho Exp $
+
+EAPI="4"
+
+inherit eutils multilib
+
+DESCRIPTION="A GTK+/libglade/GNOME language binding for the librep Lisp environment"
+HOMEPAGE="http://rep-gtk.sourceforge.net/"
+SRC_URI="http://download.tuxfamily.org/librep/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="gtk-2.0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/librep-0.90.5
+ >=dev-libs/glib-2.6:2
+ >=x11-libs/gtk+-2.24.0:2"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
+
+src_configure() {
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ --disable-static
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ find "${D}" -name '*.la' -exec rm -f {} + || die "la file removal failed"
+ dodoc AUTHORS ChangeLog README* TODO
+}