summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-03-20 13:01:51 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-03-20 13:01:51 +0000
commit2066947028749f8f1bfdba209ab3e406594e5811 (patch)
tree51399749067e4755c58803abf3d46ed1534bc60d /x11-libs
parentRemoved usage of pic USE flag (diff)
downloadhistorical-2066947028749f8f1bfdba209ab3e406594e5811.tar.gz
historical-2066947028749f8f1bfdba209ab3e406594e5811.tar.bz2
historical-2066947028749f8f1bfdba209ab3e406594e5811.zip
pic crap removed
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/evas/evas-1.0.0.20030220_pre5.ebuild14
-rw-r--r--x11-libs/ewl/ewl-0.0.2.20030310.ebuild21
2 files changed, 15 insertions, 20 deletions
diff --git a/x11-libs/evas/evas-1.0.0.20030220_pre5.ebuild b/x11-libs/evas/evas-1.0.0.20030220_pre5.ebuild
index e852c0bb5d84..58821b341610 100644
--- a/x11-libs/evas/evas-1.0.0.20030220_pre5.ebuild
+++ b/x11-libs/evas/evas-1.0.0.20030220_pre5.ebuild
@@ -1,9 +1,12 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/evas/evas-1.0.0.20030220_pre5.ebuild,v 1.3 2003/03/11 17:23:19 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/evas/evas-1.0.0.20030220_pre5.ebuild,v 1.4 2003/03/20 13:01:51 seemant Exp $
inherit flag-o-matic
+IUSE="X mmx opengl jpeg png directfb fbcon"
+
+S=${WORKDIR}/${PN}
DESCRIPTION="hardware-accelerated canvas API"
HOMEPAGE="http://www.enlightenment.org/pages/evas.html"
SRC_URI="mirror://gentoo/${P}.tar.bz2
@@ -12,7 +15,6 @@ SRC_URI="mirror://gentoo/${P}.tar.bz2
LICENSE="as-is"
SLOT="0"
KEYWORDS="~x86 ~ppc ~alpha"
-IUSE="X mmx opengl jpeg png pic directfb fbcon"
DEPEND="virtual/x11
>=media-libs/imlib2-1.0.6.2003*
@@ -22,8 +24,6 @@ DEPEND="virtual/x11
jpeg? ( media-libs/jpeg )
directfb? ( >=dev-libs/DirectFB-0.9.16 )"
-S=${WORKDIR}/${PN}
-
src_compile() {
env NOCONFIGURE=yes ./autogen.sh || die "could not autogen"
@@ -68,12 +68,10 @@ src_compile() {
--enable-convert-32-bgr-8888 \
--enable-convert-32-bgrx-8888 \
--enable-convert-32-rgb-rot-0 \
- --with-gnu-ld \
- `use_with pic` \
`use_enable png image-loader-png` \
`use_enable jpeg image-loader-jpeg` \
- ${myconf} \
- || die
+ ${myconf} || die
+
emake || die
}
diff --git a/x11-libs/ewl/ewl-0.0.2.20030310.ebuild b/x11-libs/ewl/ewl-0.0.2.20030310.ebuild
index 65bf7e503ced..098191d35732 100644
--- a/x11-libs/ewl/ewl-0.0.2.20030310.ebuild
+++ b/x11-libs/ewl/ewl-0.0.2.20030310.ebuild
@@ -1,30 +1,27 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/ewl/ewl-0.0.2.20030310.ebuild,v 1.2 2003/03/14 19:21:53 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/ewl/ewl-0.0.2.20030310.ebuild,v 1.3 2003/03/20 12:59:58 seemant Exp $
+
+IUSE=""
inherit flag-o-matic
+S=${WORKDIR}/${PN}
DESCRIPTION="simple-to-use general purpose widget library"
HOMEPAGE="http://www.enlightenment.org/pages/ewl.html"
-SRC_URI="mirror://gentoo/${P}.tar.bz2
- http://wh0rd.tk/gentoo/distfiles/${P}.tar.bz2"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
-LICENSE="as-is"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~alpha"
-IUSE="pic"
+LICENSE="as-is"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
-DEPEND="virtual/glibc
- sys-devel/gcc
- >=x11-libs/evas-1.0.0.2003*
+DEPEND=">=x11-libs/evas-1.0.0.2003*
>=media-libs/ebits-1.0.1.2003*
>=dev-db/edb-1.0.3.2003*
>=x11-libs/ecore-0.0.2.2003*
>=dev-libs/ewd-0.0.1.2003*
>=media-libs/etox-0.0.1.2003*"
-S=${WORKDIR}/${PN}
-
src_compile() {
cp autogen.sh{,.old}
sed -e 's:.*configure.*::' autogen.sh.old > autogen.sh
@@ -32,7 +29,7 @@ src_compile() {
use alpha && append-flags -fPIC
- econf `use_with pic` --with-gnu-ld || die
+ econf || die
emake || die
}