summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-06-22 14:38:07 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-06-22 14:38:07 +0000
commitaa45f0eb1517685deb7656248a6e6e293d69a147 (patch)
tree83be982fe07aaf9c3fe743ae3766e1dc4a07f4a7 /x11-libs
parentbump of revision number, now build both new and old style packages. (diff)
downloadhistorical-aa45f0eb1517685deb7656248a6e6e293d69a147.tar.gz
historical-aa45f0eb1517685deb7656248a6e6e293d69a147.tar.bz2
historical-aa45f0eb1517685deb7656248a6e6e293d69a147.zip
fixes
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/rep-gtk/rep-gtk-20020611.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/x11-libs/rep-gtk/rep-gtk-20020611.ebuild b/x11-libs/rep-gtk/rep-gtk-20020611.ebuild
index fa780b8aeb3c..91f3a24364dd 100644
--- a/x11-libs/rep-gtk/rep-gtk-20020611.ebuild
+++ b/x11-libs/rep-gtk/rep-gtk-20020611.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/rep-gtk-20020611.ebuild,v 1.1 2002/06/12 01:24:30 stroke Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/rep-gtk-20020611.ebuild,v 1.2 2002/06/22 14:38:07 azarah Exp $
# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
DEBUG="yes"
@@ -32,8 +32,6 @@ DEPEND="virtual/glibc
>=gnome-base/libglade-2.0.0"
src_compile() {
- local myconf
-
./configure --host=${CHOST} \
--with-libglade \
--prefix=/usr \
@@ -41,15 +39,18 @@ src_compile() {
--with-gnome --with-libglade \
--infodir=/usr/share/info || die
- emake || die
+ emake host_type=${CHOST} || die
}
src_install() {
- make DESTDIR=${D} install || die
+# make DESTDIR=${D} install || die
+ make install \
+ host_type=${CHOST} \
+ installdir=${D}/usr/lib/rep/${CHOST} || die
# insinto /usr/include
# doins src/rep_config.h
-# dodoc AUTHORS BUGS COPYING ChangeLog NEWS README THANKS TODO DOC
-# docinto doc
-# dodoc doc/*
+ dodoc AUTHORS BUGS COPYING ChangeLog HACKING \
+ NEWS README* TODO
}
+