summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-05-30 18:29:20 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-05-30 18:29:20 +0000
commit2c353bea18019c5af0d95940feb6fdddcfc4d1db (patch)
treeccd31585fddc761952d11276c63cf731b1329b5e /x11-misc/bbppp/bbppp-0.2.5.ebuild
parentalpha/arm/ia64/m68k/s390/sh/sparc stable wrt #311725 (diff)
downloadhistorical-2c353bea18019c5af0d95940feb6fdddcfc4d1db.tar.gz
historical-2c353bea18019c5af0d95940feb6fdddcfc4d1db.tar.bz2
historical-2c353bea18019c5af0d95940feb6fdddcfc4d1db.zip
Version bump. Fixing build with as-needed wrt bug 248552. Thanks Diego for report
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'x11-misc/bbppp/bbppp-0.2.5.ebuild')
-rw-r--r--x11-misc/bbppp/bbppp-0.2.5.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-misc/bbppp/bbppp-0.2.5.ebuild b/x11-misc/bbppp/bbppp-0.2.5.ebuild
new file mode 100644
index 000000000000..c396f41cd80b
--- /dev/null
+++ b/x11-misc/bbppp/bbppp-0.2.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbppp/bbppp-0.2.5.ebuild,v 1.1 2010/05/30 18:29:20 xarthisius Exp $
+
+EAPI=2
+
+inherit autotools eutils
+
+DESCRIPTION="blackbox ppp frontend/monitor"
+HOMEPAGE="http://bbtools.windsofstorm.net/sources/available.phtml#bbppp"
+SRC_URI="mirror://sourceforge/bbtools/${PN}/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND="${DEPEND}
+ virtual/blackbox"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc3-multiline.patch \
+ "${FILESDIR}"/${PN}-asneeded.patch
+ eautoreconf
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+ dodoc README AUTHORS BUGS ChangeLog NEWS TODO data/README.bbppp || die
+ rm "${D}"/usr/share/bbtools/README.bbppp
+}
+
+pkg_postinst() {
+ # don't assume blackbox exists because virtual/blackbox is installed
+ if [[ -x ${ROOT}/usr/bin/blackbox ]] ; then
+ if ! grep bbppp "${ROOT}"/usr/bin/blackbox &>/dev/null ; then
+ sed -e "s/.*blackbox/exec \/usr\/bin\/bbppp \&\n&/" blackbox | cat > blackbox
+ fi
+ fi
+}