summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-08-30 09:46:37 +0000
committerDonny Davies <woodchip@gentoo.org>2001-08-30 09:46:37 +0000
commit56368f56c5549df74bdbf2e67033ecbd03075cac (patch)
tree095d08d401dfe848f83e322113de74f937dc9cad /x11-misc/bubblemon
parentweeee a fun little dockapp (diff)
downloadhistorical-56368f56c5549df74bdbf2e67033ecbd03075cac.tar.gz
historical-56368f56c5549df74bdbf2e67033ecbd03075cac.tar.bz2
historical-56368f56c5549df74bdbf2e67033ecbd03075cac.zip
Added a system load monitor featuring a swimming duck!
Diffstat (limited to 'x11-misc/bubblemon')
-rw-r--r--x11-misc/bubblemon/bubblemon-1.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-misc/bubblemon/bubblemon-1.4.ebuild b/x11-misc/bubblemon/bubblemon-1.4.ebuild
new file mode 100644
index 000000000000..059b3d6b720b
--- /dev/null
+++ b/x11-misc/bubblemon/bubblemon-1.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bubblemon/bubblemon-1.4.ebuild,v 1.1 2001/08/30 09:46:37 woodchip Exp $
+
+DESCRIPTION="A fun monitoring applet for your desktop, complete with swimming duck"
+HOMEPAGE="http://www.ne.jp/asahi/linux/timecop"
+
+S=${WORKDIR}/${PN}-dockapp-${PV}
+SRC_URI="http://www.ne.jp/asahi/linux/timecop/software/${PN}-dockapp-${PV}.tar.gz"
+DEPEND=">=x11-libs/gtk+-1.2.8"
+
+src_compile() {
+
+ # respect users CFLAGS and enable a neat feature turned off by default
+ sed -e "s/CFLAGS = -O3/CFLAGS = ${CFLAGS}/" \
+ -e "s/# EXTRA += -DUPSIDE_DOWN_DUCK/EXTRA += -DUPSIDE_DOWN_DUCK/" \
+ Makefile | cat > Makefile
+ make || die
+}
+
+src_install () {
+
+ into /usr/X11R6
+ dobin bubblemon
+ # im putting the extra goodies in with docs. *very* small :)
+ dodoc INSTALL ChangeLog README doc/* misc/*
+}