summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2004-04-27 19:58:50 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2004-04-27 19:58:50 +0000
commit8a6b52dd119b42efb44d083d4434a86686b2a3fa (patch)
treec09dd32c3ce9a2df0318ab385c9b0b202d98225f /x11-misc/pypanel/pypanel-1.2.ebuild
parent(no commit message) (diff)
downloadhistorical-8a6b52dd119b42efb44d083d4434a86686b2a3fa.tar.gz
historical-8a6b52dd119b42efb44d083d4434a86686b2a3fa.tar.bz2
historical-8a6b52dd119b42efb44d083d4434a86686b2a3fa.zip
New upstream version. Fixes #47954.
Diffstat (limited to 'x11-misc/pypanel/pypanel-1.2.ebuild')
-rw-r--r--x11-misc/pypanel/pypanel-1.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-misc/pypanel/pypanel-1.2.ebuild b/x11-misc/pypanel/pypanel-1.2.ebuild
new file mode 100644
index 000000000000..30ac04572b7d
--- /dev/null
+++ b/x11-misc/pypanel/pypanel-1.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/pypanel/pypanel-1.2.ebuild,v 1.1 2004/04/27 19:58:50 karltk Exp $
+
+inherit distutils
+
+DESCRIPTION="PyPanel is a lightweight panel/taskbar for X11 window managers."
+HOMEPAGE="http://pypanel.sourceforge.net"
+SRC_URI="mirror://sourceforge/pypanel/PyPanel-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+DEPEND="virtual/x11
+ >=dev-lang/python-2.2.3-r1
+ >=dev-python/python-xlib-0.12"
+S="${WORKDIR}/PyPanel-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Removing offensive material
+ sed -i -e "s/%D %I:%M %p/%Y-%m-%d %H:%M/" pypanelrc
+}
+
+src_install() {
+ distutils_src_install
+}
+
+pkg_postinst() {
+ ewarn "If you previously ran 0.8, please remove ~/.pypanelrc before starting 1.2!"
+}