summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2006-12-04 16:08:42 +0000
committerMarinus Schraal <foser@gentoo.org>2006-12-04 16:08:42 +0000
commit79f3d3435b3c8db790c20e444db33da328fb126e (patch)
treef8f406dfb8f588debd1028d4a78e331b03cf7168 /x11-misc/shared-mime-info
parentStable for HPPA (bug #151879). (diff)
downloadhistorical-79f3d3435b3c8db790c20e444db33da328fb126e.tar.gz
historical-79f3d3435b3c8db790c20e444db33da328fb126e.tar.bz2
historical-79f3d3435b3c8db790c20e444db33da328fb126e.zip
it.. i see no topic protection.. its there by the grace of the gods apparently
Package-Manager: portage-2.1.1-r2
Diffstat (limited to 'x11-misc/shared-mime-info')
-rw-r--r--x11-misc/shared-mime-info/ChangeLog7
-rw-r--r--x11-misc/shared-mime-info/files/digest-shared-mime-info-0.193
-rw-r--r--x11-misc/shared-mime-info/shared-mime-info-0.19.ebuild46
3 files changed, 55 insertions, 1 deletions
diff --git a/x11-misc/shared-mime-info/ChangeLog b/x11-misc/shared-mime-info/ChangeLog
index f939d57fa129..e1fec054b790 100644
--- a/x11-misc/shared-mime-info/ChangeLog
+++ b/x11-misc/shared-mime-info/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/shared-mime-info
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/shared-mime-info/ChangeLog,v 1.63 2006/10/20 13:31:42 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/shared-mime-info/ChangeLog,v 1.64 2006/12/04 16:08:42 foser Exp $
+
+*shared-mime-info-0.19 (04 Dec 2006)
+
+ 04 Dec 2006; Marinus Schraal <foser@gentoo.org> shared-mime-info-0.19.ebuild :
+ New release per #150428
20 Oct 2006; Aron Griffis <agriffis@gentoo.org>
shared-mime-info-0.17-r2.ebuild:
diff --git a/x11-misc/shared-mime-info/files/digest-shared-mime-info-0.19 b/x11-misc/shared-mime-info/files/digest-shared-mime-info-0.19
new file mode 100644
index 000000000000..20a01583b7da
--- /dev/null
+++ b/x11-misc/shared-mime-info/files/digest-shared-mime-info-0.19
@@ -0,0 +1,3 @@
+MD5 056a86a8245aecfd9c80740380c5265a shared-mime-info-0.19.tar.gz 595168
+RMD160 edb36ea4c23f608749cb9e8bfa747297a10afed1 shared-mime-info-0.19.tar.gz 595168
+SHA256 4aae542285cdf011d8486ece8c2c8b0431ce1e25e7eb7efd39593f04bc76d118 shared-mime-info-0.19.tar.gz 595168
diff --git a/x11-misc/shared-mime-info/shared-mime-info-0.19.ebuild b/x11-misc/shared-mime-info/shared-mime-info-0.19.ebuild
new file mode 100644
index 000000000000..19294182cbc9
--- /dev/null
+++ b/x11-misc/shared-mime-info/shared-mime-info-0.19.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/shared-mime-info/shared-mime-info-0.19.ebuild,v 1.1 2006/12/04 16:08:42 foser Exp $
+
+inherit eutils fdo-mime
+
+DESCRIPTION="The Shared MIME-info Database specification"
+HOMEPAGE="http://www.freedesktop.org/software/shared-mime-info"
+SRC_URI="http://www.freedesktop.org/~hadess/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2
+ >=dev-libs/libxml2-2.4"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.29"
+
+src_compile() {
+
+ econf --disable-update-mimedb || die
+ emake || die
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc ChangeLog NEWS README
+
+}
+
+pkg_postinst() {
+
+ fdo-mime_mime_database_update
+
+}
+
+# FIXME :
+# This ebuild should probably also remove the stuff it now leaves behind
+# in /usr/share/mime