summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-02-20 14:54:09 +0000
committerJustin Lecher <jlec@gentoo.org>2015-02-20 14:54:09 +0000
commit232984022d36d76b0d1a3be79f0042a489104063 (patch)
treee722f903a39476fc4547d5e155b0c9815a1114d6 /x11-misc/viewglob/viewglob-2.0.4-r1.ebuild
parentDrop old; move to EAPI=5, fixes #478598 (diff)
downloadhistorical-232984022d36d76b0d1a3be79f0042a489104063.tar.gz
historical-232984022d36d76b0d1a3be79f0042a489104063.tar.bz2
historical-232984022d36d76b0d1a3be79f0042a489104063.zip
Bump to EAPI=5 and fix underlinking problem, #512478 & #540802
Package-Manager: portage-2.2.17/cvs/Linux x86_64 Manifest-Sign-Key: 0xB9D4F231BD1558AB!
Diffstat (limited to 'x11-misc/viewglob/viewglob-2.0.4-r1.ebuild')
-rw-r--r--x11-misc/viewglob/viewglob-2.0.4-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-misc/viewglob/viewglob-2.0.4-r1.ebuild b/x11-misc/viewglob/viewglob-2.0.4-r1.ebuild
new file mode 100644
index 000000000000..3c9e6336e7f8
--- /dev/null
+++ b/x11-misc/viewglob/viewglob-2.0.4-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/viewglob/viewglob-2.0.4-r1.ebuild,v 1.1 2015/02/20 14:54:08 jlec Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils readme.gentoo
+
+DESCRIPTION="Graphical display of directories and globs referenced at the shell prompt"
+HOMEPAGE="http://viewglob.sourceforge.net/"
+SRC_URI="mirror://sourceforge/viewglob/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/glib
+ x11-libs/gtk+:2
+ || ( app-shells/bash app-shells/zsh )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-underlinking.patch
+)
+
+src_install() {
+ autotools-utils_src_install
+ readme.gentoo_src_install
+}