summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-06-14 20:49:55 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-06-14 20:49:55 +0000
commit6b54d162c9ffd39144ee89612dc3998bf5f1cec5 (patch)
tree9e3bfc471ba925fcb83a6cf57cea6f22a82a1545 /x11-misc/x2x/x2x-1.27.ebuild
parentnew revision (diff)
downloadhistorical-6b54d162c9ffd39144ee89612dc3998bf5f1cec5.tar.gz
historical-6b54d162c9ffd39144ee89612dc3998bf5f1cec5.tar.bz2
historical-6b54d162c9ffd39144ee89612dc3998bf5f1cec5.zip
New package. Fixes #3346
Diffstat (limited to 'x11-misc/x2x/x2x-1.27.ebuild')
-rw-r--r--x11-misc/x2x/x2x-1.27.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-misc/x2x/x2x-1.27.ebuild b/x11-misc/x2x/x2x-1.27.ebuild
new file mode 100644
index 000000000000..fa21bfcddb11
--- /dev/null
+++ b/x11-misc/x2x/x2x-1.27.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x2x/x2x-1.27.ebuild,v 1.1 2002/06/14 20:49:55 rphillips Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="An utility to connect the Mouse and KeyBoard to another X"
+HOMEPAGE="http://www.the-labs.com/X11/#x2x"
+LICENSE="as-is"
+DEPEND="virtual/x11"
+RDEPEND="virtual/x11"
+SRC_URI="http://ftp.digital.com/pub/Digital/SRC/x2x/${P}.tar.gz"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ gunzip < ${FILESDIR}/${P}.diff.gz | patch || die "patch failed"
+}
+
+src_compile() {
+ xmkmf
+ cp x2x.1 x2x.man
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ doman x2x.1
+ dodoc ${S}/LICENSE
+}