summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2006-03-25 03:14:31 +0000
committerAron Griffis <agriffis@gentoo.org>2006-03-25 03:14:31 +0000
commit67c1c4dc67ec20da879ae62183558d97152cfe43 (patch)
treea30609a17077376857a5c2addea8d41eb6331587 /x11-misc/xclip/xclip-0.08-r1.ebuild
parentRemove configure to force autotools rebuild (the pic patch changes Makefile.am). (diff)
downloadhistorical-67c1c4dc67ec20da879ae62183558d97152cfe43.tar.gz
historical-67c1c4dc67ec20da879ae62183558d97152cfe43.tar.bz2
historical-67c1c4dc67ec20da879ae62183558d97152cfe43.zip
Install man-page correctly so it's gzipped. Don't install bogus html doc
Package-Manager: portage-2.1_pre5-r4
Diffstat (limited to 'x11-misc/xclip/xclip-0.08-r1.ebuild')
-rw-r--r--x11-misc/xclip/xclip-0.08-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-misc/xclip/xclip-0.08-r1.ebuild b/x11-misc/xclip/xclip-0.08-r1.ebuild
new file mode 100644
index 000000000000..0ab87a4e22fc
--- /dev/null
+++ b/x11-misc/xclip/xclip-0.08-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xclip/xclip-0.08-r1.ebuild,v 1.1 2006/03/25 03:14:31 agriffis Exp $
+
+S=${WORKDIR}/xclip
+DESCRIPTION="Command-line utility to read data from standard in and place it in an X selection for pasting into X applications."
+SRC_URI="http://people.debian.org/~kims/xclip/${P}.tar.gz"
+HOMEPAGE="http://people.debian.org/~kims/xclip/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="|| ( (
+ x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXext )
+ virtual/x11 )"
+DEPEND="${RDEPEND}
+ || ( ( x11-proto/xproto
+ app-text/rman
+ x11-misc/imake )
+ virtual/x11 )"
+
+src_compile() {
+ xmkmf || die
+ make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ make DESTDIR=${D} MANPATH=/usr/share/man MANSUFFIX=1 \
+ install.man || die
+ rm -f ${D}/usr/lib/X11/doc/html/*
+ find ${D} -type d -depth | xargs -n1 rmdir 2>/dev/null
+ dodoc README CHANGES
+}