summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-11-02 10:25:15 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-11-02 10:25:15 +0000
commit4750cbc2b119a38792c4885fd210a48e78054188 (patch)
tree4a5d12c3e751807897f41664868c92de8f5c2970 /x11-misc/xgestures/xgestures-0.4.ebuild
parentInitial commit wrt bug #217337. Thanks to Michał Kiedrowicz for first versio... (diff)
downloadhistorical-4750cbc2b119a38792c4885fd210a48e78054188.tar.gz
historical-4750cbc2b119a38792c4885fd210a48e78054188.tar.bz2
historical-4750cbc2b119a38792c4885fd210a48e78054188.zip
Initial commit wrt bug #217337. Thanks to Michał Kiedrowicz for first version of ebuild
Package-Manager: portage-2.2.0_alpha141/cvs/Linux x86_64
Diffstat (limited to 'x11-misc/xgestures/xgestures-0.4.ebuild')
-rw-r--r--x11-misc/xgestures/xgestures-0.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-misc/xgestures/xgestures-0.4.ebuild b/x11-misc/xgestures/xgestures-0.4.ebuild
new file mode 100644
index 000000000000..62d75a2c90c0
--- /dev/null
+++ b/x11-misc/xgestures/xgestures-0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xgestures/xgestures-0.4.ebuild,v 1.1 2012/11/02 10:25:10 pinkbyte Exp $
+
+EAPI=4
+
+DESCRIPTION="A mouse gesture recognition program for X11 desktops"
+HOMEPAGE="http://www.cs.bgu.ac.il/~tzachar/xgestures.html"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXmu
+ x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_install() {
+ default
+ newdoc .gestures gestures
+}
+
+pkg_postinst()
+{
+ elog "Unpack /usr/share/doc/${PF}/gestures* and copy it to \$HOME/.gestures"
+}