summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-06-05 10:08:06 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-06-05 10:08:06 +0000
commit185460209122f411bfca4a45f01f7b0a6f6d1dae (patch)
tree51bb3b148ca580d24066dfd332856bb1d47f561f /x11-misc
parentChange binary installation path wrt bug #283322 (diff)
downloadhistorical-185460209122f411bfca4a45f01f7b0a6f6d1dae.tar.gz
historical-185460209122f411bfca4a45f01f7b0a6f6d1dae.tar.bz2
historical-185460209122f411bfca4a45f01f7b0a6f6d1dae.zip
Make python improvements wrt bug #317017
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/icewmcp/ChangeLog9
-rw-r--r--x11-misc/icewmcp/Manifest3
-rw-r--r--x11-misc/icewmcp/icewmcp-3.2-r2.ebuild63
3 files changed, 72 insertions, 3 deletions
diff --git a/x11-misc/icewmcp/ChangeLog b/x11-misc/icewmcp/ChangeLog
index 94985638258b..3a008da58e3f 100644
--- a/x11-misc/icewmcp/ChangeLog
+++ b/x11-misc/icewmcp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/icewmcp
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/icewmcp/ChangeLog,v 1.10 2007/02/21 23:45:45 jokey Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/icewmcp/ChangeLog,v 1.11 2010/06/05 10:08:06 hwoarang Exp $
+
+*icewmcp-3.2-r2 (05 Jun 2010)
+
+ 05 Jun 2010; Markos Chandras <hwoarang@gentoo.org> +icewmcp-3.2-r2.ebuild:
+ Make python improvements wrt bug #317017
21 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/x11-misc/icewmcp/Manifest b/x11-misc/icewmcp/Manifest
index ef9aaf7ef64e..434eab3a1990 100644
--- a/x11-misc/icewmcp/Manifest
+++ b/x11-misc/icewmcp/Manifest
@@ -1,4 +1,5 @@
DIST IceWMControlPanel-3.2.tar.bz2 586044 RMD160 8637ae5f4b28c2a7a8187dd9f02e6317c6ff925f SHA1 13dcea63146123342cf8c384675fce37a161a184 SHA256 6259d27b5de151049b245cac17606ba77d055766ef1706363dc301085c925af9
EBUILD icewmcp-3.2-r1.ebuild 2453 RMD160 e58d35dd9215672d9f6e098fcae51f0904e2ebfd SHA1 493b23765a202a3a8084dcd0b3aa50127dc82f75 SHA256 faef91d2f50a2d4383da2eab146808ac04cd26e62899784ddbf43807c9934ec2
-MISC ChangeLog 1401 RMD160 404f456bfb8eafb299bf1826e97f71b282e0995c SHA1 f9840b53c29d52483e58de9507ee5c4dd1402a05 SHA256 b4e1623e47609ce799a49ef84ad9b41f091716bc4712ab105b78e246d17b3df2
+EBUILD icewmcp-3.2-r2.ebuild 2548 RMD160 35dbf7ec94488c53a03b709de36bd22d41c3a6a7 SHA1 43b70c37b5b2eb23633daa5044663abd0a66ea5b SHA256 7e837b0b817581996393eb93f3624bd89d9b0e119060e9aeb68a6931ed87eb42
+MISC ChangeLog 1556 RMD160 bcc3a75dc2e003bfd6149d1bfad007b35c1726e8 SHA1 5c602ee6dedae3627a432ee6cbd77fcefa1c2df8 SHA256 0197b4433eb005632103358285008c0f76256a3ca71f31b5aa16c03123a16aa3
MISC metadata.xml 166 RMD160 7b80226659bf40e97050b1ffce1858d5f20b3c60 SHA1 e6c6436c304a65b4a012a5b7be7ee264b228a645 SHA256 8e7de0a7f7c15840474de373a3ce36adcc5dd658b2e4d18366fcb63b964a0826
diff --git a/x11-misc/icewmcp/icewmcp-3.2-r2.ebuild b/x11-misc/icewmcp/icewmcp-3.2-r2.ebuild
new file mode 100644
index 000000000000..6b08181031a5
--- /dev/null
+++ b/x11-misc/icewmcp/icewmcp-3.2-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/icewmcp/icewmcp-3.2-r2.ebuild,v 1.1 2010/06/05 10:08:06 hwoarang Exp $
+
+PYTHON_DEPEND="2"
+
+inherit python multilib
+
+S=${WORKDIR}/INSTALL-IceWMCP
+MY_PN=IceWMControlPanel
+MY_DEST="usr/$(get_libdir)/${P}"
+MY_BIN="usr/bin"
+
+DESCRIPTION="A complete control panel for IceWM using gtk & python"
+HOMEPAGE="http://icesoundmanager.sourceforge.net/index.php"
+SRC_URI="mirror://sourceforge/icesoundmanager/${MY_PN}-${PV}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+DEPEND="x11-wm/icewm
+ >=dev-python/pygtk-1.99
+ >=x11-libs/gtk+-2.0.0"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ dodir "${MY_DEST}/"
+ dodir "${MY_BIN}/"
+ dodoc "${S}"/doc/* "${S}"/licenses/*
+ cp "${S}"/* "${D}"/${MY_DEST}
+ cp -R "${S}"/applets "${S}"/applet-icons "${S}"/help "${S}"/icons \
+ "${S}"/locale "${S}"/pixmaps "${D}"/${MY_DEST}/
+ # create executable shortcuts to the python scripts
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCP.py" > ${T}/IceWMCP
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCPKeyboard.py" > ${T}/IceWMCP-Keyboard
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCPMouse.py" > ${T}/IceWMCP-Mouse
+ echo -e "#!/bin/bash \n python /${MY_DEST}/pyspool.py" > ${T}/IceWMCP-PySpool
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCPWallpaper.py" > ${T}/IceWMCP-Wallpaper
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCPWinOptions.py" > ${T}/IceWMCP-WinOptions
+ echo -e "#!/bin/bash \n python /${MY_DEST}/phrozenclock.py" > ${T}/PhrozenClock
+ echo -e "#!/bin/bash \n python /${MY_DEST}/icesound.py" > ${T}/IceSoundManager
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCP_GtkPCCard.py" > ${T}/GtkPCCard
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceMe.py" > ${T}/iceme
+ echo -e "#!/bin/bash \n python /${MY_DEST}/icepref.py" > ${T}/icepref
+ echo -e "#!/bin/bash \n python /${MY_DEST}/icepref_td.py" > ${T}/icepref_td
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCPGtkIconSelection.py" > ${T}/IceWMCP-Icons
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCPEnergyStar.py" > ${T}/IceWMCP-EnergyStar
+ dobin "${T}"/*
+}
+
+pkg_postinst() {
+ einfo "Some of the icons displayed by IceWMCP may be pointing to"
+ einfo "programs which are not on your system! You can hide them"
+ einfo "using the Configuration window (Ctrl+C) or change them"
+ einfo "by editing the files in"
+ einfo "/${MY_DEST}/applets and"
+ einfo "/${MY_DEST}/applet-icons."
+}