summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-05-06 00:08:17 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-05-06 00:08:17 +0000
commit5e80cffcf4c8af3fe96a8ae68b7f0ad87d184e87 (patch)
treed2cc1618d6b60c5d04b0dfb626e0658223a87a02 /x11-misc
parentkeyword ~amd64-fbsd (diff)
downloadhistorical-5e80cffcf4c8af3fe96a8ae68b7f0ad87d184e87.tar.gz
historical-5e80cffcf4c8af3fe96a8ae68b7f0ad87d184e87.tar.bz2
historical-5e80cffcf4c8af3fe96a8ae68b7f0ad87d184e87.zip
add live-ebuild, reorganize global scope, remove old
Package-Manager: portage-2.2.0_alpha101/cvs/Linux x86_64
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/compton/ChangeLog9
-rw-r--r--x11-misc/compton/compton-0_pre20120316.ebuild57
-rw-r--r--x11-misc/compton/compton-0_pre20120330.ebuild16
-rw-r--r--x11-misc/compton/compton-9999.ebuild35
4 files changed, 47 insertions, 70 deletions
diff --git a/x11-misc/compton/ChangeLog b/x11-misc/compton/ChangeLog
index 0bd13e513743..2c105c3a8582 100644
--- a/x11-misc/compton/ChangeLog
+++ b/x11-misc/compton/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/compton
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/compton/ChangeLog,v 1.3 2012/05/05 04:53:45 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/compton/ChangeLog,v 1.4 2012/05/06 00:08:17 hasufell Exp $
+
+*compton-9999 (06 May 2012)
+
+ 06 May 2012; Julian Ospald <hasufell@gentoo.org>
+ -compton-0_pre20120316.ebuild, compton-0_pre20120330.ebuild,
+ +compton-9999.ebuild:
+ add live-ebuild, reorganize global scope, remove old
05 May 2012; Jeff Horelick <jdhore@gentoo.org> compton-0_pre20120316.ebuild,
compton-0_pre20120330.ebuild:
diff --git a/x11-misc/compton/compton-0_pre20120316.ebuild b/x11-misc/compton/compton-0_pre20120316.ebuild
deleted file mode 100644
index 752473a122cc..000000000000
--- a/x11-misc/compton/compton-0_pre20120316.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/compton/compton-0_pre20120316.ebuild,v 1.2 2012/05/05 04:53:45 jdhore Exp $
-
-EAPI=4
-
-unset _live_inherits
-
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="git://github.com/chjj/compton.git"
- _live_inherits="git-2"
-else
- KEYWORDS="~amd64 ~x86"
- SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.xz"
-fi
-
-inherit toolchain-funcs ${_live_inherits}
-
-DESCRIPTION="A compositor for X, and a fork of xcompmgr-dana"
-HOMEPAGE="http://github.com/chjj/compton"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE=""
-
-COMMON_DEPEND="x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXdamage
- x11-libs/libXfixes
- x11-libs/libXrender"
-RDEPEND="${COMMON_DEPEND}
- app-shells/bash
- x11-apps/xprop
- x11-apps/xwininfo"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- x11-proto/xproto"
-
-src_prepare() {
- sed -i \
- -e '/^CFLAGS/s/=/+=/' \
- -e '/$(LIBS)$/s/$(CC)/$(CC) $(LDFLAGS)/' \
- -e 's/`pkg-config --libs $(PACKAGES)`/$(shell pkg-config --libs $(PACKAGES))/' \
- -e 's/`pkg-config --cflags $(PACKAGES)`/$(shell pkg-config --cflags $(PACKAGES))/' \
- Makefile || die
-}
-
-src_compile() {
- tc-export CC
- emake
-}
-
-src_install() {
- dobin ${PN} bin/settrans
- doman man/${PN}.1
- dodoc README.md
-}
diff --git a/x11-misc/compton/compton-0_pre20120330.ebuild b/x11-misc/compton/compton-0_pre20120330.ebuild
index 72d7e43eb6f6..153dd9d3c0ea 100644
--- a/x11-misc/compton/compton-0_pre20120330.ebuild
+++ b/x11-misc/compton/compton-0_pre20120330.ebuild
@@ -1,26 +1,18 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/compton/compton-0_pre20120330.ebuild,v 1.2 2012/05/05 04:53:45 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/compton/compton-0_pre20120330.ebuild,v 1.3 2012/05/06 00:08:17 hasufell Exp $
EAPI=4
-unset _live_inherits
-
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="git://github.com/chjj/compton.git"
- _live_inherits="git-2"
-else
- KEYWORDS="~amd64 ~x86"
- SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.xz"
-fi
-
-inherit toolchain-funcs ${_live_inherits}
+inherit toolchain-funcs
DESCRIPTION="A compositor for X, and a fork of xcompmgr-dana"
HOMEPAGE="http://github.com/chjj/compton"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.xz"
LICENSE="MIT"
SLOT="0"
+KEYWORDS="~amd64 ~x86"
IUSE=""
COMMON_DEPEND="x11-libs/libX11
diff --git a/x11-misc/compton/compton-9999.ebuild b/x11-misc/compton/compton-9999.ebuild
new file mode 100644
index 000000000000..97df746d14dc
--- /dev/null
+++ b/x11-misc/compton/compton-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/compton/compton-9999.ebuild,v 1.1 2012/05/06 00:08:17 hasufell Exp $
+
+EAPI=4
+
+inherit toolchain-funcs git-2
+
+DESCRIPTION="A compositor for X, and a fork of xcompmgr-dana"
+HOMEPAGE="http://github.com/chjj/compton"
+SRC_URI=""
+
+EGIT_REPO_URI="git://github.com/chjj/compton.git"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+COMMON_DEPEND="x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ x11-libs/libXrender"
+RDEPEND="${COMMON_DEPEND}
+ app-shells/bash
+ x11-apps/xprop
+ x11-apps/xwininfo"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ x11-proto/xproto"
+
+pkg_setup() {
+ tc-export CC
+}