summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2005-12-06 02:40:57 +0000
committerJory Pratt <anarchy@gentoo.org>2005-12-06 02:40:57 +0000
commitf23324b212a90372a67ac64a5adacecf6d70cb5d (patch)
treebd375baf1b43e2174c965404191a58392e43b446 /x11-plugins/enigmail
parentdelete buggy version, #84142 (diff)
downloadhistorical-f23324b212a90372a67ac64a5adacecf6d70cb5d.tar.gz
historical-f23324b212a90372a67ac64a5adacecf6d70cb5d.tar.bz2
historical-f23324b212a90372a67ac64a5adacecf6d70cb5d.zip
initial import to the tree for >=mozilla-thunderbird-1.5_rc1
Package-Manager: portage-2.0.53
Diffstat (limited to 'x11-plugins/enigmail')
-rw-r--r--x11-plugins/enigmail/ChangeLog11
-rw-r--r--x11-plugins/enigmail/Manifest7
-rw-r--r--x11-plugins/enigmail/enigmail-0.93.1.ebuild131
-rw-r--r--x11-plugins/enigmail/files/50_enigmail_no_upgrade.patch17
-rw-r--r--x11-plugins/enigmail/files/70_enigmail-fix.patch11
-rw-r--r--x11-plugins/enigmail/files/digest-enigmail-0.93.13
-rw-r--r--x11-plugins/enigmail/files/firefox-1.1-visibility.patch22
-rw-r--r--x11-plugins/enigmail/metadata.xml11
8 files changed, 213 insertions, 0 deletions
diff --git a/x11-plugins/enigmail/ChangeLog b/x11-plugins/enigmail/ChangeLog
new file mode 100644
index 000000000000..1e6e0ff8e487
--- /dev/null
+++ b/x11-plugins/enigmail/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-plugins/enigmail
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/enigmail/ChangeLog,v 1.1 2005/12/06 02:40:57 anarchy Exp $
+
+*enigmail-0.93.1 (06 Dec 2005)
+
+ 06 Dec 2005; Jory A. Pratt <anarchy@gentoo.org>
+ +files/firefox-1.1-visibility.patch, +files/50_enigmail_no_upgrade.patch,
+ +files/70_enigmail-fix.patch, +metadata.xml, +enigmail-0.93.1.ebuild:
+ initial import for >=1.5_rc1 thunderbird
+
diff --git a/x11-plugins/enigmail/Manifest b/x11-plugins/enigmail/Manifest
new file mode 100644
index 000000000000..690c792c7f00
--- /dev/null
+++ b/x11-plugins/enigmail/Manifest
@@ -0,0 +1,7 @@
+MD5 581bbdccfff09ea4fe86a88c7ddcf71a ChangeLog 488
+MD5 05901c77a7e603f74cd04ead1e8c2831 enigmail-0.93.1.ebuild 4017
+MD5 f6da2f617f170f8bbc915d81d7588fa1 files/50_enigmail_no_upgrade.patch 633
+MD5 6bbab0286558a86eb8175fb601b43678 files/70_enigmail-fix.patch 343
+MD5 a9e5f97457fe82c26106daa0a6e17677 files/digest-enigmail-0.93.1 208
+MD5 cc5756b8c7af5c88b248b86c73fc5c8d files/firefox-1.1-visibility.patch 930
+MD5 d048ab0ca56f9151afdebcff86b18438 metadata.xml 303
diff --git a/x11-plugins/enigmail/enigmail-0.93.1.ebuild b/x11-plugins/enigmail/enigmail-0.93.1.ebuild
new file mode 100644
index 000000000000..6e515f7957f1
--- /dev/null
+++ b/x11-plugins/enigmail/enigmail-0.93.1.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/enigmail/enigmail-0.93.1.ebuild,v 1.1 2005/12/06 02:40:57 anarchy Exp $
+
+unset ALLOWED_FLAGS # stupid extra-functions.sh ... bug 49179
+inherit flag-o-matic toolchain-funcs eutils nsplugins mozcoreconf makeedit multilib
+
+EMVER=${PV}
+TBVER="1.5rc1"
+IPCVER="1.1.3"
+
+DESCRIPTION="Gnupg encryption plugin for thunderbird."
+HOMEPAGE="http://www.enigmail.mozdev.org"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/${TBVER}/source/thunderbird-${TBVER}-source.tar.bz2
+ http://www.mozilla-enigmail.org/downloads/src/enigmail-${EMVER}.tar.gz
+ http://downloads.mozdev.org/enigmail/src/ipc-${IPCVER}.tar.gz "
+
+KEYWORDS="-*"
+SLOT="0"
+LICENSE="MPL-1.1 NPL-1.1"
+IUSE=""
+
+DEPEND=">=mail-client/mozilla-thunderbird-1.5_rc1"
+RDEPEND="${DEPEND}
+ >=app-crypt/gnupg-1.4
+ >=www-client/mozilla-launcher-1.37"
+
+S=${WORKDIR}/mozilla
+
+# Needed by src_compile() and src_install().
+# Would do in pkg_setup but that loses the export attribute, they
+# become pure shell variables.
+export BUILD_OFFICIAL=1
+export MOZILLA_OFFICIAL=1
+export MOZ_CO_PROJECT=mail
+
+src_unpack() {
+ unpack ${A} || die "unpack failed"
+ cd ${S} || die "cd failed"
+
+ epatch ${FILESDIR}/firefox-1.1-visibility.patch
+
+ # Unpack the enigmail plugin
+ for x in ipc enigmail; do
+ mv ${WORKDIR}/${x} ${S}/extensions || die "mv failed"
+ cd ${S}/extensions/${x} || die "cd failed"
+ makemake # from mozconfig.eclass
+ done
+ cd ${S}
+
+ # Use the right theme for thunderbird #45609
+ sed -i -ne '/^enigmail-skin.jar:$/ { :x; n; /^\t/bx; }; p' extensions/enigmail/ui/jar.mn
+
+ # Don't allow upgrades via the browser
+ epatch ${FILESDIR}/50_enigmail_no_upgrade.patch
+
+ # Fix installation of enigmail.js
+ epatch ${FILESDIR}/70_enigmail-fix.patch
+}
+
+src_compile() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/mozilla-thunderbird
+
+ ####################################
+ #
+ # mozconfig, CFLAGS and CXXFLAGS setup
+ #
+ ####################################
+
+ mozconfig_init
+
+ # tb-specific settings
+ mozconfig_annotate '' \
+ --with-default-mozilla-five-home=${MOZILLA_FIVE_HOME} \
+ --with-user-appdir=.thunderbird
+
+ # Finalize and report settings
+ mozconfig_final
+
+ # hardened GCC uses -fstack-protector-all by default, and this breaks
+ # thunderbird
+ has_hardened && append-flags -fno-stack-protector-all
+ replace-flags -fstack-protector-all -fstack-protector
+
+ ####################################
+ #
+ # Configure and build Thunderbird
+ #
+ ####################################
+
+ econf || die "econf failed"
+
+ # This removes extraneous CFLAGS from the Makefiles to reduce RAM
+ # requirements while compiling
+ edit_makefiles
+
+ # Only build the parts necessary to support building enigmail
+ emake -j1 export || die "make export failed"
+ emake -C modules/libreg || die "make modules/libreg failed"
+ emake -C xpcom/string || die "make xpcom/string failed"
+ emake -C xpcom || die "make xpcom failed"
+ emake -C xpcom/obsolete || die "make xpcom/obsolete failed"
+
+ # Build the enigmail plugin
+ einfo "Building Enigmail plugin..."
+ emake -C extensions/ipc || die "make ipc failed"
+ emake -C extensions/enigmail || die "make enigmail failed"
+
+ # Package the enigmail plugin; this may be the easiest way to collect the
+ # necessary files
+ emake -j1 -C extensions/enigmail xpi || die "make xpi failed"
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/mozilla-thunderbird
+ declare emid
+
+ cd ${T}
+ unzip ${S}/dist/bin/*.xpi install.rdf
+ emid=$(sed -n '/<em:id>/!d; s/.*\({.*}\).*/\1/; p; q' install.rdf)
+
+ dodir ${MOZILLA_FIVE_HOME}/extensions/${emid}
+ cd ${D}${MOZILLA_FIVE_HOME}/extensions/${emid}
+ unzip ${S}/dist/bin/*.xpi
+
+ # these files will be picked up by mozilla-launcher -register
+ dodir ${MOZILLA_FIVE_HOME}/{chrome,extensions}.d
+ insinto ${MOZILLA_FIVE_HOME}/chrome.d
+ newins ${S}/dist/bin/chrome/installed-chrome.txt ${PN}
+ echo "extension,${emid}" > ${D}${MOZILLA_FIVE_HOME}/extensions.d/${PN}
+}
diff --git a/x11-plugins/enigmail/files/50_enigmail_no_upgrade.patch b/x11-plugins/enigmail/files/50_enigmail_no_upgrade.patch
new file mode 100644
index 000000000000..572b4dcc1664
--- /dev/null
+++ b/x11-plugins/enigmail/files/50_enigmail_no_upgrade.patch
@@ -0,0 +1,17 @@
+This patch is from Debian's enigmail-0.91 patch set
+
+--- mozilla/extensions/enigmail/ui/content/enigmailMessengerOverlay.xul.orig 2004-11-08 23:34:04.000000000 +0000
++++ mozilla/extensions/enigmail/ui/content/enigmailMessengerOverlay.xul 2004-11-08 23:35:20.000000000 +0000
+@@ -159,10 +159,12 @@
+ </menu>
+
+ <menuseparator/>
++ <!--
+ <menuitem id="enigmail_upgrade"
+ label="&enigmail.upgrade.label;"
+ accesskey="&enigmail.upgrade.accesskey;"
+ oncommand="EnigUpgrade();" />
++ -->
+
+ <menuitem id="enigmail_help"
+ label="&enigmail.help.label;"
diff --git a/x11-plugins/enigmail/files/70_enigmail-fix.patch b/x11-plugins/enigmail/files/70_enigmail-fix.patch
new file mode 100644
index 000000000000..0acf0c8760ed
--- /dev/null
+++ b/x11-plugins/enigmail/files/70_enigmail-fix.patch
@@ -0,0 +1,11 @@
+--- mozilla/extensions/enigmail/package/Makefile.in 14 Mar 2004 16:39:18 -0000 1.73
++++ mozilla/extensions/enigmail/package/Makefile.in 20 Mar 2004 18:20:08 -0000
+@@ -48,6 +48,8 @@
+
+ XPIDLSRCS = nsIEnigmail.idl
+
++PREF_JS_EXPORTS=prefs/enigmail.js
++
+ include $(topsrcdir)/config/rules.mk
+
+ XPIFILE = $(XPI_MODULE)-$(XPI_MODULE_VERS).xpi
diff --git a/x11-plugins/enigmail/files/digest-enigmail-0.93.1 b/x11-plugins/enigmail/files/digest-enigmail-0.93.1
new file mode 100644
index 000000000000..218dd5ebd57f
--- /dev/null
+++ b/x11-plugins/enigmail/files/digest-enigmail-0.93.1
@@ -0,0 +1,3 @@
+MD5 d0de6d3968dc6a38e60578d6cf9098fd enigmail-0.93.1.tar.gz 405011
+MD5 64ba4c6e3b52568468c4f6680ec7e679 ipc-1.1.3.tar.gz 102593
+MD5 0df70073cc6ac9f6772f82bc9e024543 thunderbird-1.5rc1-source.tar.bz2 35022501
diff --git a/x11-plugins/enigmail/files/firefox-1.1-visibility.patch b/x11-plugins/enigmail/files/firefox-1.1-visibility.patch
new file mode 100644
index 000000000000..e0665fe742b4
--- /dev/null
+++ b/x11-plugins/enigmail/files/firefox-1.1-visibility.patch
@@ -0,0 +1,22 @@
+Index: configure
+===================================================================
+RCS file: /cvsroot/mozilla/configure,v
+retrieving revision 1.1443
+diff -u -p -6 -r1.1443 configure
+--- configure 2 Jun 2005 04:00:20 -0000 1.1443
++++ configure 6 Jun 2005 07:34:06 -0000
+@@ -7303,13 +7303,13 @@ else
+ int foo_default = 1;
+ EOF
+ ac_cv_visibility_pragma=no
+ if ${CC-cc} -Werror -S conftest.c -o conftest.s >/dev/null 2>&1; then
+ if grep '\.hidden.*foo_hidden' conftest.s >/dev/null; then
+ if ! grep '\.hidden.*foo_default' conftest.s > /dev/null; then
+- ac_cv_visibility_pragma=yes
++ ac_cv_visibility_pragma=no
+ fi
+ fi
+ fi
+ rm -f conftest.cs
+
+ fi
diff --git a/x11-plugins/enigmail/metadata.xml b/x11-plugins/enigmail/metadata.xml
new file mode 100644
index 000000000000..4a9afb0c7d03
--- /dev/null
+++ b/x11-plugins/enigmail/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>mozilla</herd>
+<maintainer>
+ <email>anarchy@gentoo.org</email>
+</maintainer>
+<longdescription>
+Gnupg encryption plugin for thunderbird.
+</longdescription>
+</pkgmetadata>