summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Vasilevski <yvasilev@gentoo.org>2006-03-13 00:29:15 +0000
committerYuri Vasilevski <yvasilev@gentoo.org>2006-03-13 00:29:15 +0000
commit3c331edac9880598cfc9c833c647df152301a7f9 (patch)
tree56d8f9a258688c59e9bb2600ba13e2d48ea550b1 /x11-plugins/matchbox-applet-startup-monitor/matchbox-applet-startup-monitor-0.1.ebuild
parentX is implicit (diff)
downloadhistorical-3c331edac9880598cfc9c833c647df152301a7f9.tar.gz
historical-3c331edac9880598cfc9c833c647df152301a7f9.tar.bz2
historical-3c331edac9880598cfc9c833c647df152301a7f9.zip
- Initial import. Original ebuild by Priit Laes, modifications by Björn Ruberg and Yuri Vasilevski.
Package-Manager: portage-2.1_pre6
Diffstat (limited to 'x11-plugins/matchbox-applet-startup-monitor/matchbox-applet-startup-monitor-0.1.ebuild')
-rw-r--r--x11-plugins/matchbox-applet-startup-monitor/matchbox-applet-startup-monitor-0.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-plugins/matchbox-applet-startup-monitor/matchbox-applet-startup-monitor-0.1.ebuild b/x11-plugins/matchbox-applet-startup-monitor/matchbox-applet-startup-monitor-0.1.ebuild
new file mode 100644
index 000000000000..ef9e1a5dd32d
--- /dev/null
+++ b/x11-plugins/matchbox-applet-startup-monitor/matchbox-applet-startup-monitor-0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2006-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/matchbox-applet-startup-monitor/matchbox-applet-startup-monitor-0.1.ebuild,v 1.1 2006/03/13 00:26:46 yvasilev Exp $
+
+inherit versionator
+
+MY_PN=${PN/matchbox/mb}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Startup notification matchbox panel tray app."
+HOMEPAGE="http://projects.o-hand.com/matchbox/"
+SRC_URI="http://projects.o-hand.com/matchbox/sources/${MY_PN}/$(get_version_component_range 1-2)/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/libmatchbox-1.5
+ x11-libs/startup-notification"
+
+RDEPEND="${DEPEND}
+ x11-wm/matchbox-panel"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf || die "Configuration failed"
+
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "Installation failed"
+
+ dodoc AUTHORS Changelog INSTALL NEWS README
+}